Index.html not working?

Hi all!

I’ve been using Netlify for a while, but I’m a bit puzzled and out of ideas for something that seems super simple.
I set up a new site, all static HTML, but it doesn’t seem to pick up the index.html.
The site is:
And as you can see, it has an index.html:

Here’s the very simple repo:

This is a new site, created from scratch, I haven’t added any configuration to it.

Any clues?

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!

Thanks for the link, it looked promising.
But alas, neither solutions helped.

This zip has index.html at the root:
Screenshot from 2020-04-22 17-10-10

And I didn’t have the publish directory set (I don’t have it in my other sites that work either), but even after setting it to /, it still doesn’t work.

Any other clues?

can you post a screenshot of your build settings, please?

Yeap, here it is (after editing the / out again)

what is the netlify site name, also? thanks.

so if i pull up that link, everything works perfectly - it is not a build settings issue:

this is telling us that it is an issue with the way your custom domain is set up and pointing at your netlify account :muscle:

so, this is a dns issue not a build settings issue. is there anything obvious in your dns settings that can explain why this isn’t working?

if you only just set it up, it can take up to 48 hours for DNS changes to propagate.

That’s interesting!

I doesn’t work for me:

I tried that as well, so I assumed it wasn’t DNS or anything funky. Now it’s even more of a mystery…
I opened an incognito tab to make sure I wasn’t picking up any caching.

I’m not redirecting DNS to netlify, I’m using an A record, but that seems to be working given it’s hitting netlify?

Have you tried clearing your browser cache? Have you tried visiting your site with GTMetrix or Browserstack? If everyone else is seeing the site but you, then the problem is local to your machine / network.

hey @beuno - i also see it loading under the domain, what are you seeing?

Thank you all, it was DNS because it eventually worked.

1 Like