Increase function timeout

Hi,

I’d like to increase the timeout on my site: sensorfield-dashboard

Thanks for the help!

Eli

Hi, @EliLauff. The functions timeout has been increased for that site. Note, a new deploy of the functions is required for the new timeout to take effect.

If there are other questions or concerns, please let us know.

Thank you for the help!

Hi @luke, when using netlify dev I sometimes run into an error output:

“errorMessage”:“Task timed out after 10.00 seconds”,“errorType”:“TimeoutError”

Will increasing the functions timeout allow the timeout in the dev environment to be increased? If not, is there something I can do to increase it? Thanks

Apologies for any inconvenience - I found a solution here:

I just changed the value for timeoutMs to 26*1000 and all is working as expected! Thank you.

1 Like

@EliLauff You may also like to know that we’ve recently released Background Functions, which can run for up to 15 minutes without requesting any special settings changes. To deploy a function to run as a background function with the extended timeout, add -background to the function file name.

Thank you for the help!

did you end up looking into background functions, @EliLauff?

if yes (or even if no) we’d love to hear what your thoughts are as they are relatively new and insight from our customers is really valuable to us.

1 Like