Hugo uglyurl option

I’m using Hugo and trying to use the uglyURL option. I have it working locally using uglyurl=true in my config and running “hugo server”, but when deployed to Netlify, it doesn’t work. I tried HUGO_UGLYURLS like described here https://github.com/gohugoio/hugo/issues/4343 but that doesn’t seem to work either with Netlify. Any ideas? I’m trying to add .html to the end of all urls.

I also tried --uglyURLs=true in the build command per hugo docs, but that results in an ‘unknown flag’ error.

The issue was Pretty Urls was enabled under asset optimization

thank you for sharing your solution! This is definitely helpful for other users :+1: