How to verificate the email?

Hi, i install the netlify widget, invite the user, and send the mail.
After i get the token https://jolly-darwin-b062ff.netlify.com/#recovery_token=3jUCVktNPdLNyqpwZFIDKw

And i get “Email not confirmed”

How to resolve that?

Hi! Welcome to the community forum.

It seems like the invite is sending you to your homepage, where the identity widget is not active. You can solve this in two ways:

  1. Add the identity widget to your homepage <head>. Upside of this method is that it’s fast and easy, no other configuration needed. The downside is that all of your users are downloading the widget while they might not need it. That’s kb’s wasted.
  2. Change the invitation emails! This takes a bit more time, but in my opinion it’s the cleanest way. You already have the identity widget loaded at your admin/ page, so it makes sense to have your users confirm their email there. You can read how to do that here.

Thanks. I will try later.

Actually, since I have them lying around anyway and everyone enjoys a good copy pasting party, here are the right templates for your use case:

confirmation.html

<h2>Confirm your signup</h2>

<p>Follow this link to confirm your user:</p>
<p><a href="{{ .SiteURL }}/admin/#confirmation_token={{ .Token }}">Confirm your mail</a></p>

recovery.html

<h2>Reset Password</h2>

<p>Follow this link to reset the password for your user:</p>
<p><a href="{{ .SiteURL }}/admin/#recovery_token={{ .Token }}">Reset Password</a></p>

invitation.html

<h2>You have been invited</h2>

<p>You have been invited to create a user on {{ .SiteURL }}. Follow this link to accept the invite:</p>
<p><a href="{{ .SiteURL }}/admin/#invite_token={{ .Token }}">Accept the invite</a></p>

email-change.html

<h2>Confirm Change of Email</h2>

<p>Follow this link to confirm the update of your email from {{ .Email }} to {{ .NewEmail }}:</p>
<p><a href="{{ .SiteURL }}/admin/#email_change_token={{ .Token }}">Change Email</a></p>

Thanks a lot, i am in))
Just must to specify, that the paths to the files for templates in settings myst be “/admin/filename”, and you didn’t write me about that, and for the first time i write “/static/admin/filename” - and that was the wrong way))

Where to put the files in order for them to get build depends entirely on the static site generator you’re using :wink: