How to remove the cached redirect file in netlify follow up

Had posted this earlier here How to remove the cached redirect file in netlify. Posting again for more visibility as stated in the above issue by Perry.

An old redirect file has been cached and doesn’t seem to go away even when a new file has been updated. I have even tried clearing cache and deploying which didn’t help.

We still get 4 invalid redirect rules even when these rules don’t exist in the redirect file anymore.

I did go through this documentation


Nowhere in there is any information regarding this scenario.

I’ve even created a branch deleting the redirect file to see if the ‘invalid rules’ error will go away. But the error still persisted even when there was no redirect file. So it’s very weird that an old file has been cached in netlify build’s and I even tried to download the zip files of the deploy to see which redirect file it has but it throws an “Error during download” error always. Tried it multiple times on different builds.

Hey, do you have a link to your repo at all, if it’s public? I suspect that you need to double-check what you’re uploading :slight_smile:

Hey Pie,

All my repo’s are private. Is there any other detail I can provide?

And also, why do the invalid rules appear even when I deleted the redirect file?

Hi!
I’m facing the same problem. I 100% removed language based redirects from netlify.toml (had negative perfomance effect) and cleared cache but redirects still happen.
I downloaded deploy zip-file and netlify.toml there is without these redirects. Also deploy summary says “6 redirect rules processed”, before it was 8.
Maybe some time needed to change netlify server behaviour?

Hmm, interesting! Okay, would you please be able to provide an x-nf-request-id for a request that shouldn’t be redirected, please? You can follow these steps: