How to force Netlify to use PHP Transliterator class during deploy?

Hi

I have a PHP static site builder (Jigsaw) and everything works fine.

Today I added a call to the Transliterator::transliterate() method and got the following error during my deply:

PHP Fatal error:  Uncaught Error: Class 'Transliterator' not found in /opt/build/repo/listeners/GenerateIndex.php:36

How can I make Netlify pull in that core PHP class during my deploy?

My local builds run just fine.

I already have my PHP_VERSION set to 7.2 and the Transliterator class has been part of core since PHP 7.0.

Thanks
Eric

Not sure if we have that support built in though I do understand your assertion that it is part of core.

I guess my first questino is can you successfully use it, if you run locally in our build image? https://github.com/netlify/build-image#running-locally

There, you can also try poking around a bit to see if different invocations work better, or maybe establish if our installation seems to be broken in a way that you can elaborate on a bit further - either of which could be the case (or it could be something else :)). Not many folks use PHP in our build environment so there may be a bug or bad config lurking and you’re the first to notice.