How to fix Acme::Client::Error: Order's status ("valid")?

Hey folks,
I got an email a few weeks while back mentioning how “Failed to renew TLS certificate for kelset.dev”.

When I open the linked page (/settings/domain#https) of my website on Netlify, it shows this error message

"Acme::Client::Error: Order’s status (“valid”) is not acceptable for finalization

We can’t renew your Let’s Encrypt certificate automatically until the issue is resolved. Check our troubleshooting guide for more information on how to fix the problem, and then renew the certificate."

And tbh I have no idea what I should be doing to fix a valid order status - the Troubleshooting guide doesn’t give any direct actionables for it.
What should I do?

LMK
cheers
Lorenzo

Hi, @kelset, the error message shown is just the last error that occurred. It is not a current error.

The SSL certificate was updated on June 10th (which is probably when the email was sent). It was renewed a short time later.

If there are other questions or concerns, please let us know.

hey @luke thanks for clarifying - so the error is still shown even if the problem is fixed? Or there’s something else that I need to do on my side? (I’m asking simply because I can also see that the certificate will expire on Sept 8th and I want to make sure I know how to renew it then)

As soon as I saw this, I knew it was this. It’s nothing to worry about! But, if the transient error worries you, drop your custom domain in that topic and we can remove the warning :smile:!

Awesome, thanks @Pieparker! Done :wink:

1 Like