How to edit html templates etc? always bugs,

i Just started to edit my test page using Kaldi templates.

I did try to delete my logo througg my github directory.

tree/master/src/img

and there i have got 2 files (logo + gitgub image)

when i trying to change the logo or when i try to delete a logo i cant to deploy it. Where is the problem ?

: error #85909 GRAPHQL
2:39:39 PM: Field "image" must not have a selection since type "String" has no subfields
2:39:39 PM: File: src/templates/product-page.js:214:19
2:39:39 PM: See our docs page for more info on this error: https://gatsby.dev/issue-how-to
2:39:39 PM: npm
2:39:39 PM:  ERR! code ELIFECYCLE
2:39:39 PM: npm
2:39:39 PM: ERR! errno 1
2:39:39 PM: npm
2:39:39 PM: ERR! gatsby-starter-netlify-cms@1.1.3 build: `npm run clean && gatsby build`
2:39:39 PM: npm ERR! Exit status 1
2:39:39 PM: npm
2:39:39 PM:  ERR!
2:39:39 PM: npm ERR! Failed at the gatsby-starter-netlify-cms@1.1.3 build script.
2:39:39 PM: npm ERR!
2:39:39 PM:  This is probably not a problem with npm. There is likely additional logging output above.
2:39:39 PM: npm
2:39:39 PM:  ERR! A complete log of this run can be found in:
2:39:39 PM: npm ERR!     /opt/buildhome/.npm/_logs/2019-11-18T13_39_39_438Z-debug.log
2:39:39 PM: Function Dir: /opt/build/repo/lambda
2:39:39 PM: TempDir: /tmp/zisi-5dd29ed32597f6c9475d64fa

hi @jasa2 - welcome to the Netlify community. I moved your question because it is more CMS related. That said, the error you are seeing is not a netlify specific one, but a gatsby error, as your templates are not getting parsed correctly.

Have you tried testing your project to see if it builds locally? my assumption is that it won’t. We definitely have some gatsby pros around - maybe @jlengstorf can weigh in - but you also get better information for this specific thing from some of the gatsby support folks :muscle:

Hey there! This error happens because the example product relies on them. If Gatsby can’t find the images, the page generation fails.

See this section for details: https://github.com/netlify-templates/gatsby-starter-netlify-cms/blob/master/src/pages/products/index.md#L54-L62

If you change an image, make sure to replace any reference to it in the codebase.

Hope that helps!

1 Like

thx for help

I don’t really understand what I’m supposed to change.
I use a github and not a local computer.

For example. I enter here (in my own repo) https://github.com/netlify-templates/gatsby-starter-netlify-cms/blob/master/src/img/logo.svg and edit the logo.svg file.

I insert my own created logo also in svg format. And I’m changing only that. I don’t understand why an error is is appearing. What else can I do to change this logo?

I am surprised that such a seemingly simple task causes me a problem…

@jasa2, are you renaming the logo in the process?

If the file location or name changes, any other references to the old file in the code would need to be changed to the new path and/or filename.

For example, in these two places:

https://github.com/netlify-templates/gatsby-starter-netlify-cms/blob/master/src/components/Footer.js#L4
https://github.com/netlify-templates/gatsby-starter-netlify-cms/blob/master/src/components/Navbar.js#L4

Or is the new file the same filename and path? If so, would you please send us a URL for the deploy from the Netlify UI?

This would be a URL in the format https://app.netlify.com/sites/<SITE_NAME>/deploys/<DEPLOY_ID>

Also, if there are other questions about this, please let us know.

I intentionally did not change the name of the logo. I just uploaded a new one for testing. Thanks for your commitment and help.

https://app.netlify.com/sites/nervous-chandrasekhar-20e4bf/deploys/5dd29ab680c01f0007d15ca2
https://app.netlify.com/sites/nervous-chandrasekhar-20e4bf/deploys/5dd29c3854f35200084e4bed
https://app.netlify.com/sites/nervous-chandrasekhar-20e4bf/deploys/5dd29af2c0f8e40007acf534
https://app.netlify.com/sites/nervous-chandrasekhar-20e4bf/deploys/5dd29ed32597f6c9475d64fa
https://app.netlify.com/sites/nervous-chandrasekhar-20e4bf/deploys/5dd2850f403ee0000733ad10

I have the exact same issue, and uncoincidentally, it started happening on exactly the same day (November 19). I couldn’t reproduce it locally at first, but after upgrading all packages and clearing caches and such, there it is:

Field “publicationLogo” must not have a selection since type “String” has no subfields
Field “image” must not have a selection since type “String” has no subfields

The first commit this happened on was an update of a single .md file, but it happens now even if that file is removed, and across all pages in my project.

I’m no JS expert, but is there a way to see what dependencies might have been updated on that day?

1 Like

…interesting…

even though I am a total noob, I discovered a mistake … eh

Would someone mind sharing a public repository that reproduces this issue?

Isn’t this one?

https://app.netlify.com/sites/gatsby-starter-netlify-cms-ci/deploys

Solved this issue. See here: https://github.com/gatsbyjs/gatsby/issues/19748

Downgrade and lock gatsby at 2.17.16 for now to fix. (npm i gatsby@2.17.16 --save --save-exact)

1 Like

Thank you so much for that follow-up, Jon! Really appreciate your sleuthing there.

Perhaps a very stupid question.
how to do it from my netlify panel (I have a free account only) .
Will this command automatically repair an existing website or do I have to rebuild it?

I mean, I already have a website. And i want to follow this command. How do I log in to the console?

Hi, @jasa2. You don’t run the command at Netlify. You run the command in your local repo, commit the changes, and then push those changes to the upstream repo.

The push to upstream then triggers a build a Netlify and we’ll clone the newest version of the repo with those changes in it when building the site. If this doesn’t work or if there are other questions, please let us know.

Thanks for the answer. But I’m sorry, I don’t really know how to do it.

I am trained to manage websites but from the server level, e.g. through ssh in linux. And here I don’t know how to approach it. Can you explain me step by step what to do?

Well, he tried already, but I’ll try saying the same instructions in a different way, maybe it will help?

  1. clone a new copy of your repo to your laptop
  2. change to the directory with the checkout
  3. since you use yarn and not npm, run yarn add gatsby@2.17.16
  4. add to git: git add yarn.lock package.json
  5. commit: git commit -m "added specific gatsby version"
  6. push to github: git push

then our build should use that version of gatsby.

1 Like

So i have copy it to my laptop:

i create my new folder , install npm and then: npm i gatsby@2.17.16 --save --save-exact
next i add this comand
git remote add origin https://github.com/myusername/gatsby-starter-netlify-cms.git
then
git push origin master

but I get this kind of error: ! [rejected] master -> master (fetch first)

Hey @jasa2. You don’t need to create a new folder and you’ve done some of the steps in the wrong order.

after you clone the directory you’ll need to change your current working directory. The steps are below. The first step shows you how to change directories.

  1. cd gatsby-starter-netlify-cms... // change to the directory of your projects
  2. npm install // install npm packages
  3. npm i gatsby@2.17.16 --save --save-exact // run the command to change the gatsby package
  4. git push

Hope that helps.

Thanks a lot for your help. I have a lot to learn…

Unfortunately, I think I broke something. I suggested some tips but it looks like I deleted everything I had and replaced it with something else. Check it out. https://github.com/tumitem/gatsby-starter-netlify-cms

Is it possible to somehow undo all these changes to a moment earlier? ;/

It doesn’t look like your repository has any history as shown here: https://github.com/tumitem/gatsby-starter-netlify-cms/commits/master. If the oldest commit isn’t what you’re looking for, you might have to start over from scratch. If you have a copy of your old repository, you might be able to recreate your site using that.