How do I change the version of HUGO used to build my site?

Hello.
I’m building a site based on this forestry template. Here is on my github account
I builds correctly on forestry.io.
You should be able to see the unpublished site on this url.

The console says the site is correctly published.

A nice guy from forestry opened an issue here, discovering the problem of the missing netlify build maybe caused by the version of HUGO used.

I’m n00b, where shall I change it? Can’t find any option in my deploy menu. .

Hi, @vongomben, there is a way! There is documentation about this here:

To summarize, set the HUGO_VERSION environment variable here:

https://app.netlify.com/sites/fluid-networks/settings/deploys#environment-variables

(You can also set that environment variable in netlify.toml if you prefer.)

If changing the Hugo version doesn’t resolve this, please reply anytime and we will keep troubleshooting

Hi Luke.
Thanks for the reply.
I’ve setted the environmental variable to 0.68 and later to 0.71 (the one that forestry build).

Neither of the two are working.

Any more help?

Hey there, that link is to theme.toml. You’ll need to add the version that our build uses in the environment table that Luke linked to or in to netlify.toml. Hope this helps!

yes I’ve done it.
I’ve added the variable in the deploy tab as explained.
I’ve put the link as reference on the version used from the theme’s author.

BTW which version of HUGO does Netlify uses as default?

Anyway, still not working :frowning:

Heya! Our build image includes:

  • Hugo - HUGO_VERSION
    • 0.54 extended (default)
    • Any version installable via binrc

Can you show me a deploy log where you’re trying to build a site with the version you’re specifying?