Hitting problem with CRITICAL: AttributeError: module 'pelican-ert' has no attribute 'register'

Having a problem on building with submodule.

Pelican SSG is used. The pelican plugins are installed as submodule.
When I include some plugins from the plugins directory, those plugins that are not submodule is fine. Those plugins that are also submodule would got problem.

Plugins like pelican-ert


and
similar_posts

would cause built problem.

The error is:

6:57:12 AM: $ make publish
6:57:13 AM: CRITICAL: AttributeError: module ‘pelican-ert’ has no attribute ‘register’
6:57:13 AM: Makefile:78: recipe for target ‘publish’ failed
6:57:13 AM: make: *** [publish] Error 1

Any help would be appreciated.

hmm, can you try clearing the deploy cache and retrying, please?

Tried to clear cache and build again. But still have the same problem. It could be built locally in my desktop.
So pelican-plugins is a submodule, and inside pelican-plugins, pelican-ert and similar_posts are also submodule. The directories of these two modules are empty in my desktop and in the github repo. But it seems Netlify had problem with this setting (submodule on submodule).

The plugin location in GH is: https://github.com/getpelican/pelican-plugins

6:58:49 AM: $ make publish
6:58:49 AM: CRITICAL: AttributeError: module ‘pelican-ert’ has no attribute ‘register’
6:58:49 AM: Makefile:78: recipe for target ‘publish’ failed
6:58:49 AM: make: *** [publish] Error 1
6:58:50 AM: ​
6:58:50 AM: ┌─────────────────────────────┐
6:58:50 AM: │ Build failed │
6:58:50 AM: └─────────────────────────────┘
6:58:50 AM: ​
6:58:50 AM: Error message
6:58:50 AM: Command failed with exit code 2: make publish

Hey @kappa-wingman,

I looked at that repo and I was able to find a similar issue. There seems to be a workaround provided in that issue. Can you let me know if this helps?

I didn’t go with that route as described in GH.

I download the sub-submodules (pelican-ert and similar-post) as submodule in another directory (outside pelican-plugins). Pelican could specify multiple plugins directories, and I could built the website now.

Hey @kappa-wingman,

Interesting! Thank you for the feedback and I’m glad that you managed to resolve this :+1: