Help to debug this

I need advice to debug deploy https://app.netlify.com/sites/stoic-ramanujan-b95e0e/deploys/5e88e7a1bb65cde537eb4967

@HumbleGeek, welcome.

the problem is in here somewhere:

1:01:45 PM: Installing missing commands

1:01:45 PM: Verify run directory

1:01:45 PM: Executing user command: npm run build

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: code ENOENT

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: syscall

1:01:45 PM: open

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: path

1:01:45 PM: /opt/build/repo/package.json

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: errno

1:01:45 PM: -2

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: enoent

1:01:45 PM: ENOENT: no such file or directory, open '/opt/build/repo/package.json'

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: enoent

1:01:45 PM: This is related to npm not being able to find a file.

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: enoent

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: A complete log of this run can be found in:

1:01:45 PM: npm

1:01:45 PM: ERR!

1:01:45 PM: /opt/buildhome/.npm/_logs/2020-04-04T20_01_45_668Z-debug.log

1:01:45 PM: Skipping functions preparation step: no functions directory set

is it possible you don’t have a package.json file?

This Common Issue contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

If you are still having problems, please provide as much information as you can on what you have already tried. Thanks!