Gulp doesn't copy all files

Hello,
im playing with Netlify for the first time. Trying to deploy static website build by my custom gulpfile.js. Everything went ok (almost) and the page is deployed, however one file (package) is missing.

I have in my package.json:

…
"dependencies": {
  "instafeed.js": "^1.4.1",
  "scrollmonitor": "^1.2.3"
},
…

I have in my gulpfile.js:

const config = {
  src: {
    js: {
      vendor: [
        'node_modules/instafeed.js/instafeed.min.js',
        'node_modules/scrollmonitor/scrollmonitor.js',
      ],
    }
  }
} 

…

gulp.task('js:vendor', () => {
  return gulp.src(config.src.js.vendor)
    .pipe($.debug({ title: 'js:vendor-source' }))
    .pipe(gulp.dest(config.dist.js))
    .pipe($.debug({ title: 'js:vendor-result:' }));
});
…

This is what I get in Netlify log:

…
4:55:23 PM: Starting 'js:vendor'...
4:55:23 PM: [14:55:23] Starting 'js'...
4:55:23 PM: [14:55:23] Starting 'images'...
4:55:23 PM: [14:55:23]
4:55:23 PM: Finished 'build' after 517 ms
4:55:24 PM: [14:55:24]
4:55:24 PM: js:vendor-source node_modules/instafeed.js/instafeed.min.js
4:55:24 PM: [14:55:24]
4:55:24 PM: js:vendor-source 1 item
4:55:24 PM: [14:55:24]
4:55:24 PM: Finished 'pug' after 979 ms
4:55:24 PM: [14:55:24]
4:55:24 PM: js:vendor-result: dist/assets/js/instafeed.min.js
4:55:24 PM: [14:55:24]
4:55:24 PM: js:vendor-result: 1 item
4:55:24 PM: [14:55:24]
4:55:24 PM: Finished 'js:vendor' after 506 ms
…

Which means scrollmonitor hasn’t been found by Gulp at all. I checked with cd node_modules/scrollmonitor && ls during the deploy if the package is installed and it is.

Everything works fine locally. Any idea?

Hi,

Can you link the netlify deploy log for one of these builds? Also if the repo is public, I recommend linking it as well.

Hey,
thanks for reply.

Here is the repo (I made it public): https://gitlab.com/mahish/creepy-teepee-netlify/
Here is the log: https://gitlab.com/mahish/creepy-teepee-netlify/blob/master/logs/log-netlify-1.txt

Thanks for checking it out!

Hmm, hard to say. Are you sure you’re using the same versions as us to build? That’s a good place to start when you see discrepancies in behavior vs your local build:

https://www.netlify.com/docs/build-gotchas/ describes how to check your settings and our settings and adjust ours to match yours.

Once you’re synced up, please let us know if things still aren’t working, and what file if any is missing from yoru final deploy. Deploy logs like these show versions in use but the article is a must-read to know what you don’t see too :slight_smile:

2:59:52 PM: Now using node v10.16.0 (npm v6.9.0)

Oh, so the case sensivitity was the issue. Real scrollMonitor.js file vs scrollmonitor.js in my gulpfile. Thanks for pointing me to the doc page. Ive read it already but didnt notice the issue. My bad. Thanks!