GSuite Email Stopped working after moving DNS to Netlify

My domain (curiouslycory.com) was purchased at godaddy a while back and set up to work with my gsuite account. I decided to set up my website at netlify and moved the DNS over. The netlify domain works great for the website, but email has stopped working. I’ve double/tripple checked all of my DNS settings, and can’t seem to receive any emails:

$dig results look good, can’t post the results though because only one image allowed and only 6 links. lol

Hi, @CuriouslyCory, we can troubleshoot the DNS records, but not the email service itself as we don’t host it.

I am seeing all the records above being returned when requested. Maybe there are other record required which are missing?

I used this tool from Google here to check the DNS configuration:

https://toolbox.googleapps.com/apps/checkmx/check?domain=curiouslycory.com&dkim_selector=

This shows DKIM, DMARC, and SPF records are missing. Would you please try adding those at Netlify and let us know if that helps?

Luke.
Most of those records aren’t required or even possible to set up in this situation, but I did manage to get it figured out. I had to add the address as an alias to my inbox again for some reason. Once I did that, the mail started coming through right away.

Thank you!

Thank you for sharing the solution. :+1:

@CuriouslyCory I have recently stumbled into this exact issue.

Would you be so kind as to clarify your solution a little further? When you mention address, does this refer to the email address?

Thank you :slight_smile:

@CuriouslyCory, please disregard the post above. I’ve managed to get this sorted.

Just going to document some notes here for anybody who arrives at this thread and requires more information.

Context:
I had an email address and domain from GSuite, but I opted to host my site with Netlify.

Problem:
Once I started pointing my domain name to Netlify, my previously working email address could no longer receive emails. I could still send them, though.

Solution:

  1. Go to Netlify > Settings > Domain Management
  2. Click on the Options dropdown and follow the link to Go to DNS Panel
  3. In the DNS Settings section, add the Google-specific records, which you can find here
  4. Save changes

Screenshot of the MX records (from the link, above) so you know what you’re looking for:

1 Like