"GLIBCXX_3.4.22' not found" error when using Parcel2

I’m using “parcel”: “^2.0.0-alpha.3.2”

I tried switching my build image to Trusty. The error changed to “Error: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.23’ not found (required by /opt/build/repo/node_modules/@parcel/watcher/build/Release/watcher.node)”

I’m not sure why Parcel thinks it needs to watch files…

This seems related: https://github.com/parcel-bundler/watcher/issues/18

"I was able to work around this problem on Ubuntu by installing a newer version of the standard C library from the ubuntu-toolchain-r/test PPA. After doing that, Parcel was able to run without errors. "

Hi @jessehattabaugh, could you try adding npm rebuild && to the beginning of your build command and see if that helps? This will rebuild any node module that has a binary component. Let me know how that goes.

1 Like

Hey @Dennis, I’m not sure about OP, but I tried to add npm rebuild at the beginning of my build command and it did indeed fix the problem!

In term of optimization, Parcel 2 is really superior to Parcel 1 & Webpack, it feels really good to be able to have simple app built with it on Netlify.

Thank you.