Getting Netlify CMS to work with local backend

I can’t get Netlify CMS to work with local repo. I added a localbackend: true line to config.yml as shown here but whenever I make a change at localhost:8000/admin it changes the file at github, and netlify starts building the site.

What am I doing wrong?
Thanks.

Hi @abdu, can you share your repo?
Are you also running npx netlify-cms-proxy-server on a different terminal window?
Also, the configuration should be local_backend: true and not localbackend: true

1 Like

Thanks @erez

I can’t share the repo but I can share config.yml if that would be helpful?

Yes, I was running proxy server too. Now, I tried again, and cannot login to /admin local or from netlify domain.

I stopped proxy server, removed local_backend line, I disabled and re-enabled git gateway in identity. Still getting these errors:

(both in incognito windows)
local: failed to fetch
netlify: Your Git Gateway backend is not returning valid settings. Please make sure it is enabled.

netlfiy-git-gateway

Hi @abdu, let’s try and focus on one issue, resolve it and move on - I’ll start with the local backend.
Can you share your full config.yml, make sure to have local_backend: true at the top level of the config, run npx netlify-cms-proxy-server is a separate terminal window, then try to load the CMS?
If that doesn’t work, can you please share the network traffic from the browser while doing so?

Once we get that sorted we can move on to git-gateway

1 Like

Hi @erez. Sorry for the late reply.

The mistake I was doing was, putting the local_backend: true line under the backend:. Putting it at the top fixed. Thanks for the help. The documentation may be misleading newbies like myself. netlifycms

1 Like