Getting Error while deploying my GitHub Page

Everything was pretty well since 2,3 weeks .The automatic deployment from my GitHub worked well

Suddenly from last night , updates werent getting automatically published so i tried to deploy it manually but got an error , i tried it 5,6 times even then clear cache and deploy site but to no avail

I hardly did anything to have this error ( just changed 1 ,2 lines of text in the HTML since last night ) , its happening suddenly without any logical reason
Please someone help me out

I am attaching the Deploy Log below -
12:18:07 PM: Build ready to start
12:18:10 PM: build-image version: 9e0f207a27642d0115b1ca97cd5e8cebbe492f63
12:18:10 PM: build-image tag: v3.3.2
12:18:10 PM: buildbot version: 38cc4984170575781fef71bee035f0855939acb8
12:18:10 PM: Fetching cached dependencies
12:18:10 PM: Starting to download cache of 255.0KB
12:18:10 PM: Finished downloading cache in 115.166752ms
12:18:10 PM: Starting to extract cache
12:18:10 PM: Failed to fetch cache, continuing with build
12:18:10 PM: Starting to prepare the repo for build
12:18:10 PM: git ref refs/heads/master does not exist or you do not have permission
12:18:10 PM: Failing build: Failed to prepare repo
12:18:10 PM: failed during stage ‘preparing repo’: git ref refs/heads/master does not exist

Hi @xd003, I recommend that you relink the repo from your site’s deploy settings. Once you’ve done that, if you keep having trouble then provide us with a link to one of your failing deploys. Thanks.