Gatsby-plugin-typography not found

Please:

  • choose at least one appropriate tag for your post (more is better)
  • a short description & what you have tried to fix it (DNS really may take up to 48 hours to propagate.)
  • build log errors, screenshots, etc
  • your Netlify instance name, for example: deluding-chances-2b123.netlify.com

Did you use the search before posting? Yes
What about reading through our https://community.netlify.com/search?q=common%20issue?

I am facing issue with my netlify deploy directly from my linked github gatsbyjs project repository. I get the following error at the online console of netlify when I trigger a deploy…

Executing user command: gatsby build

10:45:22 PM: success open and validate gatsby-configs — 0.017 s

10:45:22 PM: error Unable to find plugin “gatsby-plugin-typography”. Perhaps you need to install its package?

10:45:22 PM:

10:45:22 PM: Error: Unable to find plugin “gatsby-plugin-typography”. Perhaps you need to i nstall its package?

Could you please help me as to how I can fix this gatsby plugin install issues on netlify?
Remember, I am not using netlify-cli nor am I pushing any local (my laptop/terminal) repository to the netlify site. My github repo is directly linked to the Netlify site.

Please let me know.

Thanks,
SJ

hi there, can you share your package.json please?

Hi,

Please find below my package.json file content.

{
  "name": "gatsby-universal",
  "license": "MIT",
  "author": "Fabian Schultz <desk@fabianschultz.com>",
  "scripts": {
    "develop": "gatsby develop",
    "serve": "gatsby serve",
    "ssr": "npm run build && npm run serve",
    "format": "prettier --config ./.prettierrc --write src/**/*.js",
    "build:dir": "mkdirp ./public/icons/",
    "build:favicons": "node scripts/favicons",
    "build": "npm run build:dir && npm run build:favicons && gatsby build",
    "test": "ava **/*.test.js --verbose"
  },
  "greenkeeper": {
    "ignore": [
      "ava",
      "core-js"
    ]
  },
  "dependencies": {
    "@reach/dialog": "^0.2.0",
    "@reach/router": "^1.2.1",
    "@reach/visually-hidden": "^0.1.1",
    "babel-plugin-styled-components": "^1.10.0",
    "gatsby": "^2.3.26",
    "gatsby-image": "^2.0.39",
    "gatsby-plugin-offline": "^2.0.25",
    "gatsby-plugin-react-helmet": "^3.0.12",
    "gatsby-plugin-react-svg": "^2.0.0",
    "gatsby-plugin-sharp": "^2.0.35",
    "gatsby-plugin-sitemap": "^2.0.12",
    "gatsby-plugin-styled-components": "^3.0.7",
    "gatsby-plugin-webpack-size": "^0.0.3",
    "gatsby-source-filesystem": "^2.0.30",
    "gatsby-transformer-json": "^2.1.11",
    "gatsby-transformer-remark": "^2.3.9",
    "gatsby-transformer-sharp": "^2.1.18",
    "intersection-observer": "^0.5.1",
    "prop-types": "^15.6.2",
    "react": "^16.8.6",
    "react-dom": "^16.8.6",
    "react-helmet": "^5.2.0",
    "react-pose": "^4.0.5",
    "styled-components": "^4.1.3"
  },
  "devDependencies": {
    "ava": "^0.25.0",
    "babel-eslint": "^10.0.1",
    "chrome-launcher": "^0.10.5",
    "core-js": "^2.6.2",
    "directory-named-webpack-plugin": "^4.0.0",
    "eslint": "^5.12.1",
    "eslint-config-prettier": "^4.1.0",
    "eslint-loader": "^2.1.1",
    "eslint-plugin-import": "^2.14.0",
    "eslint-plugin-jsx-a11y": "^6.1.2",
    "eslint-plugin-prettier": "^3.0.1",
    "eslint-plugin-react": "^7.12.4",
    "favicons": "^5.3.0",
    "gatsby-plugin-eslint": "^2.0.3",
    "lighthouse": "^4.0.0",
    "mkdirp": "^0.5.1",
    "node-gyp": "^3.8.0",
    "prettier": "^1.16.0"
  }
}

Thanks,
SJ

hi there,

this output:

10:45:22 PM: success open and validate gatsby-configs — 0.017 s

10:45:22 PM: error Unable to find plugin “gatsby-plugin-typography”. Perhaps you need to install its package?

10:45:22 PM:

10:45:22 PM: Error: Unable to find plugin “gatsby-plugin-typography”. Perhaps you need to i nstall its package?

is saying that the gatsby-plugin-typography is needed for your project. But, that isn’t listed in your package.json. You’ll need to add it: