Form responses are empty.!

Hi my netlify form responses are received empty,

Also i receive an empty mail

here is the code,

<form name="join-Prabhat" method="POST" data-netlify="true" data-netlify-recaptcha="true"
                        <div class="form-group">
                            <label>Name of the Parent</label>
                            <input type="text" class="form-control" name="Name of the Parent"
                                placeholder="Enter Parent's name" aria-label="Name of the Parent" required>
                        <div class="form-group">
                            <label>Name of the Student</label>
                            <input type="text" class="form-control" name="Name of the Student"
                                placeholder="Enter student's name" aria-label="Name of the Student" required>
                        <div class="form-group">
                            <label>Institution branch area</label>
                            <input type="text" class="form-control" name="Institution branch area"
                                placeholder="Enter Institution branch area" aria-label="Institution branch area"
                        <div class="form-group">
                            <label>Contact #</label>
                            <input type="tel" class="form-control" name="Contact #"
                                placeholder="your 10 digit mobile no." minlength="10" maxlength="10"
                                autocomplete="off" aria-label="Contact number" required>
                        <div class="form-group">
                            <input type="email" class="form-control" name="Email id" placeholder=""
                                aria-label="e_mail_address" autocomplete="off" required>
                        <div class="form-group">
                            <input type="text" class="form-control" name="Profession"
                                placeholder="Enter your Profession" aria-label="Profession" required>
                        <div class="form-group">
                            <label>Select course</label>
                            <select class="form-control" name="course" aria-label="select course" required="">
                                <option value="Bharatanatyam Dance">Bharatanatyam Dance</option>
                                <option value="Kathak Dance">Kathak Dance</option>
                                <option value="Karnatic Music">Karnatic Music</option>
                        <div class="form-group">
                            <textarea class="form-control" name="Message" placeholder="Enter your message" rows="3"
                                aria-label="message" spellcheck="false" required></textarea>
                        <div data-netlify-recaptcha="true" class="mb-3"></div>
                        <input type="submit" class="btn btn-info1" value="Submit" aria-label="Submit button">

Before doing the below changes it was fine

  1. Added google conversion, analytics and adsense codes
  2. Connected a custom thank you page

Page link of form

Someone, kindly help me


Hello @TenSketch, it looks like the name attributes you gave your input fields have spaces in them. You’ll want to make sure that they don’t have spaces. Once you do that, I think things should work.

That’s not the issue, u meant the


instead of,

name=“Institution branch area”


In my contact form, I have spaces in name fields but it works, but still, I tried removing spaces and added _ but doesn’t work.

Hi @TenSketch, you should only have a single form using the name join_Prabhat. In your built site do you have multiple html files with a form named join_Prabhat? Or do you have any single file with multiple forms named join_Prabhat? This is across all branches. If you define a form named join_Prabhat in production and in staging, and your most recent staging deploy has different field values, then it will overwrite the form definition for production until your next production deploy.

i have one form name


and another named


the 2nd one I’m not using it and mentioned anywhere else, and I’m also not able to delete the 2nd form from netlify dashboard. And it didn’t bother at all!

only the first form is in use!

@TenSketch you have am index.html in /register-form and another index.html in /register, both of these files have forms named join_Prabhat . Can you rename both of these forms so they have unique names then redeploy so we can see which one of them is causing you trouble?

yeah I found it in public directory, deleted the public and generated again and now it is only one

join_Prabhat, but still responses are not fine

Our system is still seeing a form definition without any fields. Could you please check ALL of your files, after building locally, for a second .html file with a form called join_Prabhat without any fields mentioned? Pretty sure there’s one in there somewhere!

I see the correct form at that URL (/join-prabhat/register-form), so I think once you find and remove the other one, things will work better.

In the public folder, there is only one .html file with the form join_Prabhat


In the dashboard, I have another form in a different name which I had b4 but now not able to delete, but that’s not the issue because its a different form name


here is the repo, can you check and let me know, thanks

The other form would not related; we index by name.

We won’t remove a form from your dashboard that was previously deployed unless you ask, even if you make one or one hundred later deploys without it, so that remaining is expected but again not related to things not working with the join_Prabhat form.

Your current deploy has NO form with that name - I just downloaded it and looked.

So I think the problem is that you deployed it once awhile ago in an html file, and that is the definition your current javascript submission uses. Please create an explicit, separate, html file with the definition including all fields that might be submitted via your javascript submission.

I don’t understand, what should I change in the new file? A new form name or any other change in the form code?

You can try a new form name but you need to make sure that the html that contains your form code is included in your publish directory.

u mean the public directory in the rook folder right when u type ‘hugo’ in cmd

Right, for hugo, your static html form will need to either exist in your public/ folder or in your static/ folder (which gets included in your public/ folder at build time.

i changed the form name, removed public folder and generated again, still receiving empty form only. :frowning:
for now, i’m using formspree plugin

Perhaps you had two separate copies of the form with the same name, and one was empty? That would certainly create problems.

Anyway, glad to hear you found a workaround!

Hi friends,

The form is working fine now.

The solution to this issue:
Removed one form from the page (2nd one was the contact form in the footer) and the 1st form (join-Prabhat) worked. As I had already guessed that

Netlify doesn’t accept 2 forms in one page (

Thank you all for your time. Its a bug to be reported to netlify. How to report it? and there has to be delete option for unused forms from the dashboard as it causes confusion.