Flutter web build exits with error due to Dart SDK

How to enforce the Dart SDK version for build?

Deploy: https://app.netlify.com/sites/matikadokapsy/deploys/5ebe9f51c844c007c0859a60

build log:

3:58:51 PM: Running “flutter pub get” in repo…

3:58:52 PM: The current Dart SDK version is 2.6.0-dev.5.0.flutter-d6c6d12ebf.

3:58:52 PM: Because xxxxxx requires SDK version >=2.6.0 <3.0.0, version solving failed.

3:58:52 PM: pub get failed (1)

Hey @radek,

You should be able to update this from “dependencies” within your package.json file. Let me know if this helps!

Actually the reason was that Flutter does not update .metadata files during its upgrades. So everything is correct on the Netlify side.

Resolved. Thanks

1 Like

great, glad its working!