"[feature enabled]: Nitro deploys enabled. Buckle up! ⚡️"

I just noticed this in the logs. What if anything does it mean?

2 Likes

Hi, @carlmjohnson, this means that this build had a new feature enabled. This indicates the build used a new optimization for how files are uploaded when a deploy is finished.

This feature is enabled for all Netlify sites at this time. It is a new feature and this log entry is there to help us know when it is in use.

If there are other questions, please let us know.

1 Like

I also just noticed this but it looks like my build isn’t progressing after this, all the logs are saying is:

10:57:16 AM: [feature enabled]: Nitro deploys enabled. Buckle up! :zap:

10:57:17 AM: Build ready to start

How do I trigger builds with this new feature enabled?

There seems to be some kind of outage with the build system. My builds are all waiting to start as well (status: enqueued or new).

-edit- My build just finished, so it seems resolved. Try rebuilding your site.

@justrmarks and @tomrutgers, it is possible for build to be queued when there is a sharp increase in builds as our build infrastructure scales up to meet demand. (It is elastic in that respect.)

There is more information about this here:

I do agree with @tomrutgers and I can confirm that this wasn’t in any way related to the new feature (and was queuing instead).

I understand, in my experience it just hasn’t taken longer than 45 min before.

@tomrutgers, did it take that long for the build to start? If so, I’ll research why.

@luke Yes sir! I started 4 builds (I have 5 concurrent builds available) between 6.08PM and 6.20PM. Three of them failed after having a new (3x) and enqueued (1x) status, like so:

deploylog

The fourth only started building after the other three had failed at 6.51PM:
Schermafbeelding 2020-03-04 om 11.32.57
Schermafbeelding 2020-03-04 om 11.33.10

Hey Tom, mind giving us the deploy ID for one of the failed ones so we can search our internal logs to understand what might have happened?

Sure thing! https://app.netlify.com/teams/tomrutgers/builds/5e5e8ef1e784de000863105c

Hi, @tomrutgers, we do see an increase in those errors at certain times of day and we’re researching the issue to find out why.

Thanks for looking into it and keeping us posted.

We went allllll the way down the rabbit hole and figured out what was going on.

The issue should now be fixed:

more details here: Bug Fixed: Some builds fail immediately with System Error