Failing build due to too early distribution

Briefly summarize the issues you have been experiencing.

The build is distributed too early and it’s not waiting for the build script to terminated.

I run the same build process for quite a while. It statically generates a nuxt site. Today builds started failing and the process tells me about a missing dist dir.

The interesting thing about this that my build process is not done yet when this error message appears.

Please provide a link to your live site hosted on Netlify

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

This is the problem I’m running into:

6:48:43 PM:              315f4aff7c0a4c8fc364.js   2.44 KiB      24  
6:48:43 PM: 3930bc08068e1c8ebc0bc135dfdddb31.svg   1.87 KiB          
6:48:43 PM: 3d66700af57d696407190ba94a6bc192.svg  516 bytes          
6:48:45 PM: failed during stage 'building site': Deploy directory 'dist' does not exist
6:48:43 PM: 3e3dcd51271da71bcc4da0f751b6bc02.svg  473 bytes          
6:48:43 PM: 3f693b7dbfc631a746fd4f91d4c83ade.svg   1.83 KiB          
6:48:43 PM:              5534243ee3ed661a3a72.js     84 KiB       3  app

As you see it errors right in the middle of the build process. To debug this further I created dist upfront which lead to an empty deploy. The empty folder was distributed (luckily a rollback is very easy on netlify).

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?

Nope.

In case it helps: https://app.netlify.com/sites/stefanjudis/deploys/5d12545e522fdd8e41417b72

Thanks a bunch! :bowing_man:‍♂

Ok the problem was in front of the machine. An error was swallowed. I’m sorry for the noice. :man_facepalming:

1 Like