Failed to compile when deploying react app (works before)

Hello everyone

I tried to deploy my react app after some modifications on it - no breaking changes.
All precedents deploys worked pretty well, but today I’ve got an error. You can find the logs below.

I updated yarn and re-install node modules. Impossible to understand from where the issue comes.
I also build the project locally and then deploy manually the project on another url and it works perfectly.

Any idea?

Many thanks

12:47:02 PM: Build ready to start
12:47:04 PM: build-image version: 342853e31ef590be8195dfbea64bbc4657de7b6b
12:47:04 PM: build-image tag: v3.3.16
12:47:04 PM: buildbot version: 0ffb969a1fc5a7aa9d2a93dd77dd40a990576807
12:47:05 PM: Fetching cached dependencies
12:47:05 PM: Starting to download cache of 254.3KB
12:47:05 PM: Finished downloading cache in 79.992342ms
12:47:05 PM: Starting to extract cache
12:47:05 PM: Failed to fetch cache, continuing with build
12:47:05 PM: Starting to prepare the repo for build
12:47:05 PM: No cached dependencies found. Cloning fresh repo
12:47:05 PM: git clone https://github.com/mehdilouraoui/adp-front
12:47:07 PM: Preparing Git Reference refs/heads/master
12:47:08 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'build' versus 'build/' in the Netlify UI
12:47:08 PM: Starting build script
12:47:08 PM: Installing dependencies
12:47:08 PM: Python version set to 2.7
12:47:09 PM: Downloading and installing node v10.21.0...
12:47:10 PM: Downloading https://nodejs.org/dist/v10.21.0/node-v10.21.0-linux-x64.tar.xz...
12:47:10 PM: Computing checksum with sha256sum
12:47:10 PM: Checksums matched!
12:47:12 PM: Now using node v10.21.0 (npm v6.14.4)
12:47:13 PM: Started restoring cached build plugins
12:47:13 PM: Finished restoring cached build plugins
12:47:13 PM: Attempting ruby version 2.6.2, read from environment
12:47:13 PM: 
12:47:13 PM: ** WARNING **
12:47:13 PM: Using custom ruby version 2.6.2, this will slow down the build.
12:47:13 PM: To ensure fast builds, set the RUBY_VERSION environment variable, or .ruby-version file, to an included ruby version.
12:47:13 PM: Included versions: 2.7.1
12:47:13 PM: 
12:47:14 PM: Required ruby-2.6.2 is not installed - installing.
12:47:14 PM: Searching for binary rubies, this might take some time.
12:47:14 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.6.2.tar.bz2
12:47:14 PM: Checking requirements for ubuntu.
12:47:15 PM: Requirements installation successful.
12:47:15 PM: ruby-2.6.2 - #configure
12:47:15 PM: ruby-2.6.2 - #download
12:47:16 PM: No checksum for downloaded archive, recording checksum in user configuration.
12:47:16 PM: ruby-2.6.2 - #validate archive
12:47:21 PM: ruby-2.6.2 - #extract
12:47:24 PM: ruby-2.6.2 - #validate binary
12:47:25 PM: ruby-2.6.2 - #setup
12:47:25 PM: ruby-2.6.2 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.6.2@global
12:47:25 PM: ruby-2.6.2 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems........................................
12:47:26 PM: ruby-2.6.2 - #generating global wrappers.......
12:47:26 PM: ruby-2.6.2 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.6.2
12:47:26 PM: ruby-2.6.2 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
12:47:26 PM: ruby-2.6.2 - #generating default wrappers.......
12:47:26 PM: Using /opt/buildhome/.rvm/gems/ruby-2.6.2
12:47:27 PM: Using ruby version 2.6.2
12:47:27 PM: Using PHP version 5.6
12:47:27 PM: 5.2 is already installed.
12:47:27 PM: Using Swift version 5.2
12:47:27 PM: Started restoring cached node modules
12:47:27 PM: Finished restoring cached node modules
12:47:27 PM: Started restoring cached yarn cache
12:47:27 PM: Finished restoring cached yarn cache
12:47:27 PM: Installing yarn at version 1.17.0
12:47:27 PM: Installing Yarn!
12:47:27 PM: > Downloading tarball...
12:47:27 PM: [1/2]: https://yarnpkg.com/downloads/1.17.0/yarn-v1.17.0.tar.gz --> /tmp/yarn.tar.gz.ayiytUTcL4
12:47:27 PM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
12:47:27 PM:                                  Dload  Upload   Total   Spent    Left  Speed
12:47:27 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
12:47:28 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
12:47:28 PM: 100    80  100    80    0     0    257      0 --:--:-- --:--:-- --:--:--   257
12:47:28 PM: 100    93  100    93    0     0    144      0 --:--:-- --:--:-- --:--:--   144
12:47:28 PM: 100   630  100   630    0     0    690      0 --:--:-- --:--:-- --:--:--   690
12:47:29 PM:   0 1213k    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
12:47:29 PM: 100 1213k  100 1213k    0     0   901k      0  0:00:01  0:00:01 --:--:-- 7054k
12:47:29 PM: [2/2]: https://yarnpkg.com/downloads/1.17.0/yarn-v1.17.0.tar.gz.asc --> /tmp/yarn.tar.gz.ayiytUTcL4.asc
12:47:29 PM: 100    84  100    84    0     0   3081      0 --:--:-- --:--:-- --:--:--  3081
12:47:29 PM: 100    97  100    97    0     0   1724      0 --:--:-- --:--:-- --:--:--  1724
12:47:29 PM: 100   634  100   634    0     0   7036      0 --:--:-- --:--:-- --:--:--  7036
12:47:29 PM: 100   832  100   832    0     0   6267      0 --:--:-- --:--:-- --:--:--  6267
12:47:29 PM: > Verifying integrity...
12:47:29 PM: gpg: Signature made Fri 14 Jun 2019 06:55:58 PM UTC using RSA key ID 69475BAA
12:47:29 PM: gpg: Good signature from "Yarn Packaging <yarn@dan.cx>"
12:47:29 PM: gpg: WARNING: This key is not certified with a trusted signature!
12:47:29 PM: gpg:          There is no indication that the signature belongs to the owner.
12:47:29 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
12:47:29 PM:      Subkey fingerprint: 6D98 490C 6F1A CDDD 448E  4595 4F77 6793 6947 5BAA
12:47:29 PM: > GPG signature looks good
12:47:29 PM: > Extracting to ~/.yarn...
12:47:29 PM: > Adding to $PATH...
12:47:29 PM: > Successfully installed Yarn 1.17.0! Please open another terminal where the `yarn` command will now be available.
12:47:30 PM: Installing NPM modules using Yarn version 1.17.0
12:47:30 PM: yarn install v1.17.0
12:47:31 PM: [1/4] Resolving packages...
12:47:31 PM: [2/4] Fetching packages...
12:47:56 PM: info fsevents@2.1.3: The platform "linux" is incompatible with this module.
12:47:56 PM: info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
12:47:56 PM: info fsevents@2.1.2: The platform "linux" is incompatible with this module.
12:47:56 PM: info "fsevents@2.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.
12:47:56 PM: info fsevents@1.2.13: The platform "linux" is incompatible with this module.
12:47:56 PM: info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
12:47:56 PM: [3/4] Linking dependencies...
12:47:56 PM: warning " > @testing-library/user-event@7.2.1" has unmet peer dependency "@testing-library/dom@>=5".
12:47:56 PM: warning "react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
12:48:08 PM: [4/4] Building fresh packages...
12:48:09 PM: Done in 39.10s.
12:48:09 PM: NPM modules installed using Yarn
12:48:10 PM: Started restoring cached go cache
12:48:10 PM: Finished restoring cached go cache
12:48:10 PM: Installing Go version 1.12
12:48:16 PM: unset GOOS;
12:48:16 PM: unset GOARCH;
12:48:16 PM: export GOROOT='/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64';
12:48:16 PM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64/bin:${PATH}";
12:48:16 PM: go version >&2;
12:48:16 PM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.12.linux.amd64.env"
12:48:16 PM: go version go1.12 linux/amd64
12:48:16 PM: Installing missing commands
12:48:16 PM: Verify run directory
12:48:17 PM: ​
12:48:17 PM: ┌─────────────────────────────┐
12:48:17 PM: │        Netlify Build        │
12:48:17 PM: └─────────────────────────────┘
12:48:17 PM: ​
12:48:17 PM: ❯ Version
12:48:17 PM:   @netlify/build 2.0.10
12:48:17 PM: ​
12:48:17 PM: ❯ Flags
12:48:17 PM:   deployId: 5eeb462611a0a9aedc7c9ef9
12:48:17 PM:   mode: buildbot
12:48:17 PM: ​
12:48:17 PM: ❯ Current directory
12:48:17 PM:   /opt/build/repo
12:48:17 PM: ​
12:48:17 PM: ❯ Config file
12:48:17 PM:   No config file was defined: using default values.
12:48:17 PM: ​
12:48:17 PM: ❯ Context
12:48:17 PM:   production
12:48:17 PM: ​
12:48:17 PM: ┌────────────────────────────────┐
12:48:17 PM: │ 1. Build command from settings │
12:48:17 PM: └────────────────────────────────┘
12:48:17 PM: ​
12:48:17 PM: $ yarn build
12:48:18 PM: yarn run v1.22.4
12:48:18 PM: $ GENERATE_SOURCEMAP=false react-scripts build
12:48:19 PM: Creating an optimized production build...
12:48:43 PM: 
12:48:43 PM: Treating warnings as errors because process.env.CI = true.
12:48:43 PM: Most CI servers set it automatically.
12:48:43 PM: 
12:48:43 PM: Failed to compile.
12:48:43 PM: 
12:48:43 PM: ./src/components/BottomBar.js
12:48:43 PM:   Line 10:7:   'backToTop' is assigned a value but never used  no-unused-vars
12:48:43 PM:   Line 41:11:  'isFrench' is assigned a value but never used   no-unused-vars
12:48:43 PM: ./src/components/Logo.js
12:48:43 PM:   Line 1:28:  'useState' is defined but never used     no-unused-vars
12:48:43 PM:   Line 2:19:  'useLocation' is defined but never used  no-unused-vars
12:48:43 PM: ./src/App.js
12:48:43 PM:   Line 1:38:  'useRef' is defined but never used  no-unused-vars
12:48:43 PM: ./src/views/InteriorProjectDetailsView.js
12:48:43 PM:   Line 1:46:  'createContext' is defined but never used     no-unused-vars
12:48:43 PM:   Line 4:16:  'useLocation' is defined but never used       no-unused-vars
12:48:43 PM:   Line 6:8:   'LocomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM:   Line 8:8:   'imagesLoaded' is defined but never used      no-unused-vars
12:48:43 PM: ./src/components/Loader.js
12:48:43 PM:   Line 4:10:    'homeAnim' is defined but never used                 no-unused-vars
12:48:43 PM:   Line 4:20:    'langSelectAnim' is defined but never used           no-unused-vars
12:48:43 PM:   Line 4:36:    'navItemsAnim' is defined but never used             no-unused-vars
12:48:43 PM:   Line 6:8:     's' is defined but never used                        no-unused-vars
12:48:43 PM:   Line 7:8:     'Logo' is defined but never used                     no-unused-vars
12:48:43 PM:   Line 10:7:    'Line' is assigned a value but never used            no-unused-vars
12:48:43 PM:   Line 182:7:   'style' is assigned a value but never used           no-unused-vars
12:48:43 PM:   Line 189:11:  'interiorLoaded' is assigned a value but never used  no-unused-vars
12:48:43 PM:   Line 189:27:  'archiLoaded' is assigned a value but never used     no-unused-vars
12:48:43 PM: ./src/views/Agency.js
12:48:43 PM:   Line 4:8:    'LocomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM:   Line 6:8:    'ContactUs' is defined but never used         no-unused-vars
12:48:43 PM:   Line 285:7:  'u' is assigned a value but never used        no-unused-vars
12:48:43 PM: ./src/views/Publications.js
12:48:43 PM:   Line 4:8:   'LocomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM:   Line 5:23:  'moveUpFromTo' is defined but never used      no-unused-vars
12:48:43 PM:   Line 92:9:  'locomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM: ./src/views/Prize.js
12:48:43 PM:   Line 4:8:   'LocomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM:   Line 5:24:  'moveUpFromTo' is defined but never used      no-unused-vars
12:48:43 PM:   Line 91:9:  'locomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM: ./src/views/NewsView.js
12:48:43 PM:   Line 6:8:   'axios' is defined but never used                         no-unused-vars
12:48:43 PM:   Line 8:3:   'fetchPrizesFromBackend' is defined but never used        no-unused-vars
12:48:43 PM:   Line 9:3:   'fetchPublicationsFromBackend' is defined but never used  no-unused-vars
12:48:43 PM:   Line 10:3:  'fetchActusFromBackend' is defined but never used         no-unused-vars
12:48:43 PM: ./src/views/Contact.js
12:48:43 PM:   Line 6:8:  'LocomotiveScroll' is defined but never used  no-unused-vars
12:48:43 PM: ./src/components/GridInterior.js
12:48:43 PM:   Line 9:8:  'BottomBar' is defined but never used  no-unused-vars
12:48:43 PM: error Command failed with exit code 1.
12:48:43 PM: info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
12:48:43 PM: ​
12:48:43 PM: ┌─────────────────────────────┐
12:48:43 PM: │   "build.command" failed    │
12:48:43 PM: └─────────────────────────────┘
12:48:43 PM: ​
12:48:43 PM:   Error message
12:48:43 PM:   Command failed with exit code 1: yarn build
12:48:43 PM: ​
12:48:43 PM:   Error location
12:48:43 PM:   In Build command from settings:
12:48:43 PM:   yarn build
12:48:43 PM: ​
12:48:43 PM:   Resolved config
12:48:43 PM:   build:
12:48:43 PM:     command: yarn build
12:48:43 PM:     publish: /opt/build/repo/build
12:48:43 PM: Caching artifacts
12:48:43 PM: Started saving node modules
12:48:43 PM: Finished saving node modules
12:48:43 PM: Started saving build plugins
12:48:43 PM: Finished saving build plugins
12:48:43 PM: Started saving yarn cache
12:48:43 PM: Finished saving yarn cache
12:48:43 PM: Started saving pip cache
12:48:44 PM: Finished saving pip cache
12:48:44 PM: Started saving emacs cask dependencies
12:48:44 PM: Finished saving emacs cask dependencies
12:48:44 PM: Started saving maven dependencies
12:48:44 PM: Finished saving maven dependencies
12:48:44 PM: Started saving boot dependencies
12:48:44 PM: Finished saving boot dependencies
12:48:44 PM: Started saving go dependencies
12:48:46 PM: Finished saving go dependencies
12:48:49 PM: Cached ruby version 2.6.2
12:48:49 PM: Error running command: Build script returned non-zero exit code: 1
12:48:49 PM: Failing build: Failed to build site
12:48:49 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
12:48:50 PM: Finished processing build request in 1m45.156778388s

Hey there, you’ll want to check out this discussion. Thanks!

@Pie Many thanks for your response!
I’m not sure to understand where I need to update the command line.
I’m currently using the continous deployment. When I push on github, it’s automatically trying to deploy.

Here is my package.json

{
“name”: “adp-front”,
“version”: “0.1.0”,
“private”: true,
“dependencies”: {
@testing-library/jest-dom”: “^4.2.4”,
@testing-library/react”: “^9.3.2”,
@testing-library/user-event”: “^7.1.2”,
“add”: “^2.0.6”,
“axios”: “^0.19.1”,
“dotenv”: “^8.2.0”,
“gh-pages”: “^2.2.0”,
“gsap”: “^3.0.4”,
“html-scribe”: “^1.0.2”,
“imagesloaded”: “^4.1.4”,
“locomotive-scroll”: “^3.4.4”,
“netlify-cli”: “^2.35.0”,
“react”: “^16.12.0”,
“react-dom”: “^16.12.0”,
“react-helmet”: “^5.2.1”,
“react-redux”: “^7.1.3”,
“react-router”: “^5.1.2”,
“react-router-dom”: “^5.1.2”,
“react-scripts”: “3.4.0”,
“react-showdown”: “^2.0.2”,
“react-spring”: “^8.0.27”,
“react-transition-group”: “^4.3.0”,
“react-use”: “^13.27.0”,
“redux”: “^4.0.5”,
“use-measure”: “^0.3.0”,
“yarn”: “^1.22.4”
},
“scripts”: {
“start”: “react-scripts start”,
“predeploy”: “yarn run build”,
“deploy”: “gh-pages -d build”,
“build”: “GENERATE_SOURCEMAP=false react-scripts build”,
“test”: “react-scripts test”,
“eject”: “react-scripts eject”
},
“eslintConfig”: {
“extends”: “react-app”
},
“browserslist”: {
“production”: [
“>0.2%”,
“not dead”,
“not op_mini all”
],
“development”: [
“last 1 chrome version”,
“last 1 firefox version”,
“last 1 safari version”
]
}
}

Hey @m_loura,

If you add CI= to the start of your build commands (either in your netlify.toml or the UI under Build settings), you’ll be set.

However, this is a bandaid for an underlying issue – you should then examine your deploy log for errors and warnings with a view to resolve them!

Many thanks, @Pie !
It’s finally working fine :slight_smile: