Failed deploys on Hugo-themed repo

My Hugo-themed GitHub repo https://github.com/mroberts1/mroberts333 fails to deploy to domain https://mroberts333.net, even though builds successfully locally. There appear to be numerous issues and I don’t know where to start. Any suggestions greatly appreciated.

Local deploys were tested with Hugo 0.72.0, which was also set as Env Variable before Netlify deploy attempts.

Logs for https://github.com/mroberts1/mroberts333 and https://github.com/mroberts1/hugo-archie:

==================================================

  1. Repo: mroberts333

2:34:49 PM: Build ready to start
2:34:54 PM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
2:34:54 PM: build-image tag: v3.3.20
2:34:54 PM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4
2:34:55 PM: Fetching cached dependencies
2:34:55 PM: Failed to fetch cache, continuing with build
2:34:55 PM: Starting to prepare the repo for build
2:34:55 PM: No cached dependencies found. Cloning fresh repo
2:34:55 PM: git clone https://github.com/mroberts1/mroberts333
2:34:56 PM: Preparing Git Reference refs/heads/master
2:34:58 PM: Starting build script
2:34:58 PM: Installing dependencies
2:34:58 PM: Python version set to 2.7
2:35:00 PM: v12.18.0 is already installed.
2:35:01 PM: Now using node v12.18.0 (npm v6.14.4)
2:35:01 PM: Started restoring cached build plugins
2:35:01 PM: Finished restoring cached build plugins
2:35:01 PM: Attempting ruby version 2.7.1, read from environment
2:35:03 PM: Using ruby version 2.7.1
2:35:03 PM: Using PHP version 5.6
2:35:03 PM: 5.2 is already installed.
2:35:03 PM: Using Swift version 5.2
2:35:03 PM: Started restoring cached go cache
2:35:03 PM: Finished restoring cached go cache
2:35:03 PM: go version go1.14.4 linux/amd64
2:35:03 PM: go version go1.14.4 linux/amd64
2:35:03 PM: Installing missing commands
2:35:03 PM: Verify run directory
2:35:05 PM: ​
2:35:05 PM: ┌─────────────────────────────┐
2:35:05 PM: │ Netlify Build │
2:35:05 PM: └─────────────────────────────┘
2:35:05 PM: ​
2:35:05 PM: ❯ Version
2:35:05 PM: @netlify/build 3.0.1
2:35:05 PM: ​
2:35:05 PM: ❯ Flags
2:35:05 PM: deployId: 5f1b29c9e1fec492c8031d42
2:35:05 PM: mode: buildbot
2:35:05 PM: ​
2:35:05 PM: ❯ Current directory
2:35:05 PM: /opt/build/repo
2:35:05 PM: ​
2:35:05 PM: ❯ Config file
2:35:05 PM: No config file was defined: using default values.
2:35:05 PM: ​
2:35:05 PM: ❯ Context
2:35:05 PM: production
2:35:05 PM: ​
2:35:05 PM: ┌───────────────────────────────────┐
2:35:05 PM: │ 1. Build command from Netlify app │
2:35:05 PM: └───────────────────────────────────┘
2:35:05 PM: ​
2:35:05 PM: $ hugo
2:35:05 PM: Building sites … ERROR 2020/07/24 18:35:05 “/opt/build/repo/content/conferences.md:1:1”: duplicate menu entry with identifier “Publications” in menu “publications”
2:35:05 PM: ERROR 2020/07/24 18:35:05 “/opt/build/repo/content/conferences.md:1:1”: duplicate menu entry with identifier “Teaching” in menu “teaching”
2:35:05 PM: ERROR 2020/07/24 18:35:05 “/opt/build/repo/content/conferences.md:1:1”: duplicate menu entry with identifier “Appointments” in menu “appointments”
2:35:05 PM: ERROR 2020/07/24 18:35:05 “/opt/build/repo/content/conferences.md:1:1”: duplicate menu entry with identifier “Awards” in menu “awards”
2:35:06 PM: ERROR 2020/07/24 18:35:06 render of “page” failed: execute of template failed: template: _default/single.html:17:11: executing “main” at <partial "postInfo.ht…>: error calling partial: “/opt/build/repo/themes/anubis/layouts/partials/postInfo.html:8:41”: execute of template failed: template: partials/postInfo.html:8:41: executing “partials/postInfo.html” at <.Params.date.format>: can’t evaluate field format in type interface {}ERROR 2020/07/24 18:35:06 render of “page” failed: execute of template failed: template: _default/single.html:17:11: executing “main” at <partial "postInfo.ht…>: error calling partial: “/opt/build/repo/themes/anubis/layouts/partials/postInfo.html:8:41”: execute of template failed: template: partials/postInfo.html:8:41: executing “partials/postInfo.html” at <.Params.date.format>: can’t evaluate field format in type interface {}ERROR 2020/07/24 18:35:06 render of “page” failed: execute of template failed: template: _default/single.html:17:11: executing “main” at <partial "postInfo.ht…>: error calling partial: “/opt/build/repo/themes/anubis/layouts/partials/postInfo.html:8:41”: execute of template failed: template: partials/postInfo.html:8:41: executing “partials/postInfo.html” at <.Params.date.format>: can’t evaluate field format in type interface {}ERROR 2020/07/24 18:35:06 render of “page” failed: execute of template failed: template: _default/single.html:17:11: executing “main” at <partial "postInfo.ht…>: error calling partial: “/opt/build/repo/themes/anubis/layouts/partials/postInfo.html:8:41”: execute of template failed: template: partials/postInfo.html:8:41: executing “partials/postInfo.html” at <.Params.date.format>: can’t evaluate field format in type interface {}ERROR 2020/07/24 18:35:06 render of “page” failed: execute of template failed: template: _default/single.html:17:11: executing “main” at <partial "postInfo.ht…>: error calling partial: “/opt/build/repo/themes/anubis/layouts/partials/postInfo.html:8:41”: execute of template failed: template: partials/postInfo.html:8:41: executing “partials/postInfo.html” at <.Params.date.format>: can’t evaluate field format in type interface {}Total in 903 ms
2:35:06 PM: Error: Error building site: “/opt/build/repo/content/conferences.md:1:1”: duplicate menu entry with identifier “Service” in menu “service”
2:35:06 PM: ​
2:35:06 PM: ┌─────────────────────────────┐
2:35:06 PM: │ “build.command” failed │
2:35:06 PM: └─────────────────────────────┘
2:35:06 PM: ​
2:35:06 PM: Error message
2:35:06 PM: Command failed with exit code 255: hugo
2:35:06 PM: ​
2:35:06 PM: Error location
2:35:06 PM: In Build command from Netlify app:
2:35:06 PM: hugo
2:35:06 PM: ​
2:35:06 PM: Resolved config
2:35:06 PM: build:
2:35:06 PM: command: hugo
2:35:06 PM: commandOrigin: ui
2:35:06 PM: environment:
2:35:06 PM: - hugo
2:35:06 PM: publish: /opt/build/repo/public
2:35:06 PM: Caching artifacts
2:35:06 PM: Started saving build plugins
2:35:06 PM: Finished saving build plugins
2:35:06 PM: Started saving pip cache
2:35:06 PM: Finished saving pip cache
2:35:06 PM: Started saving emacs cask dependencies
2:35:06 PM: Finished saving emacs cask dependencies
2:35:06 PM: Started saving maven dependencies
2:35:06 PM: Finished saving maven dependencies
2:35:06 PM: Started saving boot dependencies
2:35:06 PM: Finished saving boot dependencies
2:35:06 PM: Started saving go dependencies
2:35:06 PM: Finished saving go dependencies
2:35:15 PM: Error running command: Build script returned non-zero exit code: 1
2:35:15 PM: Failing build: Failed to build site
2:35:15 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
2:35:15 PM: Finished processing build request in 20.456395154s

Hi, @mroberts1, I see the deploy above using the default Hugo version which is 0.54.0.

I do see a more recent successful deploy using 0.74.0. Was updating the Hugo version how you resolved the issue?

The issue is still not resolved. I am completely confused about the Identity tab, accessing CMS admin page, and the documentation doesn’t help. I have a website: mroberts333.net but can’t access the admin page because of some Identity issue. 3 months so far with no successful deploys.

Hi @mroberts1, can you provide more context on what is still not resolved? Has the error message changed? Have you take a look at the errors mentioned ‘duplicate menu entry’ that seems specific to your content. Also, with regards to your confusion, can you elaborate further?

It’s hard to guess what the issue might be. Can you share a link to your netlify site so I can take a look?