Exit Status 128

Briefly summarize the issues you have been experiencing.

I have been getting an exit status 128 error on build.

4:36:04 PM: Waiting to build. Currently running 1 concurrent builds on your account
4:36:05 PM: Build ready to start
4:36:40 PM: build-image version: 9e0f207a27642d0115b1ca97cd5e8cebbe492f63
4:36:40 PM: build-image tag: v3.3.2
4:36:40 PM: buildbot version: ef8d0929ed0baabafd8bbb7d0b021e1fc24180c0
4:36:40 PM: Fetching cached dependencies
4:36:40 PM: Failed to fetch cache, continuing with build
4:36:40 PM: Starting to prepare the repo for build
4:36:41 PM: No cached dependencies found. Cloning fresh repo
4:36:41 PM: git clone https://github.com/escaladesports/victorytailgate.com-gatsby
4:36:53 PM: Error cloning repository: https://github.com/escaladesports/victorytailgate.com-gatsby
4:36:53 PM: failed during stage 'preparing repo': exit status 128
4:36:53 PM: Failing build: Failed to prepare repo
4:36:53 PM: Finished processing build request in 12.915195759s

Please provide a link to your live site hosted on Netlify

https://app.netlify.com/sites/victorytailgate-dev/deploys

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

This is an auth error for sure. It is a private repo and requires 2FA user to be signed in, in order to clone it.

We have the netlify app installed on our github and it has all access to all of our repos.

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?


Hi @tbaustin, and welcome to our community!

Check out #8 on this post and let us know if that info helps: [Common Issue]: Frequently encountered problems during builds

1 Like

I believe this is the step I’m at:

In the other 1% of the cases, there is some OTHER problem cloning your repo - perhaps around Git LFS, Large Media , or some other git-related situation, and in those cases our Support team will have to look in our internal logs to debug things. We’ll still need a link to your deploy logs to do so.

can you post your deploy log please? thanks!

Sure thing it should be there now!

@perry any feedback from the logs that help?

Hi @tbaustin, can you please re-link the repo from https://app.netlify.com/sites/victorytailgate-dev/settings/deploys#build-settings

Also, is the repo part of an organization?

@futuregerald it is part of the organization! I also tried re linking and this did not work. Sorry for the delay in response, it was a busy weekend!

Digging into the internal logs for your deploy, something seems misconfigured. During clone, about 90% of the way through, we get some errors about failed to clone https://some-id.netlify.com which would indeed not be something you could clone.

At first I thought perhaps you had a mistyped submodule or access token in a config file somewhere? You could check this by seeing if you can successfully clone your repo in a new directory, and cd to it, and run: git submodule update -f --init in it.

That might not show the problem depending on how your local authentication is setup if that is the problem.

But upon third review, I found the problem: the ID I mentioned seems to be an LFS pointer.

You have LFS-tracked files in your repo, but you set GIT_LFS_ENABLED to false here https://app.netlify.com/sites/victorytailgate-dev/settings/deploys#environment-variables so that failure is expected. Either remove the LFS assets, or configure us to handle them are your options :slight_smile:

1 Like

Build is not working and can’t see why after changing the env var to true

@fool just getting this:
9:07:09 AM: [ERROR] Deploy logs are currently unavailable. We are working on resolving the issue.

Hello @tbaustin, that error just means that the build logs are temporarily unavailable. If you wait a bit more times, your build logs should be available again. Hopefully that’ll show you the results of enabling that env var. Let us know what you see then.

It’s been pretty much a day and I’m still seeing that same error when I go to the logs however when I look at the deploys I do see a failed during stage 'preparing repo': exit status 2 which is different than before.

https://app.netlify.com/sites/victorytailgate-dev/deploys/5d2f2b7916a7d318f47c7cdc

hi @tbaustin! This is the same cause I mentioned in the helpdesk on July 9th when you wrote in there, and to which you never responded. There, I said this:

From looking at our internal logs, it seems to be something relating to LFS and Large Media. Have you made any changes to the configuration in recent days around either of those two things?

So, same problem is still the cause with this recent deploy you linked, and same question stands :slight_smile:

PS: In the future, please mention that you have dual threads going, so we don’t work on the same issue in parallel - thanks!

@fool completely forgot I had another thread, sorry about that!! I have not made any changes that I know about. Is there something I should be looking for?

Hi @tbaustin,

The issue here is that you have Netlify Large Media setup on that repo for your primary site, and you linked that repo to a second site. A repo that’s connected to one site with large media enabled will not work on another netlify site unless you reconfigure large media to work on that second site (which will mean disabling it for the original site).

The happy path we generally recommend for a staging site while using Netlify Large Media would be to setup a staging branch on that same site, since we’ll deploy all branches and PR’s for you there. This way you can still have dev and staging branches, as well as production, all on the same Netlify site on separate production URL’s.

1 Like

A post was merged into an existing topic: Large File Storage (LFS) / Netlify Large Media (NLM) feature requests