Exclude .webmanifest from password protection

Hi,

I deploy my gatsby website with site-wide password protection, and see site loading much slower on deploy-preview than my localhost after that protection.
Finally, I found “manifest.webmanifest” always returns 401, even after authenticated, and ServiceWorker may not work, I guess.

スクリーンショット 2020-01-21 9.57.36

Then, can we exclude specified URLs from the protection?

My Live Draft URL is here – protected, of course:
https://5e263e6e6448240975bd6e86--je-courses.netlify.com/courses/1306/

Thanks

Hi @y.kato, the site-wide password protection is not configurable in that way. You could, instead, use basic-auth to password protection specific paths on your site what excludes that file.

Thank you. I see. About this issue, cross-origin setting did work.