Error: RootQueryType.allSitePage

Please help for this error in deploy, no changes in app.
Many thanks

Error: RootQueryType.allSitePage field type must be Output Type but got: SiteP ageConnection.

  • Array.forEach
  • Array.reduce
  • index.js:52 _callee$
    [repo]/[gatsby]/dist/schema/index.js:52:20

hi there,

this sounds like a JS error that may be independent of Netlify.

Does this work locally?

If it does and the problem presents itself on deploy, can you share a netlify site name and the full build & deploy log, please? thanks.

Hello Perry
Many thanks, here the information of the site
Only work in Netlify + Github, not locally, the user only change the files *.md
Its possible relation with many version of Graphql, this is a gatsby_app V1_9?
Regards

netlify_
rccclrs’team
zangolotinosclublectura
gatsby_app
deploy_build

10:42:52 AM: Build ready to start
10:42:54 AM: build-image version: 2dbd444fcdce00cf06325060a8238d5ae3e86774
10:42:54 AM: build-image tag: v3.3.7
10:42:54 AM: buildbot version: 93ff258b60dcc6c2c8bb9cfe1ece15d7b4f24193
10:42:54 AM: Fetching cached dependencies
10:42:54 AM: Starting to download cache of 254.9KB
10:42:54 AM: Finished downloading cache in 64.374044ms
10:42:54 AM: Starting to extract cache
10:42:54 AM: Failed to fetch cache, continuing with build
10:42:54 AM: Starting to prepare the repo for build
10:42:55 AM: No cached dependencies found. Cloning fresh repo
10:42:55 AM: git clone https://github.com/rccclr/zangolotinos
10:42:56 AM: Preparing Git Reference refs/heads/master
10:42:57 AM: Starting build script
10:42:57 AM: Installing dependencies
10:42:58 AM: Downloading and installing node v10.20.1…
10:42:59 AM: Downloading https://nodejs.org/dist/v10.20.1/node-v10.20.1-linux-x64.tar.xz…
10:42:59 AM:
###########################
10:42:59 AM: 38.8%
10:42:59 AM:
############################################
10:42:59 AM: ############################ 100.0%
10:42:59 AM: Computing checksum with sha256sum
10:42:59 AM: Checksums matched!
10:43:02 AM: Now using node v10.20.1 (npm v6.14.4)
10:43:02 AM: Attempting ruby version 2.6.2, read from environment
10:43:03 AM: Using ruby version 2.6.2
10:43:04 AM: Using PHP version 5.6
10:43:04 AM: Started restoring cached node modules
10:43:04 AM: Finished restoring cached node modules
10:43:04 AM: Started restoring cached yarn cache
10:43:04 AM: Finished restoring cached yarn cache
10:43:04 AM: Installing yarn at version 1.13.0
10:43:04 AM: Installing Yarn!
10:43:04 AM: > Downloading tarball…
10:43:04 AM: [1/2]: https://yarn
10:43:04 AM: pkg.com/downloads/1.13.0/yarn-v1.13.0.tar.gz
10:43:04 AM: --> /tmp/yarn.tar.gz
10:43:04 AM: .79Bl94ZFii
10:43:04 AM: % Total % Received % Xferd Average Speed Time Time Time Current
10:43:04 AM: Dload U
10:43:04 AM: pload Total Spent Le
10:43:04 AM: ft Speed
10:43:04 AM:
0
10:43:04 AM: 0 0 0 0 0 0 0 --:–:
10:43:04 AM: – --:–:-- --:–:
10:43:04 AM: – 0
10:43:04 AM:
0 0 0 0 0 0
10:43:04 AM: 0 0 --:–:-- --:–:-- --:–:-- 0
10:43:04 AM: 1
10:43:04 AM: 0
10:43:04 AM: 0
10:43:04 AM: 8
10:43:04 AM: 0
10:43:04 AM: 1
10:43:04 AM: 0
10:43:04 AM: 0
10:43:04 AM: 8
10:43:04 AM: 0
10:43:04 AM: 0
10:43:04 AM: 0 260 0 –
10:43:04 AM: :–:-- --:–:-
10:43:04 AM: - --:–:-- 259
10:43:04 AM: 1
10:43:04 AM: 00 9
10:43:04 AM: 3 100 93 0 0 145
10:43:04 AM: 0 --:–:-- --:–:-
10:43:04 AM: - --:-
10:43:04 AM: -:-- 145
10:43:04 AM:
100 630 100 630 0 0 693 0 --:–:-- --:–:-- –
10:43:04 AM: :–:-- 693
10:43:05 AM:
2 1142k 2 33330 0
10:43:05 AM: 0 27377 0 0:00:42 0:00:01 0:00:41 27377
10:43:05 AM:
100 1142k 100 1142k 0 0 852k 0 0:00
10:43:05 AM: :01 0:00:01 --:–:-- 9170k
10:43:05 AM: [2/2]: htt
10:43:05 AM: ps://yarnpkg.com/downloads/1.13.0/yarn-v1.13.0.tar.gz.asc --> /tmp/yarn.tar.gz.79Bl94ZF
10:43:05 AM: ii.asc
10:43:05 AM:
100 84 100 84 0
10:43:05 AM: 0 3035 0 --:–:-- --:–:-- --:–:-- 3035
10:43:05 AM: 1
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 9
10:43:05 AM: 7
10:43:05 AM: 1
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 9
10:43:05 AM: 7
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 1
10:43:05 AM: 7
10:43:05 AM: 5
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: --:-- --:–:--
10:43:05 AM: --:–:-- 1750
10:43:05 AM: 1
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 6
10:43:05 AM: 3
10:43:05 AM: 4
10:43:05 AM: 1
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 6
10:43:05 AM: 3
10:43:05 AM: 4
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: 6
10:43:05 AM: 9
10:43:05 AM: 5
10:43:05 AM: 0
10:43:05 AM: 0
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: :
10:43:05 AM: -
10:43:05 AM: -
10:43:05 AM: 6
10:43:05 AM: 9
10:43:05 AM: 5
10:43:05 AM: 0
10:43:05 AM:
100 832 100 832 0 0 555
10:43:05 AM: 5 0 --:–:-- --:–:-- --:–:-- 5555
10:43:05 AM: > Verifying integrity…
10:43:05 AM: gpg:
10:43:05 AM: Signature made Tue 18 Dec 2018 04:04:55 PM UTC using RSA key ID B6FF4DE3
10:43:05 AM: gpg: Good signature from β€œYarn Packaging yarn@dan.cx”
10:43:05 AM: gpg: Note: This key has expired!
10:43:05 AM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
10:43:05 AM: Subkey fingerprint: E219 30C4 D0A4 AA46 1858 1F7A E074 D16E B6FF 4DE3
10:43:05 AM: > GPG signature looks good
10:43:05 AM: > Extracting to ~/.yarn…
10:43:05 AM: > Adding to PATH... 10:43:06 AM: > Successfully installed Yarn 1.13.0! Please open another terminal where the `yarn` command will now be available. 10:43:06 AM: Installing NPM modules using Yarn version 1.13.0 10:43:07 AM: yarn install v1.13.0 10:43:07 AM: warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json. 10:43:07 AM: [1/4] Resolving packages... 10:43:08 AM: warning gatsby-cli > core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3. 10:43:09 AM: warning gatsby-cli > gatsby-recipes > babel-plugin-add-module-exports > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies. 10:43:09 AM: warning gatsby-cli > gatsby-recipes > babel-plugin-add-module-exports > chokidar > fsevents@1.2.12: fsevents 1 will break on node v14+. Upgrade to fsevents 2 with massive improvements. 10:43:11 AM: [2/4] Fetching packages... 10:43:43 AM: info fsevents@1.1.3: The platform "linux" is incompatible with this module. 10:43:43 AM: info "fsevents@1.1.3" is an optional dependency and failed compatibility check. Excluding it from installation. 10:43:43 AM: info fsevents@1.2.12: The platform "linux" is incompatible with this module. 10:43:43 AM: info "fsevents@1.2.12" is an optional dependency and failed compatibility check. Excluding it from installation. 10:43:43 AM: warning multiyargs@1.0.0: The engine "yargs" appears to be invalid. 10:43:43 AM: [3/4] Linking dependencies... 10:43:43 AM: warning " > @material-ui/core@1.4.0" has unmet peer dependency "react@^16.3.0". 10:43:43 AM: warning " > @material-ui/core@1.4.0" has unmet peer dependency "react-dom@^16.3.0". 10:43:43 AM: warning "@material-ui/core > react-event-listener@0.6.1" has unmet peer dependency "react@^16.3.0". 10:43:43 AM: warning "@material-ui/core > react-jss@8.3.0" has unmet peer dependency "react@>=0.13". 10:43:43 AM: warning "@material-ui/core > react-transition-group@2.2.1" has unmet peer dependency "react@>=15.0.0". 10:43:43 AM: warning "@material-ui/core > react-transition-group@2.2.1" has unmet peer dependency "react-dom@>=15.0.0". 10:43:43 AM: warning "@material-ui/core > recompose@0.27.1" has unmet peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning "@material-ui/core > react-jss > theming@1.3.0" has unmet peer dependency "react@>=0.15". 10:43:43 AM: warning " > @material-ui/icons@1.1.0" has unmet peer dependency "react@^16.3.0". 10:43:43 AM: warning " > @material-ui/icons@1.1.0" has unmet peer dependency "react-dom@^16.3.0". 10:43:43 AM: warning "gatsby > postcss-cssnext@2.11.0" has unmet peer dependency "caniuse-db@^1.0.30000652". 10:43:43 AM: warning "gatsby-cli > gatsby-recipes > babel-loader@8.1.0" has unmet peer dependency "webpack@>=2". 10:43:43 AM: warning "gatsby-cli > gatsby-recipes > babel-plugin-remove-graphql-queries@2.8.3" has incorrect peer dependency "gatsby@^2.0.0". 10:43:43 AM: warning "gatsby-cli > gatsby-recipes > url-loader@1.1.2" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0". 10:43:43 AM: warning "gatsby-plugin-jss > react-jss@7.2.0" has unmet peer dependency "react@>=0.13". 10:43:43 AM: warning "gatsby-transformer-remark > graphql-type-json@0.1.4" has unmet peer dependency "graphql@>=0.4.0". 10:43:43 AM: warning " > react-custom-scrollbars@4.2.1" has unmet peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-custom-scrollbars@4.2.1" has unmet peer dependency "react-dom@^0.14.0 || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-facebook@5.0.3" has unmet peer dependency "react@15.x || 16.x". 10:43:43 AM: warning "react-facebook > react-spinner-children@1.0.8" has unmet peer dependency "react@15.x || 16.x". 10:43:43 AM: warning " > react-headroom@2.2.2" has unmet peer dependency "react@*". 10:43:43 AM: warning " > react-helmet@5.2.0" has unmet peer dependency "react@>=15.0.0". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-core@5.2.2" has unmet peer dependency "react@>= 15.3.0 < 17". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-dom@5.2.2" has unmet peer dependency "react@>= 15.3.0 < 17". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-dom@5.2.2" has unmet peer dependency "react-dom@>= 15.3.0 < 17". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-native@5.2.2" has unmet peer dependency "react@>= 15.3.0 < 17". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-native@5.2.2" has unmet peer dependency "react-native@>= 0.32.0". 10:43:43 AM: warning "react-instantsearch > react-instantsearch-core > algoliasearch-helper@2.26.0" has unmet peer dependency "algoliasearch@>= 3.1 < 4". 10:43:43 AM: warning " > react-lazyload@2.3.0" has unmet peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-lazyload@2.3.0" has unmet peer dependency "react-dom@^0.14.0 || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-loadable-visibility@2.5.0" has unmet peer dependency "react@>=15.4.0". 10:43:43 AM: warning " > react-material-ui-form-validator@2.0.1" has unmet peer dependency "react@^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-material-ui-form-validator@2.0.1" has unmet peer dependency "react-dom@^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-material-ui-form-validator@2.0.1" has unmet peer dependency "prop-types@^15.0.0". 10:43:43 AM: warning "react-material-ui-form-validator > react-form-validator-core@0.4.4" has unmet peer dependency "react@^15.0.0 || ^16.0.0". 10:43:43 AM: warning "react-material-ui-form-validator > react-form-validator-core@0.4.4" has unmet peer dependency "react-dom@^15.0.0 || ^16.0.0". 10:43:43 AM: warning "react-material-ui-form-validator > react-form-validator-core@0.4.4" has unmet peer dependency "prop-types@^15.0.0". 10:43:43 AM: warning " > react-popper@0.10.4" has unmet peer dependency "react@0.14.x || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-popper@0.10.4" has unmet peer dependency "react-dom@0.14.x || ^15.0.0 || ^16.0.0". 10:43:43 AM: warning " > react-redux@5.0.7" has unmet peer dependency "react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0". 10:43:43 AM: warning " > react-share@2.2.0" has unmet peer dependency "react@^0.13.0 || ^0.14.0 || ^15.0.0 || ^16.0.0-0". 10:43:43 AM: warning " > eslint-plugin-graphql@2.1.1" has unmet peer dependency "graphql@^0.12.0 || ^0.13.0". 10:43:43 AM: warning "eslint-plugin-graphql > graphql-config@2.0.1" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0". 10:43:43 AM: warning "eslint-plugin-graphql > graphql-config > graphql-import@0.4.5" has unmet peer dependency "graphql@^0.11.0 || ^0.12.0 || ^0.13.0". 10:44:08 AM: [4/4] Building fresh packages... 10:44:53 AM: success Saved lockfile. 10:44:53 AM: Done in 106.73s. 10:44:54 AM: NPM modules installed using Yarn 10:44:54 AM: Started restoring cached go cache 10:44:54 AM: Finished restoring cached go cache 10:44:54 AM: unset GOOS; 10:44:54 AM: unset GOARCH; 10:44:54 AM: export GOROOT='/opt/buildhome/.gimme/versions/go1.12.linux.amd64'; 10:44:54 AM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:{PATH}";
10:44:54 AM: go version >&2;
10:44:54 AM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
10:44:54 AM: go version go1.12 linux/amd64
10:44:54 AM: Installing missing commands
10:44:54 AM: Verify run directory
10:44:57 AM: Resolved Netlify Build version tag β€œlatest” to β€œ0.3.8”
10:44:57 AM: Netlify Build not installed. Installing Netlify Build version 0.3.8
10:45:16 AM: /opt/buildhome/.nvm/versions/node/v12.16.1/bin/netlify-build -> /opt/buildhome/.nvm/versions/node/v12.16.1/lib/node_modules/@netlify/build/src/core/bin.js
10:45:16 AM: + @netlify/build@0.3.8
10:45:16 AM: added 584 packages from 325 contributors in 18.826s
10:45:17 AM: Starting Netlify Build…
10:45:19 AM: ​
10:45:19 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
10:45:19 AM: β”‚ Netlify Build β”‚
10:45:19 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
10:45:19 AM: ​
10:45:19 AM: ❯ Version
10:45:19 AM: @netlify/build 0.3.8
10:45:19 AM: ​
10:45:19 AM: ❯ Flags
10:45:19 AM: mode: buildbot
10:45:19 AM: ​
10:45:19 AM: ❯ Current directory
10:45:19 AM: /opt/build/repo
10:45:19 AM: ​
10:45:19 AM: ❯ Config file
10:45:19 AM: No config file was defined: using default values.
10:45:19 AM: ​
10:45:19 AM: ❯ Context
10:45:19 AM: production
10:45:19 AM: ​
10:45:19 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
10:45:19 AM: β”‚ 1. build.lifecycle.onBuild command β”‚
10:45:19 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
10:45:19 AM: ​
10:45:19 AM: gatsby build 10:45:23 AM: success delete html and css files from previous builds β€” 0.008 s 10:45:23 AM: success open and validate gatsby-config β€” 0.007 s 10:45:23 AM: success copy gatsby files β€” 0.014 s 10:45:23 AM: success onPreBootstrap β€” 0.893 s 10:45:23 AM: success source and transform nodes β€” 0.428 s 10:45:23 AM: error RootQueryType.allSitePage field type must be Output Type but got: SitePageConnection. 10:45:23 AM: 10:45:23 AM: 10:45:23 AM: Error: RootQueryType.allSitePage field type must be Output Type but got: SiteP ageConnection. 10:45:23 AM: 10:45:23 AM: - Array.forEach 10:45:23 AM: 10:45:23 AM: - Array.reduce 10:45:23 AM: 10:45:23 AM: - index.js:52 _callee
10:45:23 AM: [repo]/[gatsby]/dist/schema/index.js:52:20
10:45:23 AM:
10:45:23 AM:
10:45:23 AM: ​
10:45:23 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
10:45:23 AM: β”‚ Build failed β”‚
10:45:23 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
10:45:23 AM: ​
10:45:23 AM: Error message
10:45:23 AM: Command failed with exit code 1: gatsby build
10:45:23 AM: ​
10:45:23 AM: Error location
10:45:23 AM: In configuration β€œbuild.lifecycle.onBuild” command:
10:45:23 AM: gatsby build
10:45:23 AM: ​
10:45:24 AM: Caching artifacts
10:45:24 AM: Started saving node modules
10:45:24 AM: Finished saving node modules
10:45:24 AM: Started saving yarn cache
10:45:24 AM: Finished saving yarn cache
10:45:24 AM: Started saving pip cache
10:45:24 AM: Finished saving pip cache
10:45:24 AM: Started saving emacs cask dependencies
10:45:24 AM: Finished saving emacs cask dependencies
10:45:24 AM: Started saving maven dependencies
10:45:24 AM: Finished saving maven dependencies
10:45:24 AM: Started saving boot dependencies
10:45:24 AM: Finished saving boot dependencies
10:45:24 AM: Started saving go dependencies
10:45:24 AM: Finished saving go dependencies
10:45:32 AM: Error running command: Build script returned non-zero exit code: 1
10:45:32 AM: Failing build: Failed to build site
10:45:32 AM: failed during stage β€˜building site’: Build script returned non-zero exit code: 1
10:45:32 AM: Finished processing build request in 2m38.311675297s

hey there, can you clarify a little more whether you can run this locally successfully or not?

The gatsby version is a little out of date - 2.20.29 is the current version, so I wonder if there is an issue with some of the dependencies are you trying to use.

You might also try asking in the gatsby community:

to see if they have advice on addressing this specific issue, or migrating to a newer version of gatsby.

Hello Perry

Many thansk for your support.

Its possible in Netlify, before β€œgatsby build” execute the command following?:

For reproduce in local environment, install netlify-cli,and execute: netlify-deploy but show this message, and not finish, its possible send me a link with the steps for reproduce in local?:
Waiting for deploy to go live…

Many thanks

Hello Perry
With this its ok!!
Many thanks

1 Like

great! glad you solved it!!

1 Like