Error "DNS verification failed, domain doesn't appear to be served by Netlify"

My domain settings for jump.run are showing the following error when I’m attempting to verify the DNS configuration for the purposes of generating the Netlify SSL certificate:

**DNS verification failed**
* jump.run doesn't appear to be served by Netlify

I don’t believe this is true. I successfully delegated my DNS to Netlify several days ago. I currently have no A records and the only other relevant records are NETLIFY ones that have been auto-generated:

Name Type Type Value
jump.run 3600 IN NETLIFY
www.jump.run 3600 IN NETLIFY
jump.run 3600 IN NETLIFYv6
www.jump.run 3600 IN NETLIFYv6

When checking any server for ANY records, I get the following:

$ dig jump.run ANY

; <<>> DiG 9.10.6 <<>> jump.run ANY
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2655
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 4, ADDITIONAL: 5

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;jump.run.			IN	ANY

;; ANSWER SECTION:
jump.run.		3600	IN	HINFO	"RFC8482" ""
jump.run.		29747	IN	NS	dns2.p08.nsone.net.
jump.run.		29747	IN	NS	dns1.p08.nsone.net.
jump.run.		29747	IN	NS	dns4.p08.nsone.net.
jump.run.		29747	IN	NS	dns3.p08.nsone.net.

;; AUTHORITY SECTION:
jump.run.		29747	IN	NS	dns1.p08.nsone.net.
jump.run.		29747	IN	NS	dns2.p08.nsone.net.
jump.run.		29747	IN	NS	dns4.p08.nsone.net.
jump.run.		29747	IN	NS	dns3.p08.nsone.net.

;; ADDITIONAL SECTION:
dns1.p08.nsone.net.	85231	IN	A	198.51.44.8
dns2.p08.nsone.net.	85441	IN	A	198.51.45.8
dns3.p08.nsone.net.	85441	IN	A	198.51.44.72
dns4.p08.nsone.net.	85441	IN	A	198.51.45.72

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Mar 01 12:03:59 GMT 2020
;; MSG SIZE  rcvd: 267

Can you please help me understand why I’m receiving this error? Happy to provide any additional detail

You might double-check to see that you have entered the correct Netlify DNS servers for your domain with your registrar.

Fair shout, though I’ve checked them a few times. Currently:

dns1.p08.nsone.net
dns2.p08.nsone.net
dns3.p08.nsone.net
dns4.p08.nsone.net

Good instinct from @gregraven but you had all of that configured correctly, and indeed, nothing you did seems incorrect. Instead, something went wrong with our automagic configuration for the jump.run hostnames: I see we had no DNS “A” record for plain “jump.run” at our DNS service! I got that in place and now the DNS warning is gone, and I think the SSL certificate will arrive shortly.

1 Like

SSL Looks good now. Thanks for the help @fool & @gregraven, on a Sunday no less! :clap::pray:

This is why you get the Big Bucks.

1 Like