Error 403: Forbidden

whenever i try to use the domain i bought (yifanyang.ca) i get back a 403 error: “Forbidden You don’t have permission to access / on this server.”. I already set up the nameservers and it has been more than 24 hours since i updated the nameservers. Everything works fine if I use the domain netlify provided me with: yifanyang.netlify.com

1 Like

Sorry I cant help, but Im having the same issue. :confused:

Did you find a solution somewhere?

Hi, @YifanYang2000. I’m showing that the this domain is using both Netlify DNS and other DNS service:

$ whois yifanyang.ca | grep "Name Server"
Name Server: dns1.p08.nsone.net
Name Server: dns2.p08.nsone.net
Name Server: dns3.p08.nsone.net
Name Server: dns4.p08.nsone.net
Name Server: ns1.domain.com
Name Server: ns2.domain.com
Name Server: dns1.p08.nsone.net
Name Server: dns2.p08.nsone.net
Name Server: dns3.p08.nsone.net
Name Server: dns4.p08.nsone.net
Name Server: ns1.domain.com
Name Server: ns2.domain.com

So, what you see will be affected by which name server answer, Netlify’s or the other service. If I ask one of the Netlify controlled DNS reservers, I get an IP address controlled by Netlify:

$ dig @dns4.p08.nsone.net yifanyang.ca A +noall +answer

; <<>> DiG 9.10.6 <<>> @dns4.p08.nsone.net yifanyang.ca A +noall +answer
; (1 server found)
;; global options: +cmd
yifanyang.ca.		20	IN	A	167.172.221.254

However, if I ask the other DNS service, I get an IP address not controlled by Netlify:

$ dig @ns1.domain.com yifanyang.ca A +noall +answer

; <<>> DiG 9.10.6 <<>> @ns1.domain.com yifanyang.ca A +noall +answer
; (1 server found)
;; global options: +cmd
yifanyang.ca.		3600	IN	A	66.96.162.139

Please remove the other name servers which are not part of the Netlify DNS service to resolve this.

Alternately, if you don’t want to use Netlify DNS, you can still point the custom domain to your Netlify site. To do this, delete the Netlify DNS configuration, remove our NS records for that domain at the registrar, and then use the external DNS instructions below instead:

https://docs.netlify.com/domains-https/custom-domains/configure-external-dns/

If there are other questions about this, please let us know.

Hi, @Maxim, and welcome to our Netlify community site. What is the domain name not working for you with your Netlify site?

If you would prefer to send that by private message (PM), I’ve enabled that for your user. Please keep in mind that PMs get much slower replies than public messages as I will be the only person to see it (as opposed to the whole support team).

Hey @luke thanks for the answer :slightly_smiling_face:

It´s working now, I have no clue what fixed it but yeah… :smile:

The problem I had was that my custom domain maximgehricke.com gave a 403 forbidden error, while the maximgehricke.netlify.com worked fine.

If you know what could have caused this it would be nice to know, otherwise i´d say case closed
:slightly_smiling_face:

1 Like

Hi, @Maxim. I don’t see our CDN serving any 403 responses for this custom domain in the last 30 days.

My best guess is that there were delays in the changes to DNS settings due to the time to live (TTL) values in the previous DNS records. This would mean that the domain was pointing somewhere other than Netlify and that the 403 was coming some other system (meaning not a Netlify system). When the TTLs expired the new records started working and the issue was resolved. Again, this is just my best guess.