DNS records not working

Hi, I have the two following DNS records that do not work, what is the problem please?

Name
    collab.algosphere.org
TTL
    3600 seconds
Type
    NETLIFYv6
Value
    algo-portal.netlify.com

https://collab.algosphere.org/ > Not Found (157.230.103.136)
(targetted website is algo-portal.netlify.com)


Name
    robert.algosphere.org
TTL
    3600 seconds
Type
    A
Value
    149.56.16.106

https://robert.algosphere.org/ > Apache is functioning normally (149.56.16.106 directadmin-ca-1.trusty.network)
(targeted website is https://robertdaoust.org/)

Hi, @algosphere, there is a different answer for each domain name. For the first one with collab, I’ll explain about the record type itself first.

There are two types of DNS records which have a special purpose with Netlify DNS:

  • NETLIFY
  • NETLIFYv6

These two record types are point to IP addresses. The value of the record will show the first site it was linked to but is otherwise cosmetic. It shows the first site the domain name was linked to but doesn’t actually control which site is shown.

The site shown is controlled by the setting: Site Name > Settings > Domain management > Custom domains.

I checked our database and there are no sites currently using that specific domain name (collab.algosphere.org). The DNS record does point to our CDN but, once there, our CDN finds no site using that domain name so it results in a 404 not found.

If you want to delete that record, you may do so but it will then result in a DNS lookup error instead of a not found error. To avoid this, you can add this domain to a new site or you can create an A, AAAA, or CNAME records to replace the deleted NETLIFY record.

Again, if you do add it to a new site, the name in the value won’t change but it will correctly show the new site. Or you can delete it and add it to a new site. That will make a new record which will effectively (if not technically) update the name.

For the robert A record, I show that just working. Netlify is only the DNS service and we don’t control the HTTP response in any way for that subdomain. This is because the A record points to an IP address which Netlify doesn’t control.

Here is the traced DNS lookup using dig below. This is long but the last few lines are the most important:

$ dig robert.algosphere.org +trace

; <<>> DiG 9.10.6 <<>> robert.algosphere.org +trace
;; global options: +cmd
.			11035	IN	NS	l.root-servers.net.
.			11035	IN	NS	i.root-servers.net.
.			11035	IN	NS	m.root-servers.net.
.			11035	IN	NS	k.root-servers.net.
.			11035	IN	NS	c.root-servers.net.
.			11035	IN	NS	b.root-servers.net.
.			11035	IN	NS	f.root-servers.net.
.			11035	IN	NS	e.root-servers.net.
.			11035	IN	NS	h.root-servers.net.
.			11035	IN	NS	g.root-servers.net.
.			11035	IN	NS	d.root-servers.net.
.			11035	IN	NS	j.root-servers.net.
.			11035	IN	NS	a.root-servers.net.
.			11035	IN	RRSIG	NS 8 0 518400 20200627050000 20200614040000 48903 . X99rvhsCJs9RFJ9jF6bDK1OCbjCe+yHe8p1iiZXa7V6cQwcUXDqLZ6GV mfMQPbERaC29Bxr9cYBm5ssEYBZpdOkm75dp/LGBVvfnrZ2sOAIVWOxf 4ZMfWaiqUH1INZVNz160lAxt9F7PuIUbXHBWjzSBGLEN6LY+JSGcpk0l Yr/t2zZLFCj9qruNXJ8nCUrrfJnLGICIOqUaGRWdCYvZbcrzloxv1hSz 14i2b7JVfNXyIMevkLKxEAKSxoChGGcQn8lGJITaqKEyrgnJRkZ1J4U3 EoLyJCR+ThuJ+UXnb52mXURGPVgd6iWBoFEDxmpZ5IT8AolsN7LCLOQS vKbMRw==
;; Received 525 bytes from 8.8.8.8#53(8.8.8.8) in 17 ms

org.			172800	IN	NS	a0.org.afilias-nst.info.
org.			172800	IN	NS	a2.org.afilias-nst.info.
org.			172800	IN	NS	b0.org.afilias-nst.org.
org.			172800	IN	NS	b2.org.afilias-nst.org.
org.			172800	IN	NS	c0.org.afilias-nst.info.
org.			172800	IN	NS	d0.org.afilias-nst.org.
org.			86400	IN	DS	17883 7 1 38C5CF93B369C7557E0515FAAA57060F1BFB12C1
org.			86400	IN	DS	17883 7 2 D889CAD790F01979E860D6627B58F85AB554E0E491FE06515F35548D 1EB4E6EE
org.			86400	IN	RRSIG	DS 8 1 86400 20200628050000 20200615040000 48903 . MUByx2KymiXcAHDKd3O7GsxzdVeUsSPNsAKQBAyVdqf09aQ8GIs5mnIx m+ExxwSfYQmszmLr60vOXf4vIZSGmwwGa1TYk9HIQ9RjluA/pcWtQzJD 58b0XVj2Y0evMBbXjxBL49QRpZwx0y2L8y3OXEK22s/2V6t2JACBuv6C 5HSxuxKBPZ/h3vyOcJ9yi++DZXiYJFKqA3ehq/t0GWxapNUGdW3kGHat pEy/6yd1Orp/X5RiOv1bLtkdGhGisKfQMSEWjmhQTLQaSws1dt85wxce PfJ9Fgvb/tqXyujqwR5d1BTflKegfwzE0pyzBLjVUW/ck6vV8sLYimNM Z0+JuQ==
;; Received 823 bytes from 192.58.128.30#53(j.root-servers.net) in 19 ms

algosphere.org.		86400	IN	NS	dns1.p02.nsone.net.
algosphere.org.		86400	IN	NS	dns2.p02.nsone.net.
algosphere.org.		86400	IN	NS	dns3.p02.nsone.net.
algosphere.org.		86400	IN	NS	dns4.p02.nsone.net.
h9p7u7tr2u91d0v0ljs9l1gidnp90u3h.org. 86400 IN NSEC3 1 1 1 D399EAAB H9PARR669T6U8O1GSG9E1LMITK4DEM0T  NS SOA RRSIG DNSKEY NSEC3PARAM
h9p7u7tr2u91d0v0ljs9l1gidnp90u3h.org. 86400 IN RRSIG NSEC3 7 2 86400 20200706055648 20200615045648 62165 org. lY/jDPpVwJNwwvE+vCvImNnpMLVhliN5p78Sc9uLzTOETSb4ZH5WSg4A xYRmtlh6Q/LlNqUtQTF5A5ZxWL1Ej72zbb2fZwXnOdPgx1gtHBPhlKBE hUzp2wzqPfRLjWOLRkiWEAcQnFianrKLkD4urJ8iDdSa3gPvKHPM0cY2 kl0=
anm97ovr8fgjdpn8lgivqanb134b6vht.org. 86400 IN NSEC3 1 1 1 D399EAAB ANMM2DI0GRE8I1C6M0TL21ELT8GUA1VN  NS DS RRSIG
anm97ovr8fgjdpn8lgivqanb134b6vht.org. 86400 IN RRSIG NSEC3 7 2 86400 20200630152909 20200609142909 62165 org. GlRtI1wRL19C5DJLmmfz+V5NVc5QCORjusI3q/c8yn0zNmau/5ScrjIF onM52+rQLPKy9VsdwyfgDEw392a9urlKoJ4VBf5P+NqIAvH07FtlRY1g yxxGjBKRVYYFwq0dZsuw1woQmkHbTiezLOOHrMxuJlDeBa/v9si+Gi2P 1is=
;; Received 632 bytes from 199.249.112.1#53(a2.org.afilias-nst.info) in 49 ms

robert.algosphere.org.	3600	IN	A	149.56.16.106
;; Received 66 bytes from 198.51.45.66#53(dns4.p02.nsone.net) in 17 ms

This shows that the NS1 DNS server (which Netlify uses for our DNS services) responded for this domain name with the IP address you configured.

If you don’t want this domain to point to that IP address, then delete the A record.

I also get the same IP address a third-party web based DNS lookup:

https://toolbox.googleapps.com/apps/dig/#A/robert.algosphere.org

I think you may want to add the robert domain name to a site under Site Name > Settings > Domain management > Custom domains. Before you can do this, you must delete the A record first. Then create a proxy redirect rule to point that subdomain to https://robertdaoust.org/.

Does that sound like the end goal? To have the browser address bar show robert.algosphere.org but show the content for robertdaoust.org?

If so, add the domain as a custom domain to a site at Netlify (after deleting the A record first) and then use a redirects to proxy this subdomain to the other site.

The rules might look something like this:

https://robert.algosphere.org/      https://robertdaoust.org/          200!
https://rebort.algosphere.org/*    https://robertdaoust.org/:splat  200!

Note, the “!” in “200!” will always proxy, even if a page exists at the original site. If you only want to proxy when the page would otherwise be not found, then remove the “!”.

If other questions about this, please let us know.

Thanks @luke for all these clarifications!
I managed to make it all work :slight_smile:

For collab indeed I forgot to add it as a domain to the Netlify website.

For robert I followed your recommendations and everything is ok. I created an empty website with an index.html and a _redirects since only a _redirects prevented the deploy from processing apparently.
I use permanent redirects to always show the target domain:

/   https://robertdaoust.org/         301!
/*  https://robertdaoust.org/:splat   301!

Hi, @algosphere, thank you for the follow-up and I’m glad to learn it is working now.

Hi,

I don’t think I changed anything but now the domain robert.algosphere.org is not working anymore (server not found) at least from Canada (it’s working from France), and Netlify warns “Check DNS configuration”, but my DNS nameservers are well set. The www.robert.algosphere.org domain works. Any idea please?

hi there, thanks for your patience. can you confirm that you are still seeing this from france? (if you can check in an incognito window to be sure that it isn’t cached in your browser, that would be best.)

From France there is no problem (even in incognito mode / with cache empty). From Canada the server is still not found for robert.algosphere.org, but is found for www.robert.algosphere.org.

And Netlify says:


But I don’t know what to do, my nameservers are well set at my registrar, I haven’t changed them.

Hey victor, we took a closer look at your DNS records and you hit a bug that messed up some of your records. We have fixed things manually for you, let us know if things work better now?

It is ok now, thanks!