Direct fetching Failed

Hi there,

I am trying to do a continuous deployment and deploying a site from GitHub to Netlify. An issue that I am stuck on is that my website won’t deploy.

When I go to Netlify and add the GitHub link for the page, the deployment fails.

I am getting the message below:

3:43:44 PM: Build ready to start

3:43:55 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6

3:43:55 PM: build-image tag: v3.4.1

3:43:55 PM: buildbot version: bca3bbf1ce7c7ca2e2192b1683becc1d98c88c5b

3:43:56 PM: Fetching cached dependencies

3:43:56 PM: Failed to fetch cache, continuing with build

3:43:56 PM: Starting to prepare the repo for build

3:43:56 PM: No cached dependencies found. Cloning fresh repo

3:43:56 PM: git clone https://github.com/fjkiani/himalayan-salt-shop

3:43:57 PM: Preparing Git Reference refs/heads/master

3:43:58 PM: Error checking out submodules: Submodule 'my-project' (https://github.com/fjkiani/himalayan-salt-shop.git) registered for path 'my-project'
Cloning into '/opt/build/repo/my-project'...
fatal: remote error: upload-pack: not our ref 592f2f87e7551897408233ad13dfd3cf344e41d6
fatal: the remote end hung up unexpectedly
Fetched in submodule path 'my-project', but it did not contain 592f2f87e7551897408233ad13dfd3cf344e41d6. Direct fetching of that commit failed.

3:43:58 PM: Failing build: Failed to prepare repo

3:43:58 PM: Failed during stage 'preparing repo': Error checking out submodules: Submodule 'my-project' (https://github.com/fjkiani/himalayan-salt-shop.git) registered for path 'my-project'
Cloning into '/opt/build/repo/my-project'...
fatal: remote error: upload-pack: not our ref 592f2f87e7551897408233ad13dfd3cf344e41d6
fatal: the remote end hung up unexpectedly
Fetched in submodule path 'my-project', but it did not contain 592f2f87e7551897408233ad13dfd3cf344e41d6. Direct fetching of that commit failed.
: exit status 1

3:43:58 PM: Finished processing build request in 2.923556336s

This is the link to the message:
https://app.netlify.com/sites/sharp-ardinghelli-996eac/deploys

This is the link to my github project:

Thank you very much for your help.

Best,
Fahad

Hi.

This has been resolved.

Thanks for the followup @fjkiani ! Could you share what you did to resolve it, so folks who end up here in the future can follow in your footsteps?

1 Like

Agreed :grin: git sub-modules could always use more documentation!

1 Like