Deployment of a static project

  • build log errors, screenshots, etc
    I am trying to use netlify for hosting a static website built on node and gatsby, but when am trying to deploy. I get the log error below. Please I urgently need your help on how to fix this. I am new to Netlify.
    Thanks.

12:53:19 PM: Build ready to start
12:53:20 PM: build-image version: 2dbd444fcdce00cf06325060a8238d5ae3e86774
12:53:20 PM: build-image tag: v3.3.7
12:53:20 PM: buildbot version: 134ec431c6a3ff76e87cc4dc34007fe13842272f
12:53:20 PM: Fetching cached dependencies
12:53:21 PM: Starting to download cache of 254.9KB
12:53:21 PM: Finished downloading cache in 63.194262ms
12:53:21 PM: Starting to extract cache
12:53:21 PM: Failed to fetch cache, continuing with build
12:53:21 PM: Starting to prepare the repo for build
12:53:21 PM: No cached dependencies found. Cloning fresh repo
12:53:21 PM: git clone https://github.com/Mickey374/Mickey374.github.io
12:53:23 PM: Preparing Git Reference refs/heads/master
12:53:24 PM: Starting build script
12:53:24 PM: Installing dependencies
12:53:25 PM: Attempting node version '10.13.0
’ from .nvmrc
12:53:25 PM: Version '10.13.0
’ not found - try nvm ls-remote to browse available versions.
12:53:25 PM: Failed to install node version '10.13.0

12:53:25 PM: Error running command: Build script returned non-zero exit code: 1
12:53:25 PM: failed during stage ‘building site’: Build script returned non-zero exit code: 1
12:53:25 PM: Failing build: Failed to build site
12:53:25 PM: Finished processing build request in 5.050160015s

hi Mickey,

is there a specific reason why you need that node version? It is quite old, and most likely the cause of your problem.

actually, I am just now realizing what the problem is:

'10.13.0
’ from .nvmrc

you are using one ' and one which are not the same. Make both straight and it might work better.

My previous advice still, applies, though, this is quite an old version, the current one is 12+.

Where do I locate this particular error to rectify, and how do I rebuild my node version, should I do it locally on my computer before hosting it.

hi there, the error is in a the .nvmrc file, I assuming you have one of those as part of your project?

1 Like

Working on it.Thanks so much for the help

1 Like