Deployment is Fine, Still Getting a Page Not Found

First Time:
Can anyone point me in the direction on how to deploy a flask website? It says everything is fine, but I am getting a page not found when I visit the site. I don’t know if the DNS has not propagated or if I am not doing something right.

Hi @tanglesit19edu! Welcome to netlify community.

The most common reason folks see the Page Not Found after a successful deploy is due to missing an index.html file in the root of your project.

This post explains how to check for this Support Guide: [Support Guide] I’ve deployed my site but I still see "Page not found”

1 Like

I have done all the checks I can even see my website preview but when I click the main link I get page not found.

I have even check my publish directory. I using only basic html and css.

My Deploy Information.

11:08:36 PM: Build ready to start
11:08:40 PM: build-image version: 2dbd444fcdce00cf06325060a8238d5ae3e86774
11:08:40 PM: build-image tag: v3.3.7
11:08:40 PM: buildbot version: 10926ec3478dd6c0bfc84e15d24de329bb1b357f
11:08:40 PM: Fetching cached dependencies
11:08:40 PM: Starting to download cache of 612.2KB
11:08:40 PM: Finished downloading cache in 83.458957ms
11:08:40 PM: Starting to extract cache
11:08:40 PM: Finished extracting cache in 18.631696ms
11:08:40 PM: Finished fetching cache in 102.927743ms
11:08:40 PM: Starting to prepare the repo for build
11:08:40 PM: Preparing Git Reference refs/heads/master
11:08:41 PM: No build command found, continuing to publishing
11:08:41 PM: Starting to deploy site from ‘src’
11:08:41 PM: Creating deploy tree
11:08:41 PM: Creating deploy upload records
11:08:41 PM: 0 new files to upload
11:08:41 PM: 0 new functions to upload
11:08:41 PM: Starting post processing
11:08:41 PM: Post processing done
11:08:41 PM: Site is live

Please someone help !!

what is the URL of the site, please? Did you read the guide to resolving “page not found” issues?

Yep I checked that but the issue is not resolved. I have set my publish directory to src inside which I have all my html and css files and one assests folder for images.

Do I need anything beyond that like config file etc. If so guide me with the same.

My URL
https://ganeshkumar.netlify.com/

My github code

Please do help. Thanks for checking things for me

hi Ganesh, it seems to be loading for me:

is it possible you checked it before your deploy had finished?

1 Like

Thanks I deleted the site and re deployed it again by dragging and dropping my src folder and then linked it with my repo. Now it’s working fine