Deployment fails for latest Jekyll 4.0

Here are the deployment logs:

2:31:14 AM: Executing user command: jekyll build

2:31:14 AM: Activating bundler (2.0.2) failed:

2:31:14 AM: Could not find ‘bundler’ (2.0.2) required by your /opt/build/repo/Gemfile.lock.

2:31:14 AM: To update to the latest version installed on your system, run bundle update --bundler.

2:31:14 AM: To install the missing version, run gem install bundler:2.0.2

2:31:14 AM: Checked in ‘GEM_PATH=/opt/buildhome/.rvm/gems/ruby-2.6.2:/opt/buildhome/.rvm/rubies/ruby-2.6.2/lib/ruby/gems/2.6.0’, execute gem env for more information

2:31:14 AM: To install the version of bundler this project requires, run gem install bundler -v '2.0.2'

2:31:14 AM: Skipping functions preparation step: no functions directory set

Full logs are here https://www.codepile.net/pile/Pr0G6Wwb

Hi @JerryGoyal , can you share a link to one of your failed builds please? Thanks!

Can you access my deploy history with the link? anway, here it is https://app.netlify.com/sites/evrcare/deploys/5dbf3d42755af1000a111456

P.S: Sorry for the late reply, for some reason netlify doesn’t send me post reply notifications over the mail.

@JerryGoyal, I’m posting the following log lines because they don’t contain any private details and are a great illustration of the issue:

12:52:50 PM: Activating bundler (2.0.2) failed:
12:52:50 PM: Could not find 'bundler' (2.0.2) required by your /opt/build/repo/Gemfile.lock.
12:52:50 PM: To update to the latest version installed on your system, run `bundle update --bundler`.
12:52:50 PM: To install the missing version, run `gem install bundler:2.0.2`
12:52:50 PM: Checked in 'GEM_PATH=/opt/buildhome/.rvm/gems/ruby-2.6.2:/opt/buildhome/.rvm/rubies/ruby-2.6.2/lib/ruby/gems/2.6.0', execute `gem env` for more information
12:52:50 PM: To install the version of bundler this project requires, run `gem install bundler -v '2.0.2'`

At this time, Bundler 2.0.2 isn’t supported by our build system and we have an open issue filed for this.

The only workaround (that I know of) for the issue is to downgrade the version of Bundler used locally to 2.0.1 and regenerate the Gemfile.lock file using that version. Then commit and push that change to the upstream repo.

Again, we have an issue filed for this and we’ll update this topic if/when the issue is resolved to let you know about it. If other people find this topic and have the same issue, please :heart: the original topic post to show your interest in seeing this issue resolved.