Deployment: "DONE Build complete", But does not deploy site and times out

PLEASE help us help you by writing a good post!

Hi

I have a Vue app which I am trying to deploy. The build seems to complete OK, but the deployment process then times out:

Netlify name: unruffled-hermann-ecc976

Deployment Log
10:13:32 AM: Build ready to start
10:13:34 AM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
10:13:34 AM: build-image tag: v3.3.20
10:13:34 AM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4
10:13:34 AM: Fetching cached dependencies
10:13:34 AM: Starting to download cache of 254.8KB
10:13:34 AM: Finished downloading cache in 80.997372ms
10:13:34 AM: Starting to extract cache
10:13:34 AM: Failed to fetch cache, continuing with build
10:13:34 AM: Starting to prepare the repo for build
10:13:35 AM: No cached dependencies found. Cloning fresh repo
10:13:35 AM: git clone https://github.com
10:13:41 AM: Preparing Git Reference refs/heads/master
10:13:43 AM: Starting build script
10:13:43 AM: Installing dependencies
10:13:43 AM: Python version set to 2.7
10:13:44 AM: v12.18.0 is already installed.
10:13:45 AM: Now using node v12.18.0 (npm v6.14.4)
10:13:45 AM: Started restoring cached build plugins
10:13:45 AM: Finished restoring cached build plugins
10:13:45 AM: Attempting ruby version 2.7.1, read from environment
10:13:46 AM: Using ruby version 2.7.1
10:13:47 AM: Using PHP version 5.6
10:13:47 AM: 5.2 is already installed.
10:13:47 AM: Using Swift version 5.2
10:13:47 AM: Started restoring cached node modules
10:13:47 AM: Finished restoring cached node modules
10:13:47 AM: Started restoring cached yarn cache
10:13:47 AM: Finished restoring cached yarn cache
10:13:47 AM: Installing yarn at version 1.22.4
10:13:47 AM: Installing Yarn!
10:13:47 AM: > Downloading tarball…
10:13:47 AM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz --> /tmp/yarn.tar.gz.zXfzs3mg7j
10:13:47 AM: % Total % Received % Xferd Average Speed Time Time Time Current
10:13:47 AM: Dload Upload Total Spent Left Speed
10:13:47 AM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
10:13:48 AM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
10:13:48 AM: 100 80 100 80 0 0 261 0 --:–:-- --:–:-- --:–:-- 260
10:13:48 AM: 100 93 100 93 0 0 149 0 --:–:-- --:–:-- --:–:-- 149
10:13:48 AM: 100 630 100 630 0 0 708 0 --:–:-- --:–:-- --:–:-- 708
10:13:49 AM: 0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
10:13:49 AM: 100 1215k 100 1215k 0 0 927k 0 0:00:01 0:00:01 --:–:-- 5734k
10:13:49 AM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc --> /tmp/yarn.tar.gz.zXfzs3mg7j.asc
10:13:49 AM: 100 84 100 84 0 0 3070 0 --:–:-- --:–:-- --:–:-- 3070
10:13:49 AM: 100 97 100 97 0 0 1766 0 --:–:-- --:–:-- --:–:-- 1766
10:13:49 AM: 100 634 100 634 0 0 7355 0 --:–:-- --:–:-- --:–:-- 7355
10:13:49 AM: 100 1028 100 1028 0 0 8224 0 --:–:-- --:–:-- --:–:-- 8224
10:13:49 AM: > Verifying integrity…
10:13:49 AM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
10:13:49 AM: gpg: Good signature from β€œYarn Packaging yarn@dan.cx”
10:13:49 AM: gpg: WARNING: This key is not certified with a trusted signature!
10:13:49 AM: gpg: There is no indication that the signature belongs to the owner.
10:13:49 AM: Primary key fingerprint: 72EC [edited] 86E5 0310
10:13:49 AM: Subkey fingerprint: 6D98 490C [edited] 5BAA
10:13:49 AM: > GPG signature looks good
10:13:49 AM: > Extracting to ~/.yarn…
10:13:49 AM: > Adding to PATH... 10:13:49 AM: > Successfully installed Yarn 1.22.4! Please open another terminal where the `yarn` command will now be available. 10:13:50 AM: Installing NPM modules using Yarn version 1.22.4 10:13:50 AM: yarn install v1.22.4 10:13:50 AM: [1/4] Resolving packages... 10:13:51 AM: [2/4] Fetching packages... 10:14:07 AM: warning url-loader@1.1.2: Invalid bin field for "url-loader". 10:14:14 AM: info fsevents@2.1.3: The platform "linux" is incompatible with this module. 10:14:14 AM: info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation. 10:14:14 AM: info fsevents@1.2.13: The platform "linux" is incompatible with this module. 10:14:14 AM: info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation. 10:14:14 AM: [3/4] Linking dependencies... 10:14:14 AM: warning "aws-amplify > @aws-amplify/api@2.2.1" has incorrect peer dependency "@aws-amplify/pubsub@^1.2.4". 10:14:14 AM: warning "aws-amplify > @aws-amplify/core@2.3.0" has unmet peer dependency "@react-native-community/netinfo@^5.5.0". 10:14:14 AM: warning " > bootstrap@4.5.0" has unmet peer dependency "jquery@1.9.1 - 3". 10:14:14 AM: warning " > bootstrap@4.5.0" has unmet peer dependency "popper.js@^1.16.0". 10:14:24 AM: [4/4] Building fresh packages... 10:14:26 AM: Done in 35.64s. 10:14:26 AM: NPM modules installed using Yarn 10:14:26 AM: Started restoring cached go cache 10:14:26 AM: Finished restoring cached go cache 10:14:26 AM: go version go1.14.4 linux/amd64 10:14:26 AM: go version go1.14.4 linux/amd64 10:14:26 AM: Installing missing commands 10:14:26 AM: Verify run directory 10:14:27 AM: ​ 10:14:27 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β” 10:14:27 AM: β”‚ Netlify Build β”‚ 10:14:27 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜ 10:14:27 AM: ​ 10:14:27 AM: ❯ Version 10:14:27 AM: @netlify/build 3.0.1 10:14:27 AM: ​ 10:14:27 AM: ❯ Flags 10:14:27 AM: deployId: 5f1d493c853f8a7d0543cc4c 10:14:27 AM: mode: buildbot 10:14:27 AM: ​ 10:14:27 AM: ❯ Current directory 10:14:27 AM: /opt/build/repo 10:14:27 AM: ​ 10:14:27 AM: ❯ Config file 10:14:27 AM: No config file was defined: using default values. 10:14:27 AM: ​ 10:14:27 AM: ❯ Context 10:14:27 AM: production 10:14:27 AM: ​ 10:14:27 AM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β” 10:14:27 AM: β”‚ 1. Build command from Netlify app β”‚ 10:14:27 AM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜ 10:14:27 AM: ​ 10:14:27 AM: yarn build
10:14:27 AM: yarn run v1.22.4
10:14:27 AM: $ vue-cli-service build
10:14:28 AM: - Building for production…
10:15:26 AM: WARNING Compiled with 3 warnings9:15:26 AM
10:15:26 AM: warning
10:15:26 AM: asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
10:15:26 AM: This can impact web performance.
10:15:26 AM: Assets:
10:15:26 AM: css/chunk-vendors.0bc42930.css (246 KiB)
10:15:26 AM: js/chunk-vendors.8687f2f6.js (4.66 MiB)
10:15:26 AM: demo-test.gif (453 KiB)
10:15:26 AM: warning
10:15:26 AM: entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
10:15:26 AM: Entrypoints:
10:15:26 AM: app (4.97 MiB)
10:15:26 AM: css/chunk-vendors.0bc42930.css
10:15:26 AM: js/chunk-vendors.8687f2f6.js
10:15:26 AM: css/app.08864e0c.css
10:15:26 AM: js/app.683461b8.js
10:15:26 AM: warning
10:15:26 AM: webpack performance recommendations:
10:15:26 AM: You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
10:15:26 AM: For more info visit https://webpack.js.org/guides/code-splitting/
10:15:29 AM: Webpack Bundle Analyzer is started at http://127.0.0.1:8888
10:15:29 AM: Use Ctrl+C to close it
10:15:29 AM: File Size Gzipped
10:15:29 AM: dist/js/chunk-vendors.8687f2f6.js 4770.24 KiB 1006.63 KiB
10:15:29 AM: dist/js/app.683461b8.js 67.95 KiB 13.89 KiB
10:15:29 AM: dist/modernizr-custom.js 5.08 KiB 2.25 KiB
10:15:29 AM: dist/css/chunk-vendors.0bc42930.css 245.80 KiB 32.96 KiB
10:15:29 AM: dist/css/app.08864e0c.css 3.61 KiB 1.29 KiB
10:15:29 AM: dist/hllo.css 0.67 KiB 0.35 KiB
10:15:29 AM: dist/customfonts.css 0.53 KiB 0.22 KiB
10:15:29 AM: Images and other types of assets omitted.
10:15:29 AM: DONE Build complete. The dist directory is ready to be deployed.
10:15:29 AM: INFO Check out deployment instructions at [link removed]
10:43:33 AM: Build exceeded maximum allowed runtime

Hi, @kevin1. Please take a look at this support guide:

Also, there is a big red flag that a running process not being exited correctly is the root cause:

10:15:29 AM: Webpack Bundle Analyzer is started at http://127.0.0.1:8888
10:15:29 AM: Use Ctrl+C to close it

If I was a gambler (which I am not), my money would be on that above being the process still running and which prevents the build from exiting.

The solution is to make certain that process is shut down when the build is complete.

If this doesn’t work, please let us know what you tried and/or if there are any questions.

Thank you.
It was the Webpack Bundle Analyzer causing the issue, should only be included for development builds.

1 Like