Deploy with drag and drop missing from admin deploy page

Hi!

Is it just me, or has the drag and drop deploy function been removed from the deploy page of the admin? Has this function been moved somewhere else?

This process is mentioned here:

you can deploy your site manually by using the deploy dropzone at the bottom of the Deploys page.

I usually deploy using this method, but right now the “dropzone” area is missing from the bottom of the deploy page.

Same issue here :confused:

Hi, @megant and @elihuansen. I’m still seeing the “dropzone” when I test. For example here:

https://app.netlify.com/teams/<INSERT TEAM SLUG HERE>/sites

If you are not seeing this, would you please send us a screenshot of what you do see there?

Hey @luke!

I was referring to the drag and drop area for updating an existing site, not for deploying a new site.

This is what I see under site A at https://app.netlify.com/sites/<SITE A>/deploys

And under site B at https://app.netlify.com/sites/<SITE B>/deploys

The drag-&-drop area is missing for some reason.

Some additional info:
Site B is hooked up to a git repository, while Site A is not. Could that be an issue?
I prefer to perform builds on my machine since the sites have large images that take quite awhile to process, and thereafter deploy either via netlify cli or drag-&-drop.

Thanks for your help! :smiley:

1 Like

hey there! you both have a good eye, we did indeed make some changes to how this area looks and works recently (most folks don’t mix and match deployment methods, so we decided to optimize for that use case.)

If there is a linked repo, the drag n drop zone on the deploys page no longer appears, as we’re assuming you are using CI or the CLI to deploy.

In order to use drag&drop from the UI on an existing site that already has a linked repo, the repo would need to be unlinked. Hopefully, unlinking via the UI is coming soon, but until then, we can unlink the repo for you if you need.

New sites can still be created via the dropzone from the Sites page. I hope that answers your questions!

Hey perry! Ah I see…
I was actually looking for a way to unlink the repo but couldn’t manage to :sweat_smile:
Could you help me unlink the repo? Thanks a lot!

hi there, i need to know the netlify site name for this to unlink!

hi, can you unlink mine 2
https://app.netlify.com/sites/zenshin/overview

Oops sorry brain fart moment :laughing:

It’s https://app.netlify.com/sites/amore-web

Thank you!

Please disconnect my repo as well (or add back the ability to drag and drop deploys). Site: https://app.netlify.com/sites/traffickinghub/

Hey Perry,

Thanks for the info.
I have been using the CLI since the change, and it works fine for me.
With that my problem has been solved.
But it’s good to know the reason why it disappeared.

glad to hear you can deploy via CLI still. I agree that we could have been more proactive in communicating this change. :bowing_man: everyone else, we’ll let you know when we have had a chance to unlink your repos. Hang tight

tis unlinked, @EvanOlsen

tis unlinked, @elihuansen

tis unlinked, @lokieno

thank you :slight_smile:

Thank you my good sirs :partying_face:

hi techtester, we’re unable to find that site - has it been deleted? If not, can you give us the API ID for that site? you can find that information on the general settings page for the site, near the top.

we have unlinked that for you, @techtester.