Deploy processing failed after 5 attempts

I’ve tried building older builds that used to pass, but they are failing too.
Deployment post-processing (asset optimization) is currently turned off.

UPDATE:
Deploying through the netlfiy cli i get the following error output

Note the error message given here "error_message": "user assets doesn't exist",

{
 »     "deploy": {
 »       "id": "5f311c6bbed268a379703cfc",
 »       "site_id": "20bf8395-3d82-41a5-ab6b-15012992d87e",
 »       "build_id": null,
 »       "state": "error",
 »       "name": "brandemetalkoebdk",
 »       "url": "https://brandemetalkoeb.dk",
 »       "ssl_url": "https://brandemetalkoeb.dk",
 »       "admin_url": "https://app.netlify.com/sites/brandemetalkoebdk",
 »       "deploy_url": "http://5f311c6bbed268a379703cfc--brandemetalkoebdk.netlify.app",
 »       "deploy_ssl_url": "https://5f311c6bbed268a379703cfc--brandemetalkoebdk.netlify.app",       
 »       "created_at": "2020-08-10T10:07:39.146Z",
 »       "updated_at": "2020-08-10T10:07:45.522Z",
 »       "user_id": "5d210ba9608434fc26de7128",
 »       "error_message": "user assets doesn't exist",
 »       "required": [],
 »       "required_functions": null,
 »       "commit_ref": null,
 »       "review_id": null,
 »       "branch": "master",
 »       "commit_url": null,
 »       "skipped": null,
 »       "locked": null,
 »       "log_access_attributes": {
 »         "type": "firebase",
 »         "url": "https://netlify-builds3.firebaseio.com/deploys/5f311c6bbed268a379703cfc/log",    
 »         "endpoint": "https://netlify-builds3.firebaseio.com",
 »         "path": "/deploys/5f311c6bbed268a379703cfc/log",
 »         "token": "eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJ2IjowLCJpYXQiOjE1OTcwNTQwNjUsImQiOnsid 
 »   WlkIjoiIn19.Vl2NAdoAOVfII6wNO_HRlIWzR0BxYWKscZGWnMT98u0"
 »       },
 »       "title": null,
 »       "review_url": null,
 »       "published_at": null,
 »       "context": "deploy-preview",
 »       "deploy_time": null,
 »       "available_functions": [],
 »       "summary": {
 »         "status": "unavailable",
 »         "messages": []
 »       },
 »       "screenshot_url": null,
 »       "site_capabilities": {
 »         "title": "Netlify Team Free",
 »         "asset_acceleration": true,
 »         "form_processing": true,
 »         "cdn_propagation": "partial",
 »         "build_gc_exchange": "buildbot-gc",
 »         "build_node_pool": "buildbot-external-ssd",
 »         "domain_aliases": true,
 »         "secure_site": false,
 »         "prerendering": true,
 »         "proxying": true,
 »         "ssl": "custom",
 »         "rate_cents": 0,
 »         "yearly_rate_cents": 0,
 »         "ipv6_domain": "cdn.makerloop.com",
 »         "branch_deploy": true,
 »         "managed_dns": true,
 »         "geo_ip": true,
 »         "split_testing": true,
 »         "id": "nf_team_dev",
 »         "cdn_tier": "reg",
 »         "identity": {
 »           "active_users": {
 »             "included": 1000,
 »             "unit": "users",
 »             "used": 0
 »           },
 »           "invite_only_users": {
 »             "included": 5,
 »             "unit": "users",
 »             "used": 1
 »           }
 »         }
 »       },
 »       "committer": null,
 »       "skipped_log": null,
 »       "manual_deploy": true,
 »       "file_tracking_optimization": false,
 »       "plugin_state": "none"
 »     }
 »   }

Here are the logs
8:41:19 AM: Build ready to start
8:41:21 AM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
8:41:21 AM: build-image tag: v3.4.1
8:41:21 AM: buildbot version: bca3bbf1ce7c7ca2e2192b1683becc1d98c88c5b
8:41:21 AM: No cache source specified, skip fetching cache
8:41:21 AM: Starting to prepare the repo for build
8:41:21 AM: No cached dependencies found. Cloning fresh repo
8:41:21 AM: git clone git@gitlab.com:littlegiants/brandemetal_vue
8:41:24 AM: Preparing Git Reference refs/heads/master
8:41:26 AM: Starting build script
8:41:26 AM: Installing dependencies
8:41:26 AM: Python version set to 2.7
8:41:27 AM: Downloading and installing node v10.22.0…
8:41:27 AM: Downloading https://nodejs.org/dist/v10.22.0/node-v10.22.0-linux-x64.tar.xz
8:41:27 AM: Computing checksum with sha256sum
8:41:28 AM: Checksums matched!
8:41:30 AM: Now using node v10.22.0 (npm v6.14.6)
8:41:30 AM: Started restoring cached build plugins
8:41:30 AM: Finished restoring cached build plugins
8:41:30 AM: Attempting ruby version 2.6.2, read from environment
8:41:31 AM: Using ruby version 2.6.2
8:41:32 AM: Using PHP version 5.6
8:41:32 AM: 5.2 is already installed.
8:41:32 AM: Using Swift version 5.2
8:41:32 AM: Started restoring cached node modules
8:41:32 AM: Finished restoring cached node modules
8:41:32 AM: Installing NPM modules using NPM version 6.14.6
8:42:02 AM: > node-sass@4.14.1 install /opt/build/repo/node_modules/node-sass
8:42:02 AM: > node scripts/install.js
8:42:03 AM: Downloading binary from https://github.com/sass/node-sass/releases/download/v4.14.1/linux-x64-64_binding.node
8:42:03 AM: Download complete
8:42:03 AM: Binary saved to /opt/build/repo/node_modules/node-sass/vendor/linux-x64-64/binding.node
8:42:03 AM: Caching binary to /opt/buildhome/.npm/node-sass/4.14.1/linux-x64-64_binding.node
8:42:03 AM: > sharp@0.23.4 install /opt/build/repo/node_modules/sharp
8:42:03 AM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
8:42:04 AM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/bmp/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/custom/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/gif/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/jpeg/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/plugin-resize/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/png/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/tiff/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:06 AM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/@jimp/types/node_modules/core-js
8:42:06 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:07 AM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/core-js
8:42:07 AM: > node -e “try{require(’./postinstall’)}catch(e){}”
8:42:07 AM: > ejs@2.7.4 postinstall /opt/build/repo/node_modules/ejs
8:42:07 AM: > node ./postinstall.js
8:42:07 AM: > cwebp-bin@5.1.0 postinstall /opt/build/repo/node_modules/cwebp-bin
8:42:07 AM: > node lib/install.js
8:42:07 AM: :heavy_check_mark: cwebp pre-build test passed successfully
8:42:08 AM: > mozjpeg@6.0.1 postinstall /opt/build/repo/node_modules/mozjpeg
8:42:08 AM: > node lib/install.js
8:42:08 AM: :heavy_check_mark: mozjpeg pre-build test passed successfully
8:42:08 AM: > pngquant-bin@5.0.2 postinstall /opt/build/repo/node_modules/pngquant-bin
8:42:08 AM: > node lib/install.js
8:42:08 AM: :heavy_check_mark: pngquant pre-build test passed successfully
8:42:08 AM: > bootstrap-vue@2.16.0 postinstall /opt/build/repo/node_modules/bootstrap-vue
8:42:08 AM: > opencollective || exit 0
8:42:09 AM: > node-sass@4.14.1 postinstall /opt/build/repo/node_modules/node-sass
8:42:09 AM: > node scripts/build.js
8:42:09 AM: Binary found at /opt/build/repo/node_modules/node-sass/vendor/linux-x64-64/binding.node
8:42:09 AM: Testing binary
8:42:09 AM: Binary is fine
8:42:09 AM: > nodemon@1.19.4 postinstall /opt/build/repo/node_modules/nodemon
8:42:09 AM: > node bin/postinstall || exit 0
8:42:09 AM: Love nodemon? You can now support the project via the open collective:
8:42:09 AM: > https://opencollective.com/nodemon/donate
8:42:09 AM: > nuxt@2.14.1 postinstall /opt/build/repo/node_modules/nuxt
8:42:09 AM: > opencollective || exit 0
8:42:11 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/watchpack/node_modules/fsevents):
8:42:11 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
8:42:11 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
8:42:11 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
8:42:11 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/@nuxt/components/node_modules/fsevents):
8:42:11 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
8:42:11 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/@nuxt/builder/node_modules/fsevents):
8:42:11 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
8:42:11 AM: added 1958 packages from 1220 contributors and audited 1965 packages in 38.505s
8:42:12 AM: 54 packages are looking for funding
8:42:12 AM: run npm fund for details
8:42:12 AM: found 209 vulnerabilities (208 low, 1 high)
8:42:12 AM: run npm audit fix to fix them, or npm audit for details
8:42:13 AM: NPM modules installed
8:42:13 AM: Started restoring cached go cache
8:42:13 AM: Finished restoring cached go cache
8:42:13 AM: Installing Go version 1.12
8:42:18 AM: unset GOOS;
8:42:18 AM: unset GOARCH;
8:42:18 AM: export GOROOT=’/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64’;
8:42:18 AM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.12.linux.amd64/bin:{PATH}"; 8:42:18 AM: go version >&2; 8:42:18 AM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.12.linux.amd64.env" 8:42:18 AM: go version go1.12 linux/amd64 8:42:18 AM: Installing missing commands 8:42:18 AM: Verify run directory 8:42:19 AM: ​ 8:42:19 AM: ┌─────────────────────────────┐ 8:42:19 AM: │ Netlify Build │ 8:42:19 AM: └─────────────────────────────┘ 8:42:19 AM: ​ 8:42:19 AM: ❯ Version 8:42:19 AM: @netlify/build 3.1.10 8:42:19 AM: ​ 8:42:19 AM: ❯ Flags 8:42:19 AM: deployId: 5f30ec0fbed2686e9d703fdd 8:42:19 AM: mode: buildbot 8:42:19 AM: timersFile: /tmp/substage_times.txt 8:42:19 AM: ​ 8:42:19 AM: ❯ Current directory 8:42:19 AM: /opt/build/repo 8:42:19 AM: ​ 8:42:19 AM: ❯ Config file 8:42:19 AM: No config file was defined: using default values. 8:42:19 AM: ​ 8:42:19 AM: ❯ Context 8:42:19 AM: production 8:42:19 AM: ​ 8:42:19 AM: ┌───────────────────────────────────┐ 8:42:19 AM: │ 1. Build command from Netlify app │ 8:42:19 AM: └───────────────────────────────────┘ 8:42:19 AM: ​ 8:42:19 AM: nuxt generate
8:42:53 AM: [error] [BABEL] Note: The code generator has deoptimised the styling of /opt/build/repo/node_modules/bootstrap-vue/src/icons/icons.js as it exceeds the max of 500KB.
8:43:44 AM: ​
8:43:44 AM: (build.command completed in 1m 24.6s)
8:43:44 AM: ​
8:43:44 AM: ┌─────────────────────────────┐
8:43:44 AM: │ Netlify Build Complete │
8:43:44 AM: └─────────────────────────────┘
8:43:44 AM: ​
8:43:44 AM: (Netlify Build completed in 1m 24.6s)
8:43:44 AM: Caching artifacts
8:43:44 AM: Started saving node modules
8:43:44 AM: Finished saving node modules
8:43:44 AM: Started saving build plugins
8:43:44 AM: Finished saving build plugins
8:43:44 AM: Started saving pip cache
8:43:44 AM: Finished saving pip cache
8:43:44 AM: Started saving emacs cask dependencies
8:43:44 AM: Finished saving emacs cask dependencies
8:43:44 AM: Started saving maven dependencies
8:43:44 AM: Finished saving maven dependencies
8:43:44 AM: Started saving boot dependencies
8:43:44 AM: Finished saving boot dependencies
8:43:44 AM: Started saving go dependencies
8:43:46 AM: Finished saving go dependencies
8:43:49 AM: Build script success
8:43:49 AM: Starting to deploy site from ‘dist’
8:43:49 AM: Creating deploy tree
8:43:49 AM: Creating deploy upload records
8:43:49 AM: 39 new files to upload
8:43:49 AM: 0 new functions to upload
8:43:51 AM: Starting post processing
8:43:51 AM: Post processing - HTML
8:43:51 AM: Starting post processing
8:43:51 AM: Post processing - HTML
8:43:51 AM: Starting post processing
8:43:51 AM: Post processing - HTML
8:43:51 AM: Starting post processing
8:43:51 AM: Post processing - HTML
8:43:51 AM: Starting post processing
8:43:51 AM: Post processing - HTML
8:44:46 AM: Finished processing build request in 3m25.421906578s

That means that there is some syntax error in your html that is breaking our attempts to parse it. If you’d give us a link to the logs page instead of pasting the logs, we’ll be able to try to discover at least which file and functionality the parsing is failing on (e.g. forms or pretty URL’s) so we can point you towards the source of the problem so you can fix the syntax in your file.

If you want to remove the asset optimization, uploading will probably work fine as is with no further work by you. But I don’t know which site you are working with so cannot link you directly to it, but it’s a section of the deploy settings page called “Asset Optimization” and you must check the checkbox to disable asset optimization to ensure that we do not try to parse your files.