Deploy Failed confusion

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example: kind-yonath-76baba.netlify.app
  • Build problems? Yes
    ┌───────────────────────────────────────────────────────┐
    4:40:12 AM: │ 3. onPostBuild command from netlify-plugin-checklinks │
    4:40:12 AM: └───────────────────────────────────────────────────────┘
    4:40:12 AM: ​
    4:40:18 AM: …××××××.×…××…××××××…××…××××××××…×.×.×.×.
    4:40:18 AM: :heavy_multiplication_x: FAIL load public/post/images/pixel_me.png
    4:40:18 AM: | operator: load
    4:40:18 AM: | expected: 200 public/post/images/pixel_me.png
    4:40:18 AM: | actual: ENOENT: no such file or directory, open ‘/opt/build/repo/public/post/images/pixel_me.png’
    4:40:18 AM: | at: public/post/index.html:48:28
    4:40:18 AM: :heavy_multiplication_x: FAIL load public/categories/images/pixel_me.png
    4:40:18 AM: | operator: load
    4:40:18 AM: | expected: 200 public/categories/images/pixel_me.png
    4:40:18 AM: | actual: ENOENT: no such file or directory, open ‘/opt/build/repo/public/categories/images/pixel_me.png’
    4:40:18 AM: | at: public/categories/index.html:113:28
    4:40:18 AM: :heavy_multiplication_x: FAIL load public/tags/images/pixel_me.png
    4:40:18 AM: | operator: load
    4:40:18 AM: | expected: 200 public/tags/images/pixel_me.png
    4:40:18 AM: | actual: ENOENT: no such file or directory, open ‘/opt/build/repo/public/tags/images/pixel_me.png’
    4:40:18 AM: | at: public/tags/index.html:48:28
    4:40:18 AM: :heavy_multiplication_x: FAIL load public/about/images/pixel_me.png
    4:40:18 AM: | operator: load

hi, can you post the full build log please? thanks.

https://app.netlify.com/sites/kind-yonath-76baba/deploys/5eea6ae3041acd00087d71a2

you are using the netlify link checker plugin, yay! that’s awesome. so this is working as expected - your build is failing because those links are failing, preventing you from deploying a site with broken links.

1 Like

But those aren’t broken. I can server my site locally :thinking:

hmm.

could this be the problem?

1 Like

Hi @franckess!

If this is not fixing your problem, I would also suggest reaching out to the repository of this plugin (link), since it is third-party. Please let us know if this solves your issue!