Deploy failed / "build.command" failed on repo for Gatsby site

Netlify site name: https://stevenorechow.netlify.app/

Hello! This is my first support topic, I tried searching around for similar posts and trying the commands there, but nothing seems to be working.

I’ve tried and failed with the following build commands:

gatsby build
npm run build

Here is the log for both.

gatsby build

3:03:59 PM: Build ready to start
3:04:01 PM: build-image version: 3031d4c9e432fd7016f6279fc9ad706f9205d845
3:04:01 PM: build-image tag: v3.3.17
3:04:01 PM: buildbot version: da42b14a989873e00cc6f36bc354c01953474181
3:04:01 PM: Fetching cached dependencies
3:04:01 PM: Failed to fetch cache, continuing with build
3:04:01 PM: Starting to prepare the repo for build
3:04:01 PM: No cached dependencies found. Cloning fresh repo
3:04:01 PM: git clone https://github.com/stevenorechow/parallax
3:04:02 PM: Preparing Git Reference refs/heads/master
3:04:03 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
3:04:03 PM: Starting build script
3:04:03 PM: Installing dependencies
3:04:03 PM: Python version set to 2.7
3:04:05 PM: v12.18.0 is already installed.
3:04:05 PM: Now using node v12.18.0 (npm v6.14.4)
3:04:05 PM: Started restoring cached build plugins
3:04:05 PM: Finished restoring cached build plugins
3:04:06 PM: Attempting ruby version 2.7.1, read from environment
3:04:07 PM: Using ruby version 2.7.1
3:04:07 PM: Using PHP version 5.6
3:04:08 PM: 5.2 is already installed.
3:04:08 PM: Using Swift version 5.2
3:04:08 PM: Started restoring cached node modules
3:04:08 PM: Finished restoring cached node modules
3:04:08 PM: Started restoring cached yarn cache
3:04:08 PM: Finished restoring cached yarn cache
3:04:08 PM: Installing yarn at version 1.22.4
3:04:08 PM: Installing Yarn!
3:04:08 PM: > Downloading tarball...
3:04:08 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz --> /tmp/yarn.tar.gz.XhKs6QcJz5
3:04:08 PM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
3:04:08 PM:                                  Dload  Upload   Total   Spent    Left  Speed
3:04:08 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:04:08 PM: 100    80  100    80    0     0    241      0 --:--:-- --:--:-- --:--:--   242
3:04:08 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:04:08 PM: 100    93  100    93    0     0    141      0 --:--:-- --:--:-- --:--:--   534
3:04:09 PM: 100   630  100   630    0     0    682      0 --:--:-- --:--:-- --:--:--   682
3:04:09 PM: 100 1215k  100 1215k    0     0   877k      0  0:00:01  0:00:01 --:--:--  877k
3:04:09 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc --> /tmp/yarn.tar.gz.XhKs6QcJz5.asc
3:04:09 PM: 100    84  100    84    0     0   2983      0 --:--:-- --:--:-- --:--:--  2983
3:04:09 PM:   0    97    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
3:04:09 PM: 100    97  100    97    0     0   1617      0 --:--:-- --:--:-- --:--:-- 97000
3:04:09 PM: 100   634  100   634    0     0   6849      0 --:--:-- --:--:-- --:--:--  6849
3:04:09 PM: 100  1028  100  1028    0     0   7693      0 --:--:-- --:--:-- --:--:--  7693
3:04:09 PM: > Verifying integrity...
3:04:09 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
3:04:09 PM: gpg: Good signature from "Yarn Packaging <yarn@dan.cx>"
3:04:09 PM: gpg: WARNING: This key is not certified with a trusted signature!
3:04:09 PM: gpg:          There is no indication that the signature belongs to the owner.
3:04:09 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
3:04:09 PM:      Subkey fingerprint: 6D98 490C 6F1A CDDD 448E  4595 4F77 6793 6947 5BAA
3:04:09 PM: > GPG signature looks good
3:04:09 PM: > Extracting to ~/.yarn...
3:04:10 PM: > Adding to $PATH...
3:04:10 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the `yarn` command will now be available.
3:04:10 PM: Installing NPM modules using Yarn version 1.22.4
3:04:11 PM: yarn install v1.22.4
3:04:11 PM: [1/4] Resolving packages...
3:04:12 PM: [2/4] Fetching packages...
3:04:23 PM: warning url-loader@1.1.2: Invalid bin field for "url-loader".
3:04:43 PM: info fsevents@2.1.3: The platform "linux" is incompatible with this module.
3:04:43 PM: info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
3:04:43 PM: info fsevents@1.2.13: The platform "linux" is incompatible with this module.
3:04:43 PM: info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
3:04:43 PM: [3/4] Linking dependencies...
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > @emotion/styled@10.0.27" has unmet peer dependency "@emotion/core@^10.0.27".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion@4.3.2" has unmet peer dependency "@babel/core@^7.0.0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion@4.3.2" has unmet peer dependency "@emotion/core@^10.0.5".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-mdx@1.2.13" has unmet peer dependency "@mdx-js/react@^1.0.0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-theme-ui@0.3.0" has incorrect peer dependency "theme-ui@^0.2.0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > @emotion/styled > @emotion/styled-base@10.0.31" has unmet peer dependency "@emotion/core@^10.0.28".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop@10.0.27" has unmet peer dependency "@babel/core@^7.0.0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @babel/plugin-transform-react-jsx@7.10.1" has unmet peer dependency "@babel/core@^7.0.0-0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @emotion/babel-plugin-jsx-pragmatic@0.1.5" has unmet peer dependency "@babel/core@^7.0.0".
3:04:43 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @babel/plugin-transform-react-jsx > @babel/plugin-syntax-jsx@7.10.1" has unmet peer dependency "@babel/core@^7.0.0-0".
3:04:43 PM: warning "gatsby > @pmmmwh/react-refresh-webpack-plugin@0.3.2" has incorrect peer dependency "react-refresh@^0.8.2".
3:04:43 PM: warning "gatsby > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
3:04:43 PM: warning "gatsby-plugin-netlify > webpack-assets-manifest@3.1.1" has unmet peer dependency "webpack@>=4.4.0".
3:05:00 PM: [4/4] Building fresh packages...
3:05:12 PM: Done in 61.27s.
3:05:12 PM: NPM modules installed using Yarn
3:05:13 PM: Started restoring cached go cache
3:05:13 PM: Finished restoring cached go cache
3:05:13 PM: go version go1.14.4 linux/amd64
3:05:13 PM: go version go1.14.4 linux/amd64
3:05:13 PM: Installing missing commands
3:05:13 PM: Verify run directory
3:05:14 PM: ​
3:05:14 PM: ┌─────────────────────────────┐
3:05:14 PM: │        Netlify Build        │
3:05:14 PM: └─────────────────────────────┘
3:05:14 PM: ​
3:05:14 PM: ❯ Version
3:05:14 PM:   @netlify/build 2.0.10
3:05:14 PM: ​
3:05:14 PM: ❯ Flags
3:05:14 PM:   deployId: 5eed283f5de0e58440686eea
3:05:14 PM:   mode: buildbot
3:05:14 PM: ​
3:05:14 PM: ❯ Current directory
3:05:14 PM:   /opt/build/repo
3:05:14 PM: ​
3:05:14 PM: ❯ Config file
3:05:14 PM:   No config file was defined: using default values.
3:05:14 PM: ​
3:05:14 PM: ❯ Context
3:05:14 PM:   production
3:05:14 PM: ​
3:05:14 PM: ┌────────────────────────────────┐
3:05:14 PM: │ 1. Build command from settings │
3:05:14 PM: └────────────────────────────────┘
3:05:14 PM: ​
3:05:14 PM: $ gatsby build
3:05:17 PM: success open and validate gatsby-configs - 0.044s
3:05:18 PM: success load plugins - 0.836s
3:05:18 PM: warning The Google Analytics plugin requires a tracking ID. Did you mean to add it?
3:05:18 PM: success onPreInit - 0.031s
3:05:18 PM: success delete html and css files from previous builds - 0.017s
3:05:18 PM: success initialize cache - 0.013s
3:05:18 PM: success copy gatsby files - 0.100s
3:05:18 PM: success onPreBootstrap - 0.013s
3:05:18 PM: success createSchemaCustomization - 0.004s
3:05:19 PM: success source and transform nodes - 0.888s
3:05:20 PM: success building schema - 0.344s
3:05:20 PM: success createPages - 0.020s
3:05:20 PM: success createPagesStatefully - 0.054s
3:05:20 PM: success onPreExtractQueries - 0.001s
3:05:20 PM: success update schema - 0.041s
3:05:20 PM: success extract queries from components - 0.205s
3:05:20 PM: success write out requires - 0.004s
3:05:20 PM: success write out redirect data - 0.001s
3:05:20 PM: success Build manifest and related icons - 0.001s
3:05:20 PM: success onPostBootstrap - 0.010s
3:05:20 PM: ⠀
3:05:20 PM: info bootstrap finished - 5.988s
3:05:20 PM: ⠀
3:05:51 PM: failed Building production JavaScript and CSS bundles - 31.105s
3:05:51 PM: error Generating JavaScript bundles failed
3:05:51 PM: unknown: Expected corresponding JSX closing tag for <br> (35:0)
3:05:51 PM:   33 | >
3:05:51 PM:   34 |   Add nice things people have said about your work, or your favourite quote. <br><i>“'You miss 100% of the shots you don't take.' — Wayne Gretzky”</i> —Michael Scott
> 35 | </ProjectCard>
3:05:51 PM:      | ^
3:05:51 PM:   36 | <ProjectCard
3:05:51 PM:   37 |   title="Whatever Else"
3:05:51 PM:   38 |   link="https://stevenorechow.me/"/opt/build/repo/src/@lekoarts/gatsby-theme-cara/sections/projects.mdx: unknown: Expected corresponding JSX closing tag for <br> (35:0)
3:05:51 PM:   33 | >
3:05:51 PM:   34 |   Add nice things people have said about your work, or your favourite quote. <br><i>“'You miss 100% of the shots you don't take.' — Wayne Gretzky”</i> —Michael Scott
> 35 | </ProjectCard>
3:05:51 PM:      | ^
3:05:51 PM:   36 | <ProjectCard
3:05:51 PM:   37 |   title="Whatever Else"
3:05:51 PM:   38 |   link="https://stevenorechow.me/"
3:05:51 PM: not finished run queries - 31.131s
3:05:51 PM: ​
3:05:51 PM: ┌─────────────────────────────┐
3:05:51 PM: │   "build.command" failed    │
3:05:51 PM: └─────────────────────────────┘
3:05:51 PM: ​
3:05:51 PM:   Error message
3:05:51 PM:   Command failed with exit code 1: gatsby build
3:05:51 PM: ​
3:05:51 PM:   Error location
3:05:51 PM:   In Build command from settings:
3:05:51 PM:   gatsby build
3:05:51 PM: ​
3:05:51 PM:   Resolved config
3:05:51 PM:   build:
3:05:51 PM:     command: gatsby build
3:05:51 PM:     publish: /opt/build/repo/public
3:05:51 PM: Caching artifacts
3:05:51 PM: Started saving node modules
3:05:51 PM: Finished saving node modules
3:05:51 PM: Started saving build plugins
3:05:51 PM: Finished saving build plugins
3:05:51 PM: Started saving yarn cache
3:05:51 PM: Finished saving yarn cache
3:05:51 PM: Started saving pip cache
3:05:52 PM: Finished saving pip cache
3:05:52 PM: Started saving emacs cask dependencies
3:05:52 PM: Finished saving emacs cask dependencies
3:05:52 PM: Started saving maven dependencies
3:05:52 PM: Finished saving maven dependencies
3:05:52 PM: Started saving boot dependencies
3:05:52 PM: Finished saving boot dependencies
3:05:52 PM: Started saving go dependencies
3:05:52 PM: Finished saving go dependencies
3:05:55 PM: Error running command: Build script returned non-zero exit code: 1
3:05:55 PM: Failing build: Failed to build site
3:05:55 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
3:05:55 PM: Finished processing build request in 1m54.340988415s

npm run build

2:52:44 PM: Build ready to start
2:52:46 PM: build-image version: 3031d4c9e432fd7016f6279fc9ad706f9205d845
2:52:46 PM: build-image tag: v3.3.17
2:52:46 PM: buildbot version: da42b14a989873e00cc6f36bc354c01953474181
2:52:47 PM: Fetching cached dependencies
2:52:47 PM: Failed to fetch cache, continuing with build
2:52:47 PM: Starting to prepare the repo for build
2:52:47 PM: No cached dependencies found. Cloning fresh repo
2:52:47 PM: git clone https://github.com/stevenorechow/parallax
2:52:48 PM: Preparing Git Reference refs/heads/master
2:52:49 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
2:52:49 PM: Starting build script
2:52:49 PM: Installing dependencies
2:52:49 PM: Python version set to 2.7
2:52:50 PM: v12.18.0 is already installed.
2:52:51 PM: Now using node v12.18.0 (npm v6.14.4)
2:52:51 PM: Started restoring cached build plugins
2:52:51 PM: Finished restoring cached build plugins
2:52:51 PM: Attempting ruby version 2.7.1, read from environment
2:52:52 PM: Using ruby version 2.7.1
2:52:53 PM: Using PHP version 5.6
2:52:53 PM: 5.2 is already installed.
2:52:53 PM: Using Swift version 5.2
2:52:53 PM: Started restoring cached node modules
2:52:53 PM: Finished restoring cached node modules
2:52:53 PM: Started restoring cached yarn cache
2:52:53 PM: Finished restoring cached yarn cache
2:52:53 PM: Installing yarn at version 1.22.4
2:52:53 PM: Installing Yarn!
2:52:53 PM: > Downloading tarball...
2:52:53 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz --> /tmp/yarn.tar.gz.7HKgMrH7uK
2:52:53 PM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
2:52:53 PM:                                  Dload  Upload   Total   Spent    Left  Speed
2:52:53 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
2:52:53 PM:   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
2:52:53 PM: 100    80  100    80    0     0    293      0 --:--:-- --:--:-- --:--:--   293
2:52:53 PM: 100    93  100    93    0     0    157      0 --:--:-- --:--:-- --:--:--   157
2:52:54 PM: 100   630  100   630    0     0    724      0 --:--:-- --:--:-- --:--:--   724
2:52:54 PM:  11 1215k   11  134k    0     0   111k      0  0:00:10  0:00:01  0:00:09  111k
2:52:54 PM: 100 1215k  100 1215k    0     0   936k      0  0:00:01  0:00:01 --:--:-- 12.4M
2:52:54 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc --> /tmp/yarn.tar.gz.7HKgMrH7uK.asc
2:52:54 PM: 100    84  100    84    0     0   3057      0 --:--:-- --:--:-- --:--:--  3057
2:52:54 PM: 100    97  100    97    0     0   1767      0 --:--:-- --:--:-- --:--:--  1767
2:52:54 PM: 100   634  100   634    0     0   7019      0 --:--:-- --:--:-- --:--:--  7019
2:52:54 PM: 100  1028  100  1028    0     0   7864      0 --:--:-- --:--:-- --:--:--  7864
2:52:54 PM: > Verifying integrity...
2:52:54 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
2:52:54 PM: gpg: Good signature from "Yarn Packaging <yarn@dan.cx>"
2:52:54 PM: gpg: WARNING: This key is not certified with a trusted signature!
2:52:54 PM: gpg:          There is no indication that the signature belongs to the owner.
2:52:54 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
2:52:54 PM:      Subkey fingerprint: 6D98 490C 6F1A CDDD 448E  4595 4F77 6793 6947 5BAA
2:52:54 PM: > GPG signature looks good
2:52:54 PM: > Extracting to ~/.yarn...
2:52:54 PM: > Adding to $PATH...
2:52:55 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the `yarn` command will now be available.
2:52:55 PM: Installing NPM modules using Yarn version 1.22.4
2:52:55 PM: yarn install v1.22.4
2:52:56 PM: [1/4] Resolving packages...
2:52:57 PM: [2/4] Fetching packages...
2:53:06 PM: warning url-loader@1.1.2: Invalid bin field for "url-loader".
2:53:22 PM: info fsevents@2.1.3: The platform "linux" is incompatible with this module.
2:53:22 PM: info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
2:53:22 PM: info fsevents@1.2.13: The platform "linux" is incompatible with this module.
2:53:22 PM: info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
2:53:22 PM: [3/4] Linking dependencies...
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > @emotion/styled@10.0.27" has unmet peer dependency "@emotion/core@^10.0.27".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion@4.3.2" has unmet peer dependency "@babel/core@^7.0.0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion@4.3.2" has unmet peer dependency "@emotion/core@^10.0.5".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-mdx@1.2.13" has unmet peer dependency "@mdx-js/react@^1.0.0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-theme-ui@0.3.0" has incorrect peer dependency "theme-ui@^0.2.0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > @emotion/styled > @emotion/styled-base@10.0.31" has unmet peer dependency "@emotion/core@^10.0.28".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop@10.0.27" has unmet peer dependency "@babel/core@^7.0.0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @babel/plugin-transform-react-jsx@7.10.1" has unmet peer dependency "@babel/core@^7.0.0-0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @emotion/babel-plugin-jsx-pragmatic@0.1.5" has unmet peer dependency "@babel/core@^7.0.0".
2:53:22 PM: warning "@lekoarts/gatsby-theme-cara > gatsby-plugin-emotion > @emotion/babel-preset-css-prop > @babel/plugin-transform-react-jsx > @babel/plugin-syntax-jsx@7.10.1" has unmet peer dependency "@babel/core@^7.0.0-0".
2:53:22 PM: warning "gatsby > @pmmmwh/react-refresh-webpack-plugin@0.3.2" has incorrect peer dependency "react-refresh@^0.8.2".
2:53:22 PM: warning "gatsby > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
2:53:22 PM: warning "gatsby-plugin-netlify > webpack-assets-manifest@3.1.1" has unmet peer dependency "webpack@>=4.4.0".
2:53:35 PM: [4/4] Building fresh packages...
2:53:44 PM: Done in 48.08s.
2:53:44 PM: NPM modules installed using Yarn
2:53:44 PM: Started restoring cached go cache
2:53:44 PM: Finished restoring cached go cache
2:53:44 PM: go version go1.14.4 linux/amd64
2:53:44 PM: go version go1.14.4 linux/amd64
2:53:44 PM: Installing missing commands
2:53:44 PM: Verify run directory
2:53:45 PM: ​
2:53:45 PM: ┌─────────────────────────────┐
2:53:45 PM: │        Netlify Build        │
2:53:45 PM: └─────────────────────────────┘
2:53:45 PM: ​
2:53:45 PM: ❯ Version
2:53:45 PM:   @netlify/build 2.0.10
2:53:45 PM: ​
2:53:45 PM: ❯ Flags
2:53:45 PM:   deployId: 5eed259cee3a4301966398a4
2:53:45 PM:   mode: buildbot
2:53:45 PM: ​
2:53:45 PM: ❯ Current directory
2:53:45 PM:   /opt/build/repo
2:53:45 PM: ​
2:53:45 PM: ❯ Config file
2:53:45 PM:   No config file was defined: using default values.
2:53:45 PM: ​
2:53:45 PM: ❯ Context
2:53:45 PM:   production
2:53:45 PM: ​
2:53:45 PM: ┌────────────────────────────────┐
2:53:45 PM: │ 1. Build command from settings │
2:53:45 PM: └────────────────────────────────┘
2:53:45 PM: ​
2:53:45 PM: $ npm run build
2:53:45 PM: > cara@0.1.5 build /opt/build/repo
2:53:45 PM: > gatsby build
2:53:48 PM: success open and validate gatsby-configs - 0.036s
2:53:48 PM: success load plugins - 0.641s
2:53:49 PM: warning The Google Analytics plugin requires a tracking ID. Did you mean to add it?
2:53:49 PM: success onPreInit - 0.020s
2:53:49 PM: success delete html and css files from previous builds - 0.013s
2:53:49 PM: success initialize cache - 0.007s
2:53:49 PM: success copy gatsby files - 0.026s
2:53:49 PM: success onPreBootstrap - 0.008s
2:53:49 PM: success createSchemaCustomization - 0.003s
2:53:49 PM: success source and transform nodes - 0.728s
2:53:50 PM: success building schema - 0.300s
2:53:50 PM: success createPages - 0.019s
2:53:50 PM: success createPagesStatefully - 0.042s
2:53:50 PM: success onPreExtractQueries - 0.001s
2:53:50 PM: success update schema - 0.033s
2:53:50 PM: success extract queries from components - 0.183s
2:53:50 PM: success write out requires - 0.003s
2:53:50 PM: success write out redirect data - 0.001s
2:53:50 PM: success Build manifest and related icons - 0.001s
2:53:50 PM: success onPostBootstrap - 0.002s
2:53:50 PM: ⠀
2:53:50 PM: info bootstrap finished - 4.686s
2:53:50 PM: ⠀
2:54:14 PM: failed Building production JavaScript and CSS bundles - 23.730s
2:54:14 PM: error Generating JavaScript bundles failed
2:54:14 PM: unknown: Expected corresponding JSX closing tag for <br> (35:0)
2:54:14 PM:   33 | >
2:54:14 PM:   34 |   Add nice things people have said about your work, or your favourite quote. <br><i>“'You miss 100% of the shots you don't take.' — Wayne Gretzky”</i> —Michael Scott
> 35 | </ProjectCard>
2:54:14 PM:      | ^
2:54:14 PM:   36 | <ProjectCard
2:54:14 PM:   37 |   title="Whatever Else"
2:54:14 PM:   38 |   link="https://stevenorechow.me/"/opt/build/repo/src/@lekoarts/gatsby-theme-cara/sections/projects.mdx: unknown: Expected corresponding JSX closing tag for <br> (35:0)
2:54:14 PM:   33 | >
2:54:14 PM:   34 |   Add nice things people have said about your work, or your favourite quote. <br><i>“'You miss 100% of the shots you don't take.' — Wayne Gretzky”</i> —Michael Scott
> 35 | </ProjectCard>
2:54:14 PM:      | ^
2:54:14 PM:   36 | <ProjectCard
2:54:14 PM:   37 |   title="Whatever Else"
2:54:14 PM:   38 |   link="https://stevenorechow.me/"
2:54:14 PM: not finished run queries - 23.751s
2:54:14 PM: npm ERR! code ELIFECYCLE
2:54:14 PM: npm ERR! errno 1
2:54:14 PM: npm ERR! cara@0.1.5 build: `gatsby build`
2:54:14 PM: npm ERR! Exit status 1
2:54:14 PM: npm ERR!
2:54:14 PM: npm ERR! Failed at the cara@0.1.5 build script.
2:54:14 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
2:54:14 PM: npm ERR! A complete log of this run can be found in:
2:54:14 PM: npm ERR!     /opt/buildhome/.npm/_logs/2020-06-19T20_54_14_201Z-debug.log
2:54:14 PM: ​
2:54:14 PM: ┌─────────────────────────────┐
2:54:14 PM: │   "build.command" failed    │
2:54:14 PM: └─────────────────────────────┘
2:54:14 PM: ​
2:54:14 PM:   Error message
2:54:14 PM:   Command failed with exit code 1: npm run build
2:54:14 PM: ​
2:54:14 PM:   Error location
2:54:14 PM:   In Build command from settings:
2:54:14 PM:   npm run build
2:54:14 PM: ​
2:54:14 PM:   Resolved config
2:54:14 PM:   build:
2:54:14 PM:     command: npm run build
2:54:14 PM:     publish: /opt/build/repo/public
2:54:14 PM: Caching artifacts
2:54:14 PM: Started saving node modules
2:54:14 PM: Finished saving node modules
2:54:14 PM: Started saving build plugins
2:54:14 PM: Finished saving build plugins
2:54:14 PM: Started saving yarn cache
2:54:14 PM: Finished saving yarn cache
2:54:14 PM: Started saving pip cache
2:54:14 PM: Finished saving pip cache
2:54:14 PM: Started saving emacs cask dependencies
2:54:14 PM: Finished saving emacs cask dependencies
2:54:14 PM: Started saving maven dependencies
2:54:14 PM: Finished saving maven dependencies
2:54:14 PM: Started saving boot dependencies
2:54:14 PM: Finished saving boot dependencies
2:54:14 PM: Started saving go dependencies
2:54:14 PM: Finished saving go dependencies
2:54:17 PM: Error running command: Build script returned non-zero exit code: 1
2:54:17 PM: Failing build: Failed to build site
2:54:17 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
2:54:17 PM: Finished processing build request in 1m30.409637652s

Your time and help would be much appreciated! Please let me know of any info I may have missed. Thank you!

Hey @stevenaaron,
Since this was working for your previously, I don’t think the issue is with the build command. Your error logs say, in a few places:

2:05:51 PM: error Generating JavaScript bundles failed
2:05:51 PM: unknown: Expected corresponding JSX closing tag for <br> (35:0)

Do you want to fix those closing tags and try deploying again?

Ugh, I’m sorry, that was dumb. But your response helped me figure it out, thank you!

Awesome, glad to hear :tada: