Default thank you page doesn't show on form submit

Hey Folks,

I am receiving the data upon pressing submit button on the form but the default thank-you screen doesn’t show up. Here are things that I did to debug the situation.

  1. Read the netlify documentation to make sure the right parameters are set.
  2. Checked using dev tools to identify the network activity caused by clicking submit button. And I see netlify sends the response correctly but it’s not shown by the browser.
    image
  3. Finally, I replaced the default thank-you with my own html file and changed action="/my_thank_you.html" but the same issue persisted.

Here’s my form. I would really appreciate if you could help identify the issue here. Thanks!

<form name="index_contact" method="POST" data-netlify="true">
          <div class="group">
            <input type="text" name="name" required />
            <label>Your name</label
            ><span class="error">Please enter your name</span>
          </div>
          <div class="group">
            <input type="text" name="email" class="required" required />
            <label>Your email</label
            ><span class="error"
              >Please enter your email address in format: email@gmail.com</span
            >
          </div>
          <div class="group">
            <textarea name="message" class="required" required></textarea>
            <label>Your message</label
            ><span class="error">Please enter your message</span>
          </div>
          <div class="text-center">
            <button type="submit" value="Send message" class="btn send_mail">
              Send message
            </button>
          </div>
        </form>

hi there, first of all, did you check this guide?

here is another thread that might be helpful:

If you can’t fix the issue, let us know and we’ll take another look.

Hi Perry,

I read both threads multiple times. I changed "method="Post" to action="thank-you" but the thank you message from your server doesn’t get shown upon clicking Send message button.

@mishraka, thanks for writing in. Can you share a link to the live form that you’re having trouble with? Thanks.

Thanks @futuregerald @perry! Here’s the link to the live form: https://www.trisetra.com/index.html

@mishraka, the form on the bottom of that page attempts to submit to a php file (https://www.trisetra.com/mail/mail.php), which won’t work because Netlify isn’t processing your PHP. Can you clarify which form you’re trying to use with Netlify forms that’s not working?

@futuregerald Thanks so much for identifying the problem! I removed the value send_mail from the class attribute and it works now.

1 Like