Dashboard bug with asset optimization settings

Just here to point out what seems to be a bug with the asset optimization settings. With the default, like this:

A file built at /page/index.html and accessed by the URL https://mysite.com/page got an unwanted 301 redirect to https://mysite.com/page/.

By unticking ‘Disable asset optimization’, unticking all of the options below then reticking ‘Disable asset optimization’, which looks UI-wise like exactly the same thing, the 301 disappeared.

There is definitely a difference between having everything unchecked and having disable asset optimization checked, not really a bug but we don’t communicate it well.

Glad to hear you found a good solution for yourself in doing so though!

We have some open issues on getting that explained better in the UI so it is likely things will improve in the future there, too.