Connection refused: exit status 128

I’ve deployed several sites (Hugo, Jekyll, Gatsby) on Netlify using the ‘Deploy’ buttons found on staticgen.com. But now I get the same type of error message and the deploys fail constantly. Just tried to deploy new repos for Middleman and Jekyll. Here’s the latest error:

10:31:46 PM: Build ready to start
10:31:47 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
10:31:47 PM: build-image tag: v3.3.5
10:31:47 PM: buildbot version: 2d05064ce3dd2eb95d282a24602ab707dd9581e8
10:31:48 PM: Fetching cached dependencies
10:31:48 PM: Failed to fetch cache, continuing with build
10:31:48 PM: Starting to prepare the repo for build
10:31:48 PM: Failing build: Failed to prepare repo
10:31:48 PM: failed during stage ‘preparing repo’: error checking for ref: fatal: unable to access ‘https://undefined.com/start/netlify-templates/jekyll-base/’: Failed to connect to undefined.com port 443: Connection refused: exit status 128

This happens on all three of my machines. I haven’t changed any GitHub settings, and I maintain the SSH key pairings. The GitHub repo gets created just fine, and I get notification of the Netlify Deploy Key pairing.

Do I need to control that port?

This is some kind of a bug in the templates or the deploy to netlify button functionality. I’ve asked the team to look into this next week.

You are not doing anything wrong!

1 Like

Ok. Thank you!

I’ll keep a lookout.

An issue has been filed for this. We’ll update here once a fix is deployed. Thank you for your patience.

1 Like