[Common Issue] How can I optimize my Netlify build time?

Doesn’t seem like 502’s would be related, no, @salmonax. 502 usually means that you have a very large site that isn’t being synced fast enough. You could try adding a --timeout 900 flag with your CLI usage to see if it helps.

heya @dannyrb , sure - you can publish from Circle but the most obvious path would be to use our cli to publish it directly, sending the already-built files from Circle. The default netlify deploy publishes in “draft” mode which is what some call a deploy preview (but the URL will be something like https://hash--yoursitename.netlify.com rather than the “usual” deploy-preview-xyz--sitename.netlify.com") - regardless, it is not published at your production URL automatically which is what I think you are after :slight_smile: You could also choose to trigger a build only via Circle - but it’d be for HEAD on whatever branch, rather than the specific commit that Circle built. You’d use that via an incoming build hook which we can configure to build even when the “usual” automatic commit-based deploys are turned off.

I’d use the second workflow to “gate” those deploys - only build on certain conditions, which you can check for at Circle.

Let me know what you think, and I can help reconfigure (either removing the repo link entirely so you MUST publish with the CLI, or deconfiguring automatic builds in favor of webhooks you configure).

Sure, tis done, @marcveens !

1 Like

Hi @fool, would it be possible to get the continuous deployment turned off for 82f2b155-bee3-4040-afdc-42127eabdae1 please?

sure thing @saul, tis done.

1 Like

@fool Thanks for the help, timeout worked for the 502. We’re changing our pipeline a bit, though and I think we’d like to turn native CI back on. ^^; App ID was 325b803a-d3c8-4d2e-9b1c-5c6a34025923.

Done, automatic deploys have been re-enabled.