CNAME records do not redirect to desired address

Hey all!

Having a problem redirecting by CNAME records. I receive a 404 from… github pages? I’ve turned off branch previews to ensure this wasn’t causing an error. But from what i can see here i don’t understand why a straight CNAME redirect cannot happen.

The record details:
tundra.danieltamkin.com 1800 IN CNAME tundradawn.co

When navigating to tundra.danieltamkin.com i get this:

Very strange,
Hope this is just a quick fix on my end, and not a limitation of the Netlify DNS system.

@danieltamkin Welcome to the Netlify community.

It appears that the reason this CNAME entry isn’t working is because the tundra subdomain uses hover.com for DNS, not Netlify, even though your bare custom domain name does use Netlify for DNS. Therefore, requests for the tundra subdomain are never reaching Netlify DNS, which means that CNAME entry will never be seen.

Thanks for the prompt & detailed reply @gregraven :blush:

This outcome is not the greatest though, the only other option is to not utilize Netlify DNS so i can redirect outside of the Netlify DNS name-servers no? I’ve never had this problem with Hover or digitalocean or any other platform before. However this would force me to manually setup HTTPS + redirect to the internal netlify.app subdomain.

@danieltamkin First, you don’t have to use Netlify DNS. It just happens to be really great.

Second, why can’t you have this entry in Netlify DNS instead of with Hover? You already have the apex domain served by Netlify DNS, it seems that it would make more sense to make your CNAME entry there.

Third, I don’t know how you got around this with Hover and/or Digital Ocean, but this is not a Netlify issue but rather an issue with the way that you’ve set up your subdomain. It’s the way DNS is supposed to work.

Finally, I don’t understand your point about a HTTPS redirect. The internal Netlify subdomain is automatically served over HTTPS, so you shouldn’t have to force anything. And if you set up A and CNAME records for your www subdomain to point to Netlify, as detailed in the docs, it should just work.

Sorry didn’t explain myself well, meant if i don’t use Netlify DNS i’ll have to manually go about setting up a certificate for https. However You pointed out that the netlify.app subdomain is served HTTPS, so it should just work. Thanks! (Would you be able to link to the docs you mention @gregraven? )

And for your other points, i’m dumb! I totally didn’t realize that Hover’s forwarding mechanism was a feature they handled. I must’ve been using that feature instead of CNAME for subdomain -> URL redirects. That mechanism requires me to to use hovers DNS servers though.

Sorry for the slightly irrelevant question then! However i hope if anyone else finds this it’ll help them out :blush:

@danieltamkin Here you go:

Thanks for the help @gregraven :blush:

1 Like