CI indicate "In progress" in GitHub PR but is finished

It’s not the first time that in a PR, the Netlify build indicate “In progress” for hours in GitHub when on Netlify.com it’s “finished”:

Netlify / Header rules - letsencrypt started 20h 19m 7s ago

But on netlify.com it’s finished since a long time:

Build time: 38s. Total deploy time: 50s
Build started at 10:12:04 PM and ended at 10:12:42 PM.

10:13:26 PM: Finished processing build request in 1m21.354805748s

The previous time it was on https://github.com/letsencrypt/website/runs/465941656

2 Likes

This seems like a frustrating bug and we appreciate the report- I’m filing an issue now with your links and screen shots.

I see that you’ve made PRs that successfully passed tests and were merge-able, so that would seem to rule out a permissions problem.

If possible, could you please share the deploy log from the previous time this happened so I can add it to the bug report? Thanks again.

1 Like

It’s fine, just annoying :sweat_smile:

The logs of https://github.com/letsencrypt/website/runs/465941656 was https://app.netlify.com/sites/letsencrypt/deploys/5e54575311ef3900085a6bc8 , is that what you need?

If it helps, it happend again with https://github.com/letsencrypt/website/pull/1004/checks?check_run_id=507974737

Thank you, I’ve added that to the open issue! We’re looking into this and will update this post as soon as we have more information.

1 Like

Hey @tdelmas, wanted to give you an update here: our backend team has shipped an update that we hope will mitigate this problem. It won’t retroactively complete old checks, but should allow new checks to fully run. Please let us know if you continue to experience this issue!

2 Likes

Thank you @jen! (for old checks on open PRs I’ll just update them from master to force CI to run again :wink:)