Changes coming to Netlify site URLs

there is no “www.blaze-in-saddle.netlify.app”, Greg - only “blaze-in-saddle.netlify.app”. Try updating that and I bet it works better!

The playground only says if there is a syntax error, not a semantics error like that…

We did indeed remove the “docs box” which was in app with that advice, since we do this now instead, to prevent the SEO hit from not so doing:

Sorry for the typo, but it still doesn’t work. Neither the netlify.app nor the netlify.com versions redirect to the custom domain name. At any rate, I’m currently unable to log into my Netlify dashboard so I can’t make any changes or corrections right now.

Never mind. This issue may be connected to a DNS setting on my end. When I switched from Cloudflare 1.1.1.1 to NameCheap SafeServe 198.54.117.10 as my public resolver, the redirects occur as expected.

We also had issues with CORS headers, specifically to a lambda function we use with a POST request as payment gateway. Because of the redirect, it stopped working completely because of CORS issues, we lost customers because of it!

Hi There ! First of all thanks for the awesome work :slight_smile: I’ve been deploying static website very easily thanks to netlify !
My app is located at commentor.netlify.app (former commentor.netlify.com) and the transition you made was pretty smooth for new users. However we made a looot of updates these days and the users that had already visited my website before the transition can still find the former version of the website (not functional anymore :slight_smile: ) when they reach commentor.netlify.com. Is this due to a cache policy of some sort ? I receive a 304 from service worker. I can’t figure out how to prevent this behaviour for my current users.
(When I reach the website form a new private brower window, I indeed receive a 301 and everything works fine)

hey maxime, i just checked your URL and it seems to be forwarding as expected to commentor.netlify.app when i try and access commentor.netlify.com

are you still seeing something different?

Hi there ! Thanks for your rapid reply ! Yes, as I said in my previous comment, the issue I’m talking about only concerns people who already visited commentor.netlify.com before the transition :slight_smile: (I would be honored if it was your case but I doubt it :wink: )

In this particular case, the user sees an older version of the website and I can’t update it anymore. When I inspect the network I see a 304 (“From service worker”) instead of the regular 301.

I’m using a custom domain, and not experiencing any issues.

However, I was wondering if there were plans to update the DNS settings to point to the canonical “.app” domain.

Right now, going to Settings > Domains > clicking my domain name, under “DNS Settings” the records of type “NETLIFY” both point to the “.com” versions of the URL and each say “This is a system record that cannot be managed directly.”

If there’s any way of forcing this to update, please let me know! Thanks.

Hello there, any news on this ? I’m still experiencing the issue

At a guess, your service worker is misbehaving; likely you have allowed it to be cached for too long (default is a day and that would have passed by now).

This isn’t a “direct” answer to your question, but more about a best practice on using service workers here:

It is unfortunately very hard to fix bad caching settings in retrospect - you basically need to entice visitors to visit some new page where you can deregister the badly cached version.

Sorry I don’t have better news for you today!

Hey guys, even though this has been done…and I just noticed the notification has been since February, it does affect some sites. Mainly those with CORS configs limiting the domains that can reach their servers. We only discovered this issue once our customers where unable to login. Although I’m not sure there’s any other way you could have notified us(as our account is a not controlled by the individual developers). Just wanted to state that…for the record

Hi there,
I’ve noticed something disturbing going on with the new Netlify domain. Twitter just added netlify.app to a blacklist. This is very bad news for site owners who don’t have a custom domain and who care about social media presence. From now on,

  • Twitter users who are about to enter a site in netlify.app subdomain will see warning message that the link can be dangerous (example: https://t.co/93DBiGxK3q).
  • what’s more, a tweet containing a link to netlify.app site has limited visibility: it is hidden from search results, replies and timelines to everyone but the author of the tweet.

It’s worth noting, that the old netlify.com domain is not affected and its links work as usual.

I hope there is something that can be done to unlock netlify.app on Twitter. Maybe Netlify staff can verify ownership of the domain or something, so Twitter knows that the domain is trusted.

Edit: Never mind. Looks like it’s been resolved and is back to normal.

1 Like

Heya and sorry to hear about the trouble @noxecane!

We sent several email notifications to the account owner(s). It is your responsibility, no matter what the nature of your account, to make sure those emails get read, as they also include e.g. billing notices that will lead to account shutdown if not acted upon. So, please make sure some attentive human is at the other end of the email address for the first owner on the account’s member list!

My site’s blog links from “realnitinworks.netlify.com” and now “realnitinworks.netlify.app” when accessed from twitter, linkedin etc, reports “malicious access” to the user. What can I do to avoid this problem?

1 Like

I have the same problem. It also is considered spam by Gmail.

Anyone have an update on this?

1 Like

Gmail is also black listing netlify.app.

1 Like

Twitter is throwing warnings up when people click on links to my site. Site went live Saturday long after the .com » .app migration. Are there docs/threads/details on how to resolve this issue?

Do we have some update on this issue. Seem others are also having the same issue.

hi all, I’m sorry to hear about these reports listing us as malicious. Of course we are as concerned about this as you are (if not more) and we are trying to work with the companies in question to fix this situation.

The problem arises because Netlify is, for many people, a free service, and so spammers and people looking to host illegal websites use us. When those sites get flagged as spam, it affects how search engines and large social media sites treat us. It is, ultimately, the fault of malicious people looking to abuse our service which is bad for everyone :face_with_head_bandage:

The solution is for us to keep working with twitter, google, etc but this is a bit of a long winded process, as these are huge sites. nevertheless we are doing everything we can as fast as we can to improve things.

You can help us by using this form for Twitter: https://help.twitter.com/forms/spam

For Linkedin, we think you can use this form: https://www.linkedin.com/help/linkedin/ask/TS-RPS to indicate that the site isn’t spam.

If enough people tell twitter that .app sites aren’t all spam, this will help speed things up.

Thank you for your patience as we keep working on this. If there are any big changes we will post here, but you can also let us know if things improve. :pray:

1 Like

Hi, it appears that any domain with Covid19 in the title is also being flagged. For example, our domain covid19cardiology.com is being blocked in some organizations. Interestingly, the netlify.app subdomain works just fine. Do you have any suggestions with regards to this issue? Thank you!