Can't see a list of my GitLab repos to connect netlify to

Hi,

I’m trying to connect to a repo in my GitLab account, but getting stuck somehow.
Here’s what’s happening:

  • In Netlify, I go to ‘create a new site’ (here in effect: https://app.netlify.com/start ), and choose ‘GitLab’ under ‘continuous deployment’ heading. It opens up a new window, and shows ‘Authorised’
  • I look at GitLab, and go to ‘settings’, and then ‘applications’, I can see that Netlify is an authorized application.

No GitLab repos showed at this stage, so I also then revoked the application on GitLab, and tried again from the ‘create new site’, and click on the ‘allow’ button at the permissions screen, and then I see ‘authorized’ again, and still no repos show.

It’s not working because I can’t move forward to the ‘pick a repository’ section of the start page.

Any suggestions, please?

Many thanks,

James

I realised that I was perhaps missing a webhook in gitlab, and so I’ve added that, but unfortunately this issue still continues.

I have exactly the same issue with connecting to my gitlab account.
Any help would be appreciated! :slight_smile:

Thanks in advance!

I click on the ‘create a new site’ (here; https://app.netlify.com/start ), and then I select GitHub, and it shows as being authenticated. Yet I can never get to connect it to a specific repo. Exact same happens with gitlab. I can see netlify as an ‘authorised github app’, and also the same in github.

I’ve read this page: https://www.netlify.com/docs/github-permissions/ but the screenshots, and info don’t really match up with anything that I see either within netlify or gitlab!

I’ve tried so much to try to get this working so far! Any thoughts on what I need to do would be gratefully received, please? :slight_smile:

I posted a similar question elsewhere in the forum, but have not had a response since yesterday; I’m sure it’s something simple that I’ve not done!

The usual reason for not seeing a repo on GitLab (or Bitbucket) in our repo linking UI is that you are not an administrator on that repo. Can you confirm that you are either an owner or an administrator (can create webhooks) at GitLab on the missing repo(s)?

GitHub is quite different since it uses the app entirely. While you’ve authorized the GitHub app probably for your own repos, do you also own the repo(s) you don’t see, or might they belong to an org as well?