Cant deploy my jekyll blog

I need advice to debug deploy

my last deploy log :

7:41:58 PM: Build ready to start
7:41:59 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
7:41:59 PM: build-image tag: v3.3.5
7:41:59 PM: buildbot version: 036f37945d6de439a17a554b3ae02e2f8f0f1fb0
7:42:00 PM: Fetching cached dependencies
7:42:00 PM: Failed to fetch cache, continuing with build
7:42:00 PM: Starting to prepare the repo for build
7:42:01 PM: No cached dependencies found. Cloning fresh repo
7:42:01 PM: git clone git@gitlab .com:KavehRS/blog
7:42:07 PM: Preparing Git Reference refs/heads/master
7:42:08 PM: Starting build script
7:42:08 PM: Installing dependencies
7:42:09 PM: Downloading and installing node v10.18.1...
7:42:10 PM: Downloading https:// nodejs .org/dist/v10.18.1/node-v10.18.1-linux-x64.tar.xz...
7:42:10 PM: 
#############################
7:42:10 PM:               41.1%
7:42:10 PM: 
########################################################################         100.0%
7:42:10 PM: Computing checksum with sha256sum
7:42:10 PM: Checksums matched!
7:42:13 PM: Now using node v10.18.1 (npm v6.13.4)
7:42:13 PM: Attempting ruby version 2.6.2, read from environment
7:42:15 PM: Using ruby version 2.6.2
7:42:15 PM: Using bundler version 2.1.4 from Gemfile.lock
7:42:20 PM: Successfully installed bundler-2.1.4
7:42:20 PM: Parsing documentation for bundler-2.1.4
7:42:20 PM: Installing ri documentation for bundler-2.1.4
7:42:20 PM: Done installing documentation for bundler after 3 seconds
7:42:20 PM: 1 gem installed
7:42:20 PM: Using PHP version 5.6
7:42:20 PM: Started restoring cached ruby gems
7:42:20 PM: Finished restoring cached ruby gems
7:42:20 PM: Installing gem bundle
7:42:20 PM: [DEPRECATED] The `--path` flag is deprecated because it relies on being  remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use `bundle config set path '/opt/build/cache/bundle'`, and stop using this flag
7:42:20 PM: [DEPRECATED] The --binstubs option will be removed in favor of `bundle binstubs`
7:42:22 PM: Fetching gem metadata from https ://rubygems .org/
7:42:22 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:23 PM: .
7:42:24 PM: Fetching public_suffix 4.0.3
7:42:24 PM: Installing public_suffix 4.0.3
7:42:24 PM: Fetching addressable 2.7.0
7:42:24 PM: Installing addressable 2.7.0
7:42:24 PM: Using bundler 2.1.4
7:42:24 PM: Fetching colorator 1.1.0
7:42:24 PM: Installing colorator 1.1.0
7:42:24 PM: Fetching concurrent-ruby 1.1.5
7:42:24 PM: Installing concurrent-ruby 1.1.5
7:42:25 PM: Fetching eventmachine 1.2.7
7:42:25 PM: Installing eventmachine 1.2.7 with native extensions
7:42:44 PM: Fetching http_parser.rb 0.6.0
7:42:44 PM: Installing http_parser.rb 0.6.0 with native extensions
7:42:46 PM: Fetching em-websocket 0.5.1
7:42:46 PM: Installing em-websocket 0.5.1
7:42:46 PM: Fetching ffi 1.12.1
7:42:46 PM: Installing ffi 1.12.1 with native extensions
7:42:56 PM: Fetching forwardable-extended 2.6.0
7:42:56 PM: Installing forwardable-extended 2.6.0
7:42:56 PM: Fetching i18n 1.8.2
7:42:56 PM: Installing i18n 1.8.2
7:42:56 PM: Fetching sassc 2.2.1
7:42:56 PM: Installing sassc 2.2.1 with native extensions

7:45:50 PM: Fetching jekyll-sass-converter 2.0.1
7:45:50 PM: Installing jekyll-sass-converter 2.0.1
7:45:50 PM: Fetching rb-fsevent 0.10.3
7:45:50 PM: Installing rb-fsevent 0.10.3
7:45:50 PM: Fetching rb-inotify 0.10.1
7:45:51 PM: Installing rb-inotify 0.10.1
7:45:51 PM: Fetching listen 3.2.1
7:45:51 PM: Installing listen 3.2.1
7:45:51 PM: Fetching jekyll-watch 2.2.1
7:45:51 PM: Installing jekyll-watch 2.2.1
7:45:51 PM: Fetching kramdown 2.1.0
7:45:51 PM: Installing kramdown 2.1.0
7:45:51 PM: Fetching kramdown-parser-gfm 1.1.0
7:45:51 PM: Installing kramdown-parser-gfm 1.1.0
7:45:51 PM: Fetching liquid 4.0.3
7:45:51 PM: Installing liquid 4.0.3
7:45:52 PM: Fetching mercenary 0.3.6
7:45:52 PM: Installing mercenary 0.3.6
7:45:52 PM: Fetching pathutil 0.16.2
7:45:52 PM: Installing pathutil 0.16.2
7:45:52 PM: Fetching rouge 3.15.0
7:45:52 PM: Installing rouge 3.15.0
7:45:52 PM: Fetching safe_yaml 1.0.5
7:45:52 PM: Installing safe_yaml 1.0.5
7:45:52 PM: Fetching unicode-display_width 1.6.1
7:45:52 PM: Installing unicode-display_width 1.6.1
7:45:52 PM: Fetching terminal-table 1.8.0
7:45:53 PM: Installing terminal-table 1.8.0
7:45:53 PM: Fetching jekyll 4.0.0
7:45:53 PM: Installing jekyll 4.0.0
7:45:53 PM: Fetching jekyll-feed 0.13.0
7:45:53 PM: Installing jekyll-feed 0.13.0
7:45:53 PM: Fetching jekyll-seo-tag 2.6.1
7:45:53 PM: Installing jekyll-seo-tag 2.6.1
7:45:53 PM: Fetching minima 2.5.1
7:45:53 PM: Installing minima 2.5.1
7:45:53 PM: Bundle complete! 6 Gemfile dependencies, 30 gems now installed.
7:45:53 PM: Bundled gems are installed into /opt/build/cache/bundle
7:45:53 PM: Post-install message from i18n:
7:45:53 PM: HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
7:45:53 PM: But that may break your application.
7:45:53 PM: If you are upgrading your Rails application from an older version of Rails:
7:45:53 PM: Please check your Rails app for ‘config.i18n.fallbacks = true’.
7:45:53 PM: If you’re using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
7:45:53 PM: ‘config.i18n.fallbacks = [I18n.default_locale]’.
7:45:53 PM: If not, fallbacks will be broken in your app by I18n 1.1.x.
7:45:53 PM: If you are starting a NEW Rails application, you can ignore this notice.
7:45:53 PM: For more info see:
7:45:53 PM: https: //github .com/svenfuchs/i18n/releases/tag/v1.1.0
7:45:53 PM: Post-install message from jekyll:
7:45:53 PM: -------------------------------------------------------------------------------------
7:45:53 PM: Jekyll 4.0 comes with some major changes, notably:
7:45:53 PM: * Our link tag now comes with the relative_url filter incorporated into it.
7:45:53 PM: You should no longer prepend {{ site.baseurl }} to {% link foo.md %}
7:45:53 PM: For further details: https://github.com/jekyll/jekyll/pull/6727
7:45:53 PM: * Our post_url tag now comes with the relative_url filter incorporated into it.
7:45:53 PM: You shouldn’t prepend {{ site.baseurl }} to {% post_url 2019-03-27-hello %}
7:45:53 PM: For further details: https :// github .com/jekyll/jekyll/pull/7589
7:45:53 PM: * Support for deprecated configuration options has been removed. We will no longer
7:45:53 PM: output a warning and gracefully assign their values to the newer counterparts
7:45:53 PM: internally.
7:45:53 PM: -------------------------------------------------------------------------------------
7:45:53 PM: Gem bundle installed
7:45:53 PM: Started restoring cached go cache
7:45:53 PM: Finished restoring cached go cache
7:45:53 PM: unset GOOS;
7:45:53 PM: unset GOARCH;
7:45:53 PM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;
7:45:53 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";
7:45:53 PM: go version >&2;
7:45:53 PM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
7:45:53 PM: go version go1.12 linux/amd64
7:45:53 PM: Installing missing commands
7:45:53 PM: Verify run directory
7:45:53 PM: Executing user command: sh scripts/bootstrap && sh scripts/build
7:45:53 PM: sh: 0: Can’t open scripts/bootstrap
7:45:53 PM: Skipping functions preparation step: no functions directory set
7:45:53 PM: Caching artifacts
7:45:53 PM: Started saving ruby gems
7:45:53 PM: Finished saving ruby gems
7:45:53 PM: Started saving pip cache
7:45:53 PM: Finished saving pip cache
7:45:53 PM: Started saving emacs cask dependencies
7:45:53 PM: Finished saving emacs cask dependencies
7:45:53 PM: Started saving maven dependencies
7:45:53 PM: Finished saving maven dependencies
7:45:53 PM: Started saving boot dependencies
7:45:53 PM: Finished saving boot dependencies
7:45:53 PM: Started saving go dependencies
7:45:53 PM: Finished saving go dependencies
7:45:56 PM: Error running command: Build script returned non-zero exit code: 127
7:45:56 PM: Failing build: Failed to build site
7:45:56 PM: failed during stage ‘building site’: Build script returned non-zero exit code: 127
7:45:57 PM: Finished processing build request in 3m57.095435451s

Hey @KavehRS,

Let’s take a look at some of the potential quick-fixes. The build configuration guide will talk you through which settings you will need to configure in order for your site to build. This ‘Common Issue’ post covers a few of the problems typically observed too.

Failing this, if you could provide some more specific details/logs, we can home in on this particular issue together.

Hi @Pieparker
I updated my post with the latest log

can you post a screenshot of your build settings please?

We also need to know the name of your netlify instance to properly debug. Example: fantastic-malevolence-54654.netlify.com

https://kavehrsblog.netlify.com/

can you post a screenshot of your build settings please?

Hi, @KavehRS, the error appears to be:

8:23:36 AM: sh: 0: Can't open scripts/bootstrap

My best guess is that this file doesn’t exist or, if it does, that its file permissions don’t include execute permissions.

Would you please add this to your build command to get more information about what that directory contains?

ls -l scripts

Meaning, the new build command would become:

ls -l scripts ; sh scripts/bootstrap && sh scripts/build

When this is done, do the logs show that directory containing the required scripts and that those scripts are executable?

after chang build command :

'4:07:41 PM: Build ready to start

4:07:43 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
4:07:43 PM: build-image tag: v3.3.5
4:07:43 PM: buildbot version: 2fd8f04962d5dbc77b79b9c2f5ab7a077e87376b
4:07:44 PM: Fetching cached dependencies
4:07:44 PM: Failed to fetch cache, continuing with build
4:07:44 PM: Starting to prepare the repo for build
4:07:44 PM: No cached dependencies found. Cloning fresh repo
4:07:44 PM: git clone git@gitlab.com:KavehRS/blog
4:07:48 PM: Preparing Git Reference refs/heads/master
4:07:49 PM: Starting build script
4:07:49 PM: Installing dependencies
4:07:50 PM: Downloading and installing node v10.19.0…
4:07:51 PM: Downloading https://nodejs.org/dist/v10.19.0/node-v10.19.0-linux-x64.tar.xz
4:07:51 PM:
#################################
4:07:51 PM: 46.4%
4:07:51 PM:
##########################################################
4:07:51 PM: ############## 100.0%
4:07:51 PM: Computing checksum with sha256sum
4:07:51 PM: Checksums matched!
4:07:54 PM: Now using node v10.19.0 (npm v6.13.4)
4:07:54 PM: Attempting ruby version 2.6.2, read from environment
4:07:55 PM: Using ruby version 2.6.2
4:07:55 PM: Using bundler version 2.1.4 from Gemfile.lock
4:08:01 PM: Successfully installed bundler-2.1.4
4:08:01 PM: Parsing documentation for bundler-2.1.4
4:08:01 PM: Installing ri documentation for bundler-2.1.4
4:08:01 PM: Done installing documentation for bundler after 4 seconds
4:08:01 PM: 1 gem installed
4:08:01 PM: Using PHP version 5.6
4:08:01 PM: Started restoring cached ruby gems
4:08:01 PM: Finished restoring cached ruby gems
4:08:01 PM: Installing gem bundle
4:08:02 PM: [DEPRECATED] The --path flag is deprecated because it relies on being remembered across bundler invocations, which bundler will no longer do in future versions. Instead please use bundle config set path '/opt/build/cache/bundle', and stop using this flag
4:08:02 PM: [DEPRECATED] The --binstubs option will be removed in favor of bundle binstubs
4:08:05 PM: Fetching gem metadata from https://rubygems.org/
4:08:05 PM: .
4:08:05 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:06 PM: .
4:08:07 PM: Fetching public_suffix 4.0.3
4:08:07 PM: Installing public_suffix 4.0.3
4:08:07 PM: Fetching addressable 2.7.0
4:08:07 PM: Installing addressable 2.7.0
4:08:07 PM: Using bundler 2.1.4
4:08:07 PM: Fetching colorator 1.1.0
4:08:07 PM: Installing colorator 1.1.0
4:08:07 PM: Fetching concurrent-ruby 1.1.5
4:08:07 PM: Installing concurrent-ruby 1.1.5
4:08:08 PM: Fetching eventmachine 1.2.7
4:08:08 PM: Installing eventmachine 1.2.7 with native extensions
4:08:26 PM: Fetching http_parser.rb 0.6.0
4:08:26 PM: Installing http_parser.rb 0.6.0 with native extensions
4:08:28 PM: Fetching em-websocket 0.5.1
4:08:28 PM: Installing em-websocket 0.5.1
4:08:28 PM: Fetching ffi 1.12.1
4:08:28 PM: Installing ffi 1.12.1 with native extensions
4:08:37 PM: Fetching forwardable-extended 2.6.0
4:08:37 PM: Installing forwardable-extended 2.6.0
4:08:37 PM: Fetching i18n 1.8.2
4:08:37 PM: Installing i18n 1.8.2
4:08:37 PM: Fetching sassc 2.2.1
4:08:37 PM: Installing sassc 2.2.1 with native extensions
4:11:33 PM: Fetching jekyll-sass-converter 2.0.1
4:11:33 PM: Installing jekyll-sass-converter 2.0.1
4:11:33 PM: Fetching rb-fsevent 0.10.3
4:11:33 PM: Installing rb-fsevent 0.10.3
4:11:33 PM: Fetching rb-inotify 0.10.1
4:11:33 PM: Installing rb-inotify 0.10.1
4:11:33 PM: Fetching listen 3.2.1
4:11:33 PM: Installing listen 3.2.1
4:11:33 PM: Fetching jekyll-watch 2.2.1
4:11:33 PM: Installing jekyll-watch 2.2.1
4:11:33 PM: Fetching kramdown 2.1.0
4:11:33 PM: Installing kramdown 2.1.0
4:11:34 PM: Fetching kramdown-parser-gfm 1.1.0
4:11:34 PM: Installing kramdown-parser-gfm 1.1.0
4:11:34 PM: Fetching liquid 4.0.3
4:11:34 PM: Installing liquid 4.0.3
4:11:34 PM: Fetching mercenary 0.3.6
4:11:34 PM: Installing mercenary 0.3.6
4:11:34 PM: Fetching pathutil 0.16.2
4:11:34 PM: Installing pathutil 0.16.2
4:11:34 PM: Fetching rouge 3.15.0
4:11:34 PM: Installing rouge 3.15.0
4:11:35 PM: Fetching safe_yaml 1.0.5
4:11:35 PM: Installing safe_yaml 1.0.5
4:11:35 PM: Fetching unicode-display_width 1.6.1
4:11:35 PM: Installing unicode-display_width 1.6.1
4:11:35 PM: Fetching terminal-table 1.8.0
4:11:35 PM: Installing terminal-table 1.8.0
4:11:35 PM: Fetching jekyll 4.0.0
4:11:35 PM: Installing jekyll 4.0.0
4:11:35 PM: Fetching jekyll-feed 0.13.0
4:11:35 PM: Installing jekyll-feed 0.13.0
4:11:35 PM: Fetching jekyll-seo-tag 2.6.1
4:11:35 PM: Installing jekyll-seo-tag 2.6.1
4:11:36 PM: Fetching minima 2.5.1
4:11:36 PM: Installing minima 2.5.1
4:11:36 PM: Bundle complete! 6 Gemfile dependencies, 30 gems now installed.
4:11:36 PM: Bundled gems are installed into /opt/build/cache/bundle
4:11:36 PM: Post-install message from i18n:
4:11:36 PM: HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
4:11:36 PM: But that may break your application.
4:11:36 PM: If you are upgrading your Rails application from an older version of Rails:
4:11:36 PM: Please check your Rails app for ‘config.i18n.fallbacks = true’.
4:11:36 PM: If you’re using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
4:11:36 PM: ‘config.i18n.fallbacks = [I18n.default_locale]’.
4:11:36 PM: If not, fallbacks will be broken in your app by I18n 1.1.x.
4:11:36 PM: If you are starting a NEW Rails application, you can ignore this notice.
4:11:36 PM: For more info see:
4:11:36 PM: https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
4:11:36 PM: Post-install message from jekyll:
4:11:36 PM: -------------------------------------------------------------------------------------
4:11:36 PM: Jekyll 4.0 comes with some major changes, notably:
4:11:36 PM: * Our link tag now comes with the relative_url filter incorporated into it.
4:11:36 PM: You should no longer prepend {{ site.baseurl }} to {% link foo.md %}
4:11:36 PM: For further details: https://github.com/jekyll/jekyll/pull/6727
4:11:36 PM: * Our post_url tag now comes with the relative_url filter incorporated into it.
4:11:36 PM: You shouldn’t prepend {{ site.baseurl }} to {% post_url 2019-03-27-hello %}
4:11:36 PM: For further details: https://github.com/jekyll/jekyll/pull/7589
4:11:36 PM: * Support for deprecated configuration options has been removed. We will no longer
4:11:36 PM: output a warning and gracefully assign their values to the newer counterparts
4:11:36 PM: internally.
4:11:36 PM: -------------------------------------------------------------------------------------
4:11:36 PM: Gem bundle installed
4:11:36 PM: Started restoring cached go cache
4:11:36 PM: Finished restoring cached go cache
4:11:36 PM: unset GOOS;
4:11:36 PM: unset GOARCH;
4:11:36 PM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;
4:11:36 PM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";
4:11:36 PM: go version >&2;
4:11:36 PM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
4:11:36 PM: go version go1.12 linux/amd64
4:11:36 PM: Installing missing commands
4:11:36 PM: Verify run directory
4:11:36 PM: Executing user command: ls -l scripts ; sh scripts/bootstrap && sh scripts/build
4:11:36 PM: ls: cannot access ‘scripts’
4:11:36 PM: : No such file or directory
4:11:36 PM: sh: 0: Can’t open scripts/bootstrap
4:11:36 PM: Skipping functions preparation step: no functions directory set
4:11:36 PM: Caching artifacts
4:11:36 PM: Started saving ruby gems
4:11:36 PM: Finished saving ruby gems
4:11:36 PM: Started saving pip cache
4:11:36 PM: Finished saving pip cache
4:11:36 PM: Started saving emacs cask dependencies
4:11:36 PM: Finished saving emacs cask dependencies
4:11:36 PM: Started saving maven dependencies
4:11:36 PM: Finished saving maven dependencies
4:11:36 PM: Started saving boot dependencies
4:11:36 PM: Finished saving boot dependencies
4:11:36 PM: Started saving go dependencies
4:11:36 PM: Finished saving go dependencies
4:11:39 PM: Error running command: Build script returned non-zero exit code: 127
4:11:39 PM: Failing build: Failed to build site
4:11:39 PM: failed during stage ‘building site’: Build script returned non-zero exit code: 127
4:11:39 PM: Finished processing build request in 3m55.624043562s’

it looks like any change to your build command didn’t get saved:

4:11:36 PM: Installing missing commands
4:11:36 PM: Verify run directory
4:11:36 PM: Executing user command: ls -l scripts ; sh scripts/bootstrap && sh scripts/build
4:11:36 PM: ls: cannot access ‘scripts’
4:11:36 PM: : No such file or directory
4:11:36 PM: sh: 0: Can’t open scripts/bootstrap

The build fails because in the build settings you are ask to run the commands bootstrap and build in the scripts directory, but your settings cannot find that folder or command.