Can't connect porkbun domain to netlify. Returning custom_domain owned by another account

Hey everyone!

I’m trying to connect a domain from porkbun to netlify, so a custom domain in addition to .netlify.app. It won’t let me do that and returns only custom_domain is owned by another account. I’ve checked with porkbun and they said that the domain is configured on another netlify account. I haven’t connected a porkbun domain to netlify before.

Hey there, this is happening because the custom domain you’re trying to use already exists on Netlify under a different account.

If you have some idea of who might be using the domain (maybe a previous collaborator or an agency you’ve worked with in the past?), the quickest way to get this resolved is for you to contact that person directly and ask them to remove the domain from their account here:

https://app.netlify.com/sites/SITE-NAME/settings/domain#custom-domains > “Options” dropdown > “Remove domain”

If you’re not sure, please verify domain ownership and let us know by responding here when that’s done. If the verification is successful we can remove the domain from the other account so you can use it on yours.

Hello! Yes I did already add a TXT record on porkbun. Could you see it?
I’ve only bought the domain last month, and have never connected it to any hosting site.

I think we’ll find that it is connected somewhere, once we know the name. Could you tell us the domain name you are trying to use, please, and on which URL in our system you get that error? I am not quite advanced enough in my psychic skills to guess which domain you are using - I think it is probably neither of the ones listed here since those appear to be successfully configured by you already?

https://app.netlify.com/teams/joalroselin/dns

Hi yes, apologies for that.

The domain I’m trying to register is shadodevelopment.co from porkbun.
Been getting that error on https://app.netlify.com/sites/shadodevelopement/settings/domain/setup
It returns custom_domain is owned by another account.

Thanks! You’ve configured that domain on a separate account as I suggested you might have:

https://app.netlify.com/teams/reverse-bot/dns

shows it. You can remove it from there, and recreate it in your current account (the last link I gave), and then you’ll be able to to use it on the site that is in the current account. Note that doing so will likely change the list of nameservers for us so you’ll likely need to update that at porkbun after recreating.

We block cross-account hostname usage which is what’s happening here :wink:

Ah perfect. Sorry for that inconvenience. Was able to add the domain now! Thank you so much.

1 Like