Can't clone from git -error 128 but permissions etc seem ok and no webhooks setup

Hi,
I’m trying to deploy a jekyll site I copied from another of my projects into its own GIT hub repo.
I have all the admin privileges on github and have successfully linked with netlify but when it comes to deploy I get a 128 error.
I’ve checked there are no webhooks and have checked the permissions on github. Ive tried reconnecting with the repository. None of it resolves the problem.

Could you advise what else I can do?

The deploy is here:
https://app.netlify.com/sites/modest-ramanujan-8ed6fe/deploys/5de7b2e7df1d7366097406cb

The log is this:
1:21:43 PM: Build ready to start
1:21:45 PM: build-image version: 9cade8af58c2cf3a17a1e9433d2e979149488837
1:21:45 PM: build-image tag: v3.3.5
1:21:45 PM: buildbot version: eb060c4dc3a8a73f9004f460f04632708166ca51
1:21:45 PM: Fetching cached dependencies
1:21:45 PM: Failed to fetch cache, continuing with build
1:21:45 PM: Starting to prepare the repo for build
1:21:45 PM: No cached dependencies found. Cloning fresh repo
1:21:45 PM: git clone https://github.com/risingphoenixtc/shibashi
1:21:47 PM: Error cloning repository: https://github.com/risingphoenixtc/shibashi
1:21:47 PM: Failing build: Failed to prepare repo
1:21:47 PM: failed during stage ‘preparing repo’: exit status 128
1:21:47 PM: Finished processing build request in 2.000203762s

For that site, there will be no webhooks - it’s our Github app that controls access. Can you check this URL to see if the app is pending approval?

Thank you for the screenshot! I did some research and it looks like this is a large media issue. Take a look at this troubleshooting guide to make sure your configuration is correct: [Common Issue] Troubleshooting your Netlify Large Media Configuration

Let us know if that helps!