Can't clear Cache / Getting error on build

Hi there,

Building a Gridsome site, getting this error when building on Netlify. I can build and develop locally on my machine without and issue.

I don’t know what I’ve to do to force Netlify to rebuild from scratch. I’ve went into a failed deploy, hit the and “Clear Cache and Redeploy” option but to no avail - still getting the error below.

I’m not sure what the discrepancy is between what I have locally Vs what I’m getting on Netlify.

Thanks

11:33:07 PM: Initializing plugins…

11:33:07 PM: Error:

11:33:07 PM: Vue packages version mismatch:

11:33:07 PM: - vue@2.6.10 (/opt/build/repo/node_modules/vue/dist/vue.runtime.common.js)

11:33:07 PM: - vue-template-compiler@2.6.11 (/opt/build/repo/node_modules/vue-template-compiler/package.json)

11:33:07 PM: This may cause things to work incorrectly. Make sure to use the same version for both.

11:33:07 PM: If you are using vue-loader@>=10.0, simply update vue-template-compiler.

11:33:07 PM: If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.

Could you link us to the build logs, Sean? Partial quotes of loglines aren’t the most useful for debugging :slight_smile:

Can I paste in here?

I get what the error is, but not sure how to fix it. The build command works locally so just not sure what’s up.

Can’t paste the logs because I get the error that I can only post 6 links but not sure if this link works
https://app.netlify.com/sites/jamessmith/deploys/5df89fc15e4403bd19ed49ba

Thanks

That link is exactly what I wanted to see, thank you!

The usual advice about conflicting versions is to specify exactly the version you use locally when you don’t have this problem. I assume you can build locally without that problem, right? Since we use npm to install your dependencies, you’ll find the docs on specifying specific versions of packages here: https://docs.npmjs.com/cli/install.html

(though you may get away with editing package.json manually and regenerating package-lock.json if you use that).

I had the same problem!

Make sure you don’t have both a yarn.lock and package-lock.json. Only have ONE of either in your project. I had both and once I removed the yarn.lock it worked.

1 Like

thanks, @elliott! does this help, @sean_smyth?

Thanks!

I’m not sure how I got it fixed in the end. Think I deleted or hard coded the exact version instead and got it to work eventually.

1 Like